summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2017-11-23 20:13:24 +0100
committerThomas Deutschmann <whissi@gentoo.org>2017-11-23 21:48:15 +0100
commit60c241cd6a5dd50626f796a6ecf49c149c68afa4 (patch)
tree13789a470b328d9c8d4c200762455a51b6276200 /sys-apps
parentsys-apps/debianutils: Bump to v4.8.3 (diff)
downloadgentoo-60c241cd6a5dd50626f796a6ecf49c149c68afa4.tar.gz
gentoo-60c241cd6a5dd50626f796a6ecf49c149c68afa4.tar.bz2
gentoo-60c241cd6a5dd50626f796a6ecf49c149c68afa4.zip
sys-apps/irqbalance: Bump to v1.3.0
Package-Manager: Portage-2.3.16, Repoman-2.3.6
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/irqbalance/Manifest1
-rw-r--r--sys-apps/irqbalance/irqbalance-1.3.0.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/sys-apps/irqbalance/Manifest b/sys-apps/irqbalance/Manifest
index 966fd0df5cb8..4af3c2462e20 100644
--- a/sys-apps/irqbalance/Manifest
+++ b/sys-apps/irqbalance/Manifest
@@ -1,3 +1,4 @@
DIST irqbalance-1.0.9.tar.gz 44661 SHA256 f1b8115948bb9f0bc36b9d7143ee8be751a294bc189d311408e753acc37169c3 SHA512 ef3ce9eeec11ec86291e2e3cd701e782ee1fb4ba256e2ea5ea0ea04b373f97ff2eae0a44919127c4dbd7fd805e9e3df3a5e62a3528e4d1c9bbab4db39186b5c5 WHIRLPOOL 7bed3d8dd868b4ad697b997143a59b9101815d0bfc08d1d594248c1fcfeaec22045fbe779605583a89aa7d2c8a54e079317bf8a6e4ef8135fc887e2d1518e706
DIST irqbalance-1.1.0.tar.gz 46742 SHA256 91506e638b03bf27cf5da7dc250d58a753ce8a0288a20265fc7ff0266040706b SHA512 66abf71b87e25df190417afbf9da24d826d817de3c0ebdc686e3ae56ac131b2f9586092ba67e5f9c749cb139fbf2faaa2af2ef30700955a5b347f1964f61bf6b WHIRLPOOL 581cb27ae79648d69200ea2746cabf6dde8c865fd3afc80d87a0c43a150b40b6ad5e22ecd15fef5cc9aff166055b568e6217554c08b4767757f0534a998f35be
DIST irqbalance-1.2.0.tar.gz 55618 SHA256 0efe5d2a0947b54d89c7196a48eca9b3b33c80bc15964e4226a0f7d3fd9535b2 SHA512 02510d0d4dc069570b5f98f3b8191384593a6ed9a88c65c87f5a4261f375c291d95c401b01c03ef9d80834925dd124a088f56ac90c5f290815e26337d4f61c1b WHIRLPOOL 32cdb9d91310012f729f45643b4d105a9840fb88fa55533d48b9a93848a6f3e7f273f9aa9957add8b5ddf4444f5d620da9accb9d79ad237126029176942a37cc
+DIST irqbalance-1.3.0.tar.gz 53225 BLAKE2B 01820d3a3e465896823927dfb43655c4c5efd1eb043a25b438d7b0802c5a6dd7a966825cfb1e71a32d47eca41b72260ba29190e49d9f585c4bf70b676db75c81 SHA512 6328d3e419689192a9dce99ccfd803aaf3ad0e766498e63da1c8c5fbbd7ef669b94fa4102b841fa7aca3729ca595f72c05a0ae4373922fb340b6832648de12c4
diff --git a/sys-apps/irqbalance/irqbalance-1.3.0.ebuild b/sys-apps/irqbalance/irqbalance-1.3.0.ebuild
new file mode 100644
index 000000000000..19cf5f4e8d0b
--- /dev/null
+++ b/sys-apps/irqbalance/irqbalance-1.3.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools systemd linux-info
+
+DESCRIPTION="Distribute hardware interrupts across processors on a multiprocessor system"
+HOMEPAGE="https://github.com/Irqbalance/irqbalance"
+SRC_URI="https://github.com/Irqbalance/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="caps +numa selinux"
+
+CDEPEND="
+ dev-libs/glib:2
+ sys-libs/ncurses:0=[unicode]
+ caps? ( sys-libs/libcap-ng )
+ numa? ( sys-process/numactl )
+"
+DEPEND="${CDEPEND}
+ virtual/pkgconfig
+"
+RDEPEND="${CDEPEND}
+ selinux? ( sec-policy/selinux-irqbalance )
+"
+
+pkg_setup() {
+ CONFIG_CHECK="~PCI_MSI"
+ linux-info_pkg_setup
+}
+
+src_prepare() {
+ # Follow systemd policies
+ # https://wiki.gentoo.org/wiki/Project:Systemd/Ebuild_policy
+ sed \
+ -e 's/ $IRQBALANCE_ARGS//' \
+ -e '/EnvironmentFile/d' \
+ -i misc/irqbalance.service || die
+
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_with caps libcap-ng)
+ $(use_enable numa)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ newinitd "${FILESDIR}"/irqbalance.init.4 irqbalance
+ newconfd "${FILESDIR}"/irqbalance.confd-1 irqbalance
+ systemd_dounit misc/irqbalance.service
+}