summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Tietz <christian.tietz@mailbox.org>2024-10-08 13:12:39 +0200
committerJoonas Niilola <juippis@gentoo.org>2024-11-05 17:13:23 +0200
commit059f192e018a9cd98e445bd7f14f69069e23a2db (patch)
treed273aefe5f3f04be8658b60efe8175cb7ecffe17 /sys-apps
parentapp-pda/usbmuxd: add 1.1.1_p20240915 (diff)
downloadgentoo-059f192e018a9cd98e445bd7f14f69069e23a2db.tar.gz
gentoo-059f192e018a9cd98e445bd7f14f69069e23a2db.tar.bz2
gentoo-059f192e018a9cd98e445bd7f14f69069e23a2db.zip
sys-apps/bleachbit: Bump to 4.6.2, enable py3.13
Tests are finally working with FEATURES=usersandbox. Hence remove the restriction. Signed-off-by: Christian Tietz <christian.tietz@mailbox.org> Closes: https://github.com/gentoo/gentoo/pull/38914 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/bleachbit/Manifest1
-rw-r--r--sys-apps/bleachbit/bleachbit-4.6.2.ebuild88
2 files changed, 89 insertions, 0 deletions
diff --git a/sys-apps/bleachbit/Manifest b/sys-apps/bleachbit/Manifest
index 0c7547edc9a1..f48ac9ddfb9d 100644
--- a/sys-apps/bleachbit/Manifest
+++ b/sys-apps/bleachbit/Manifest
@@ -1 +1,2 @@
DIST bleachbit-4.6.0.tar.bz2 667238 BLAKE2B c150ef9ff5c5f3d8241c5d8a8b8ad5b3f7a23aef24c21ef67a8680f56f3844893fd0e8513f47936ac3a667a15f0d6df2186658be282846309f3ad79f545a380d SHA512 fd0888195bc1fd6dfdc19ca4b35906554e0b6bf22c7f12db01ff8a5790a8a358aedd39f0c0906eb98e67ea5344c655e7f042516cc0c17b59637463d01927a33a
+DIST bleachbit-4.6.2.tar.bz2 672065 BLAKE2B abf475306f6e53610fd53a6b51dcba0d4a7e5d25090a2531bdae5171bedddaad07e348a41fb88242c5282b8ed5c245040ef1272e40b69fe8f67bf34ed970e7ff SHA512 0ef2ea4f02a1e3cfbd7a321c6c5ba36859e7fb9c77e6bb75798a82267481846454625d6807748247966ca345902dcf125efae87c6b55aec35819dfdf9eb4d700
diff --git a/sys-apps/bleachbit/bleachbit-4.6.2.ebuild b/sys-apps/bleachbit/bleachbit-4.6.2.ebuild
new file mode 100644
index 000000000000..446a8b8c1f9e
--- /dev/null
+++ b/sys-apps/bleachbit/bleachbit-4.6.2.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+PYTHON_REQ_USE="sqlite(+)"
+DISTUTILS_SINGLE_IMPL=1
+
+inherit desktop distutils-r1 virtualx
+
+DESCRIPTION="Clean junk to free disk space and to maintain privacy"
+HOMEPAGE="https://www.bleachbit.org"
+SRC_URI="https://download.bleachbit.org/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ ')
+ x11-libs/gtk+:3[introspection]
+"
+BDEPEND="
+ sys-devel/gettext
+ test? (
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]')
+ )
+"
+
+distutils_enable_tests unittest
+
+python_prepare_all() {
+ if use test; then
+ # avoid tests requiring internet access
+ rm tests/Test{Chaff,Update}.py || die
+
+ # fails due to non-existent $HOME/.profile
+ rm tests/TestInit.py || die
+
+ # fails due to permission error on /proc
+ sed -e "s/test_make_self_oom_target_linux(self)/_&/" \
+ -i tests/TestMemory.py || die
+
+ # only applicable to Windows installer
+ rm tests/TestNsisUtilities.py || die
+
+ # these fail on upstream Travis CI as well as on Gentoo
+ sed -e "s/test_notify(self)/_&/" \
+ -i tests/TestGUI.py || die
+
+ sed -e "s/test_get_proc_swaps(self)/_&/" \
+ -i tests/TestMemory.py || die
+ fi
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ emake -C po local
+}
+
+python_test() {
+ virtx emake tests
+}
+
+python_install() {
+ distutils-r1_python_install
+ python_newscript ${PN}.py ${PN}
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ emake -C po DESTDIR="${D}" install
+
+ insinto /usr/share/bleachbit/cleaners
+ doins cleaners/*.xml
+
+ insinto /usr/share/bleachbit
+ doins data/app-menu.ui
+
+ doicon ${PN}.png
+ domenu org.${PN}.BleachBit.desktop
+}