summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2023-02-17 23:08:26 -0500
committerMike Gilbert <floppym@gentoo.org>2023-02-17 23:08:26 -0500
commit6f19e9576402e1b8a083359effd671c9463b6420 (patch)
treeb7fe2d96c9c3e08181cf374b0b4120f7bf66d219 /sys-apps/systemd
parentnet-analyzer/icinga2: drop non-existent boost patch from 2.13.7 (diff)
downloadgentoo-6f19e9576402e1b8a083359effd671c9463b6420.tar.gz
gentoo-6f19e9576402e1b8a083359effd671c9463b6420.tar.bz2
gentoo-6f19e9576402e1b8a083359effd671c9463b6420.zip
sys-apps/systemd: fix install with USE="-sysv-utils"
The runlevel and telinit symlinks are not created when sysv compat is disabled. Closes: https://bugs.gentoo.org/895168 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'sys-apps/systemd')
-rw-r--r--sys-apps/systemd/systemd-253.ebuild4
-rw-r--r--sys-apps/systemd/systemd-9999.ebuild4
2 files changed, 4 insertions, 4 deletions
diff --git a/sys-apps/systemd/systemd-253.ebuild b/sys-apps/systemd/systemd-253.ebuild
index d7c351354825..77c9145b2914 100644
--- a/sys-apps/systemd/systemd-253.ebuild
+++ b/sys-apps/systemd/systemd-253.ebuild
@@ -362,9 +362,9 @@ multilib_src_install_all() {
fi
if ! use sysv-utils; then
- rm "${ED}${rootprefix}/${sbin}"/{halt,init,poweroff,reboot,runlevel,shutdown,telinit} || die
+ rm "${ED}${rootprefix}/${sbin}"/{halt,init,poweroff,reboot,shutdown} || die
rm "${ED}"/usr/share/man/man1/init.1 || die
- rm "${ED}"/usr/share/man/man8/{halt,poweroff,reboot,runlevel,shutdown,telinit}.8 || die
+ rm "${ED}"/usr/share/man/man8/{halt,poweroff,reboot,shutdown}.8 || die
fi
if ! use resolvconf && ! use sysv-utils && use split-usr; then
diff --git a/sys-apps/systemd/systemd-9999.ebuild b/sys-apps/systemd/systemd-9999.ebuild
index d7c351354825..77c9145b2914 100644
--- a/sys-apps/systemd/systemd-9999.ebuild
+++ b/sys-apps/systemd/systemd-9999.ebuild
@@ -362,9 +362,9 @@ multilib_src_install_all() {
fi
if ! use sysv-utils; then
- rm "${ED}${rootprefix}/${sbin}"/{halt,init,poweroff,reboot,runlevel,shutdown,telinit} || die
+ rm "${ED}${rootprefix}/${sbin}"/{halt,init,poweroff,reboot,shutdown} || die
rm "${ED}"/usr/share/man/man1/init.1 || die
- rm "${ED}"/usr/share/man/man8/{halt,poweroff,reboot,runlevel,shutdown,telinit}.8 || die
+ rm "${ED}"/usr/share/man/man8/{halt,poweroff,reboot,shutdown}.8 || die
fi
if ! use resolvconf && ! use sysv-utils && use split-usr; then