summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James (sam_c) <sam@cmpct.info>2020-05-08 03:01:45 +0000
committerThomas Deutschmann <whissi@gentoo.org>2020-05-09 15:48:22 +0200
commit47abea9b09a67cdb87fb316c5bbb131987d6b247 (patch)
tree580a68c14ead342ce98bf489d9aa6ab8593c3df3 /sys-apps/moreutils
parentapp-arch/unrpa: version bump (diff)
downloadgentoo-47abea9b09a67cdb87fb316c5bbb131987d6b247.tar.gz
gentoo-47abea9b09a67cdb87fb316c5bbb131987d6b247.tar.bz2
gentoo-47abea9b09a67cdb87fb316c5bbb131987d6b247.zip
sys-apps/moreutils: Respect compiler environment
Now respects CC as well as CFLAGS. This patch is taken from upstream, not yet in a release. Thanks-to: Agostino Sarubbo <ago@gentoo.org> Closes: https://bugs.gentoo.org/721394 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Sam James (sam_c) <sam@cmpct.info> Closes: https://github.com/gentoo/gentoo/pull/15703 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'sys-apps/moreutils')
-rw-r--r--sys-apps/moreutils/files/moreutils-0.63-respect-env.patch38
-rw-r--r--sys-apps/moreutils/moreutils-0.63.ebuild6
2 files changed, 43 insertions, 1 deletions
diff --git a/sys-apps/moreutils/files/moreutils-0.63-respect-env.patch b/sys-apps/moreutils/files/moreutils-0.63-respect-env.patch
new file mode 100644
index 000000000000..a4091cf599da
--- /dev/null
+++ b/sys-apps/moreutils/files/moreutils-0.63-respect-env.patch
@@ -0,0 +1,38 @@
+From 6c88aaa6b828d7bd7c1dccb3b842594d48c1764c Mon Sep 17 00:00:00 2001
+From: Nicolas Schier <nicolas@fjasle.eu>
+Date: Wed, 27 Nov 2019 21:16:12 +0100
+Subject: is_utf8: allow propagation of compiler and linker flags
+
+Allow propagating compiler and linker flags via overrides of CFLAGS and
+LDFLAGS variables. This allows enabling of hardening flags w/o
+modification of the original Makefile.
+
+Signed-off-by: Nicolas Schier <nicolas@fjasle.eu>
+---
+ is_utf8/Makefile | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/is_utf8/Makefile b/is_utf8/Makefile
+index 4ebf8be..13b1021 100644
+--- a/is_utf8/Makefile
++++ b/is_utf8/Makefile
+@@ -38,13 +38,13 @@ SONAME = $(LINKERNAME).$(VERSION)
+ REALNAME = $(SONAME).$(MINOR).$(RELEASE)
+
+ CC = gcc
+-CFLAGS = -O3 -Wextra -Wall -ansi -Wstrict-prototypes
++CFLAGS ?= -O3 -Wextra -Wall -ansi -Wstrict-prototypes
+
+ $(NAME): $(OBJ)
+- $(CC) $(CFLAGS) -o $(NAME) $(OBJ)
++ $(CC) $(CFLAGS) -o $(NAME) $(OBJ) $(LDFLAGS)
+
+ IS_UTF8_LIB:
+- $(CC) --shared -fPIC $(CFLAGS) $(LIB_SRC) -o $(LINKERNAME)
++ $(CC) --shared -fPIC $(CFLAGS) $(LDFLAGS) $(LIB_SRC) -o $(LINKERNAME)
+
+ all:
+ @make $(NAME)
+--
+cgit v1.2.3
+
diff --git a/sys-apps/moreutils/moreutils-0.63.ebuild b/sys-apps/moreutils/moreutils-0.63.ebuild
index cda09be7454f..3717d9f1f27b 100644
--- a/sys-apps/moreutils/moreutils-0.63.ebuild
+++ b/sys-apps/moreutils/moreutils-0.63.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -28,6 +28,10 @@ DEPEND="
app-text/docbook-xml-dtd:4.4
)"
+PATCHES=(
+ "${FILESDIR}"/${P}-respect-env.patch
+)
+
src_prepare() {
# don't build manpages
if ! use doc ; then