summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-01-05 11:37:14 +0000
committerSam James <sam@gentoo.org>2024-01-05 11:37:14 +0000
commit3f86402f0e09676b5895a33216d6d55b97f33932 (patch)
treeaa0038e961ebf09373636baef40b2f538639a15c /sys-apps/moar
parentnet-irc/znc: fix build with dev-lang/swig-4.2.0 (diff)
downloadgentoo-3f86402f0e09676b5895a33216d6d55b97f33932.tar.gz
gentoo-3f86402f0e09676b5895a33216d6d55b97f33932.tar.bz2
gentoo-3f86402f0e09676b5895a33216d6d55b97f33932.zip
sys-apps/moar: add 1.21.0
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/moar')
-rw-r--r--sys-apps/moar/Manifest2
-rw-r--r--sys-apps/moar/moar-1.21.0.ebuild42
2 files changed, 44 insertions, 0 deletions
diff --git a/sys-apps/moar/Manifest b/sys-apps/moar/Manifest
index c060152c5739..eb0ffc7b2577 100644
--- a/sys-apps/moar/Manifest
+++ b/sys-apps/moar/Manifest
@@ -4,3 +4,5 @@ DIST moar-1.19.0-deps.tar.xz 4893264 BLAKE2B 48ac9d4992c2f6d1aa0f9160bde87bd19d6
DIST moar-1.19.0.tar.gz 2789262 BLAKE2B c30f6b850d5f8998c56b6e0d8a7dbb4eadddf3b54b98904a8b947a0bef4248365091e25c2e956d3a97979b73fb93147d03c9ddda926d67c8db2111a14310bbda SHA512 096b4a6b7f5c714bfbf54bc7d9acc41c74519f360a5366fcc35c5a57b848acff73afd43abb581b9d8e7709855eb8f4d0e3ac3dc7c8b663cc2a59405c066b9652
DIST moar-1.20.0-deps.tar.xz 5100896 BLAKE2B 0be3ca9e2fa88f8d57705f0a79a21088cf1c004740c784b3b8249fde03eae0557bfba97e9e9b5266ae37364e4a686c3e8c5a5556f8ff23f8aef90845f5c891eb SHA512 ec2e5dc41fab5327b7ec25a5aed199712421121fa6f2bed0c76658784ff6260cb6cdba3e478eb3bcdee7ae177acb2be34c35ca01ad7c35f36a1b62c8ff7ad673
DIST moar-1.20.0.tar.gz 2793794 BLAKE2B 10fa1f59a0ec20703d8a478e190188555c668fddb37128dbe4821f47acba035dfa102403d5bb9f4f19af809d2e08fac9ede1e25f1aa333949ffc332ea41c2f7c SHA512 d85eb1b8e9cc01384eca606b0ccf0f76b55dd7d8635a5c4f075dbd5784bebaa4004c379b8a5ba018643d75c088dad83599a7d2faa7c15ff9d008b0c7ade76787
+DIST moar-1.21.0-deps.tar.xz 5100896 BLAKE2B 0be3ca9e2fa88f8d57705f0a79a21088cf1c004740c784b3b8249fde03eae0557bfba97e9e9b5266ae37364e4a686c3e8c5a5556f8ff23f8aef90845f5c891eb SHA512 ec2e5dc41fab5327b7ec25a5aed199712421121fa6f2bed0c76658784ff6260cb6cdba3e478eb3bcdee7ae177acb2be34c35ca01ad7c35f36a1b62c8ff7ad673
+DIST moar-1.21.0.tar.gz 2793970 BLAKE2B 696fc70d7fa05f6e3537272730a7d844c2fd5de94fb2a154906b8102096425c384fd8c54a0f9cdd5bde44b3310119fb5f1e52d98edc10e284c13cdfc44255a6e SHA512 8c91b6f910689496ebe3a5a59325fffc99aeee6808e0c65f01eead47b902481ee02841cdd33a62c90d99d760a2f052df89695b144ed2d7c5446733be7957dcb6
diff --git a/sys-apps/moar/moar-1.21.0.ebuild b/sys-apps/moar/moar-1.21.0.ebuild
new file mode 100644
index 000000000000..b5588a90db7f
--- /dev/null
+++ b/sys-apps/moar/moar-1.21.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="Pager designed to do the right thing without any configuration"
+HOMEPAGE="https://github.com/walles/moar"
+SRC_URI="https://github.com/walles/moar/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}-deps.tar.xz"
+
+LICENSE="BSD-2 BSD MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# moarvm: https://github.com/walles/moar/issues/143
+RDEPEND="!dev-lang/moarvm"
+BDEPEND="
+ test? (
+ app-arch/bzip2
+ app-arch/xz-utils
+ )
+"
+
+src_compile() {
+ # https://github.com/walles/moar/blob/master/build.sh#L28
+ ego build -ldflags="-w -X main.versionString=${PV}" -o moar
+}
+
+src_test() {
+ # From test.sh (we don't run that because it has some linting etc)
+ ego test -timeout 20s ./...
+}
+
+src_install() {
+ dobin moar
+ doman moar.1
+ einstalldocs
+}