summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-07 06:14:20 +0100
committerSam James <sam@gentoo.org>2021-04-13 00:26:27 +0000
commit018b1ccc54ca4e2a498801bc2be6c4d6752244c7 (patch)
tree40670f1f3759e9670ac1e9c7284f1adf731187e4 /sys-apps/ifd-gempc
parentsci-mathematics/calc: call pkg-config via toolchain-funcs.eclass helper (diff)
downloadgentoo-018b1ccc54ca4e2a498801bc2be6c4d6752244c7.tar.gz
gentoo-018b1ccc54ca4e2a498801bc2be6c4d6752244c7.tar.bz2
gentoo-018b1ccc54ca4e2a498801bc2be6c4d6752244c7.zip
sys-apps/ifd-gempc: call pkg-config via toolchain-funcs.eclass helper
This ensures we call the correct pkg-config in e.g. cross. Package-Manager: Portage-3.0.14-prefix, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/ifd-gempc')
-rw-r--r--sys-apps/ifd-gempc/ifd-gempc-1.0.7.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/sys-apps/ifd-gempc/ifd-gempc-1.0.7.ebuild b/sys-apps/ifd-gempc/ifd-gempc-1.0.7.ebuild
index 7e89f583238f..8c3677634c1c 100644
--- a/sys-apps/ifd-gempc/ifd-gempc-1.0.7.ebuild
+++ b/sys-apps/ifd-gempc/ifd-gempc-1.0.7.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -31,7 +31,7 @@ src_install() {
emake CC="$(tc-getCC)" DESTDIR="${D}" install
einstalldocs
- local pcscdir="$(pkg-config --variable=usbdropdir libpcsclite)"
+ local pcscdir="$($(tc-getPKG_CONFIG) --variable=usbdropdir libpcsclite)"
local conf="/etc/reader.conf.d/${PN}.conf"
dodir "$(dirname "${conf}")"
insinto "$(dirname "${conf}")"