summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-05-14 01:19:15 +0100
committerSam James <sam@gentoo.org>2024-05-14 01:19:45 +0100
commitf20e70fedc15b1474092afbc9c67574b1ca807ba (patch)
treed7e5806e9082481a13825946884b4bc3310f60ee /sys-apps/gentoo-functions
parentsci-libs/gdal: Fix build with Poppler 24.05 (diff)
downloadgentoo-f20e70fedc15b1474092afbc9c67574b1ca807ba.tar.gz
gentoo-f20e70fedc15b1474092afbc9c67574b1ca807ba.tar.bz2
gentoo-f20e70fedc15b1474092afbc9c67574b1ca807ba.zip
sys-apps/gentoo-functions: add 1.1 (masked still, but not for long)
Kerin Millar (5): ecma48-cpr: Use designated initialisers for legibility Unify the brace style Render _update_winsize() immune to the prevailing value of IFS Don't check for Emacs every time _eend() is called Simplify _eprint() and _eend() behaviour markedly Sam James (6): meson.build: add TODO wrt cleaning up functions.sh template functions.sh.in: fix typo Cleanup functions.sh.in template Drop ecma48-cpr meson.build: fix tests meson.build: prepare for gentoo-functions-1.1 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/gentoo-functions')
-rw-r--r--sys-apps/gentoo-functions/Manifest1
-rw-r--r--sys-apps/gentoo-functions/gentoo-functions-1.1.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/sys-apps/gentoo-functions/Manifest b/sys-apps/gentoo-functions/Manifest
index 28260cfbf702..443a77ed9e3d 100644
--- a/sys-apps/gentoo-functions/Manifest
+++ b/sys-apps/gentoo-functions/Manifest
@@ -1,2 +1,3 @@
DIST gentoo-functions-0.19.tar.bz2 12079 BLAKE2B be0a3a54d4dee1755866047b670a69cd6fec368239123c3f0c08180b79a33c20147bca0e35e568faef6877513551e731bdf0c181aeb0460f6574d2d708219373 SHA512 2674d3fe5724cc6d685ae58bf0ee33f4a1bdba2c5e5809cfb193fd0a710d4678c2d9392c2c62d2321cf455f524950266dc1629ab684fe46632d179e539d5a39e
DIST gentoo-functions-1.0.tar.bz2 18066 BLAKE2B a843de65d5d8f93396713dd5c80377dad478482d5749736ec3a08e0d0cc40f1a2ce5c967282b8060452d73f6377590f06e5c2a12cdfc753e7f6a18754cde4997 SHA512 057a7159a613108710a40f2ca54403adf64ab9649732be49d3a72314e2ca3c65d7a9093168e26ec12814203e1fe14cc1fc5cf2cefa2f923ec8bb714972d20f55
+DIST gentoo-functions-1.1.tar.bz2 14277 BLAKE2B 150b5481668b766a6d1c3d8fff331df66c352d03971adaf7cb0332aef32cd881bd49a64165dc5070f24033f6b0a3d91c07d2e762b4d915fb7f137b8269def76a SHA512 1345f5b87f70422ff9c8577e75743fdc9ae871be4605b7983b602918bd352a396cfd2bb9e34cb1586b951bbca7264967a5412b9c89646bdcb60646b501f946e8
diff --git a/sys-apps/gentoo-functions/gentoo-functions-1.1.ebuild b/sys-apps/gentoo-functions/gentoo-functions-1.1.ebuild
new file mode 100644
index 000000000000..8df3a1e88bad
--- /dev/null
+++ b/sys-apps/gentoo-functions/gentoo-functions-1.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2014-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/gentoo-functions.git"
+else
+ SRC_URI="https://gitweb.gentoo.org/proj/gentoo-functions.git/snapshot/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+fi
+
+inherit meson
+
+DESCRIPTION="Base functions required by all Gentoo systems"
+HOMEPAGE="https://gitweb.gentoo.org/proj/gentoo-functions.git"
+
+LICENSE="GPL-2 public-domain"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# Specifically needs GNU find, as well.
+RDEPEND=">=sys-apps/findutils-4.9"
+
+src_configure() {
+ local emesonargs=(
+ # Deliberately avoid /usr as consumers assume we're at /lib/gentoo.
+ --prefix="${EPREFIX:-/}"
+ --mandir="${EPREFIX}/usr/share/man"
+ $(meson_use test tests)
+ )
+
+ meson_src_configure
+}