summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2023-12-29 20:50:04 -0500
committerRick Farina <zerochaos@gentoo.org>2023-12-29 20:51:32 -0500
commitce0d6536cc59402682b39018e70014612c729148 (patch)
treef84050929511a47b9b1f958317e09b208f21ef1b /sys-apps/fwts
parentmedia-gfx/xfig: Stabilize 3.2.9 ppc64, #916385 (diff)
downloadgentoo-ce0d6536cc59402682b39018e70014612c729148.tar.gz
gentoo-ce0d6536cc59402682b39018e70014612c729148.tar.bz2
gentoo-ce0d6536cc59402682b39018e70014612c729148.zip
sys-apps/fwts: add 23.11.00
Reported build issues upstream, committing ebuild without keywords since it doesn't build but it's better than the version in the tree. Removed upstreamed patch https://patchwork.ozlabs.org/project/fwts/patch/20220531074030.8151-1-ivan.hu@canonical.com/ Signed-off-by: Rick Farina <zerochaos@gentoo.org>
Diffstat (limited to 'sys-apps/fwts')
-rw-r--r--sys-apps/fwts/Manifest1
-rw-r--r--sys-apps/fwts/fwts-23.11.00.ebuild54
-rw-r--r--sys-apps/fwts/metadata.xml1
3 files changed, 56 insertions, 0 deletions
diff --git a/sys-apps/fwts/Manifest b/sys-apps/fwts/Manifest
index 917680514886..a76175cb518d 100644
--- a/sys-apps/fwts/Manifest
+++ b/sys-apps/fwts/Manifest
@@ -1 +1,2 @@
+DIST fwts-23.11.00.tar.gz 3962015 BLAKE2B 33afde1548629fda784b301b42c7ca3ae4c17deb86909b0534f839ba369dae74fc0f7a3c2f4b50a2ad101da9debcb522326b649ba811b7f13c8cf7b79d552f26 SHA512 df72a799a7e317f53bd43c35953a8955aa194a93596eacab43300717d87dac4aef3bdfcdb1b2028c0177a3f40577dd0e4a55e5c3269e37190a47684df928b092
DIST fwts_22.03.00.orig.tar.gz 3900335 BLAKE2B 2e36392f69140b1a2d3b77cc8d57740f66ea016063644916e69bb738e20191a780a9d2ed275cfd8b871ad8c3455f96c8ae26ab7c1574c0cc8efdbbb20f4cc785 SHA512 88f183293da4f6ebc1cefc382c9b5e1b378ac7d03e0c577937db89be9e8417e0ffdf0952cdffda57ac21787c3fe02c5254ec7ce61e100e78555ffa92d6a30dc2
diff --git a/sys-apps/fwts/fwts-23.11.00.ebuild b/sys-apps/fwts/fwts-23.11.00.ebuild
new file mode 100644
index 000000000000..fc9c4f7e275a
--- /dev/null
+++ b/sys-apps/fwts/fwts-23.11.00.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Firmware Test Suite"
+HOMEPAGE="https://wiki.ubuntu.com/Kernel/Reference/fwts https://github.com/fwts/fwts"
+SRC_URI="https://github.com/fwts/fwts/archive/refs/tags/V${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+#https://github.com/fwts/fwts/issues/13
+#KEYWORDS="~amd64"
+
+DEPEND="dev-libs/glib:2
+ >=dev-libs/json-c-0.10-r1
+ dev-libs/libbsd
+ dev-libs/libpcre
+ sys-apps/dmidecode
+ sys-apps/dtc
+ sys-apps/pciutils
+ sys-power/iasl
+ sys-power/pmtools
+"
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-22.03.00-werror.patch"
+)
+
+src_prepare() {
+ default
+
+ sed -e 's:/usr/bin/lspci:'$(type -p lspci)':' \
+ -e 's:/usr/sbin/dmidecode:'$(type -p dmidecode)':' \
+ -e 's:/usr/bin/iasl:'$(type -p iasl)':' \
+ -i src/lib/include/fwts_binpaths.h || die
+
+ eautoreconf
+}
+
+src_compile() {
+ # https://github.com/fwts/fwts/issues/7
+ emake -j1 --shuffle=none
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+}
diff --git a/sys-apps/fwts/metadata.xml b/sys-apps/fwts/metadata.xml
index 12200cbd68b6..4d1285fa19bc 100644
--- a/sys-apps/fwts/metadata.xml
+++ b/sys-apps/fwts/metadata.xml
@@ -4,5 +4,6 @@
<!-- maintainer-needed -->
<upstream>
<remote-id type="launchpad">ubuntu</remote-id>
+ <remote-id type="github">fwts/fwts</remote-id>
</upstream>
</pkgmetadata>