summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2021-07-09 10:07:07 +0200
committerLars Wendler <polynomial-c@gentoo.org>2021-07-09 10:08:06 +0200
commit01146fcd088691653917a1f5a943e3f1f0a83d24 (patch)
treedab628acfc6bb692080428bd36c603e90cfd75e3 /sys-apps/ethtool/ethtool-5.13.ebuild
parentdev-ruby/hipchat: allow all mimemagic slots (diff)
downloadgentoo-01146fcd088691653917a1f5a943e3f1f0a83d24.tar.gz
gentoo-01146fcd088691653917a1f5a943e3f1f0a83d24.tar.bz2
gentoo-01146fcd088691653917a1f5a943e3f1f0a83d24.zip
sys-apps/ethtool: Bump to version 5.13
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-apps/ethtool/ethtool-5.13.ebuild')
-rw-r--r--sys-apps/ethtool/ethtool-5.13.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/sys-apps/ethtool/ethtool-5.13.ebuild b/sys-apps/ethtool/ethtool-5.13.ebuild
new file mode 100644
index 000000000000..4ddb6be7e3ff
--- /dev/null
+++ b/sys-apps/ethtool/ethtool-5.13.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Utility for examining and tuning ethernet-based network interfaces"
+HOMEPAGE="https://www.kernel.org/pub/software/network/ethtool/"
+SRC_URI="https://www.kernel.org/pub/software/network/ethtool/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="+netlink"
+
+BDEPEND="app-arch/xz-utils"
+RDEPEND="netlink? ( net-libs/libmnl )"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ econf $(use_enable netlink)
+}