summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2024-07-03 21:39:36 -0400
committerMike Gilbert <floppym@gentoo.org>2024-07-03 21:41:45 -0400
commitecfd5d6b7c9ffe7370e4901d1bdc7a34cc30314d (patch)
treeeeb1c3a9abf120ebcb15c67b66cff3c3540cab96 /sys-apps/busybox
parentapp-admin/ulogd: fix compat w/ newer logrotate (specify group name) (diff)
downloadgentoo-ecfd5d6b7c9ffe7370e4901d1bdc7a34cc30314d.tar.gz
gentoo-ecfd5d6b7c9ffe7370e4901d1bdc7a34cc30314d.tar.bz2
gentoo-ecfd5d6b7c9ffe7370e4901d1bdc7a34cc30314d.zip
sys-apps/busybox: move KBUILD_OUTPUT and SKIP_STRIP
Set/unset these before we call bbmake for the first time. Thanks to Peter Levine for the diagnosis. Closes: https://bugs.gentoo.org/932445 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'sys-apps/busybox')
-rw-r--r--sys-apps/busybox/busybox-1.36.1-r1.ebuild6
-rw-r--r--sys-apps/busybox/busybox-1.36.1-r2.ebuild6
-rw-r--r--sys-apps/busybox/busybox-9999.ebuild6
3 files changed, 9 insertions, 9 deletions
diff --git a/sys-apps/busybox/busybox-1.36.1-r1.ebuild b/sys-apps/busybox/busybox-1.36.1-r1.ebuild
index 98369ddbf32e..19f861692f33 100644
--- a/sys-apps/busybox/busybox-1.36.1-r1.ebuild
+++ b/sys-apps/busybox/busybox-1.36.1-r1.ebuild
@@ -116,6 +116,9 @@ bbmake() {
}
src_configure() {
+ unset KBUILD_OUTPUT #88088
+ export SKIP_STRIP=y
+
tc-export AR CC BUILD_CC PKG_CONFIG
tc-is-cross-compiler || BUILD_CFLAGS=${CFLAGS}
@@ -236,9 +239,6 @@ src_configure() {
}
src_compile() {
- unset KBUILD_OUTPUT #88088
- export SKIP_STRIP=y
-
bbmake busybox
# bug #701512
diff --git a/sys-apps/busybox/busybox-1.36.1-r2.ebuild b/sys-apps/busybox/busybox-1.36.1-r2.ebuild
index fc700c3b31e4..cd06d97bc0d3 100644
--- a/sys-apps/busybox/busybox-1.36.1-r2.ebuild
+++ b/sys-apps/busybox/busybox-1.36.1-r2.ebuild
@@ -117,6 +117,9 @@ bbmake() {
}
src_configure() {
+ unset KBUILD_OUTPUT #88088
+ export SKIP_STRIP=y
+
tc-export AR CC BUILD_CC PKG_CONFIG
tc-is-cross-compiler || BUILD_CFLAGS=${CFLAGS}
@@ -237,9 +240,6 @@ src_configure() {
}
src_compile() {
- unset KBUILD_OUTPUT #88088
- export SKIP_STRIP=y
-
bbmake busybox
# bug #701512
diff --git a/sys-apps/busybox/busybox-9999.ebuild b/sys-apps/busybox/busybox-9999.ebuild
index fc700c3b31e4..cd06d97bc0d3 100644
--- a/sys-apps/busybox/busybox-9999.ebuild
+++ b/sys-apps/busybox/busybox-9999.ebuild
@@ -117,6 +117,9 @@ bbmake() {
}
src_configure() {
+ unset KBUILD_OUTPUT #88088
+ export SKIP_STRIP=y
+
tc-export AR CC BUILD_CC PKG_CONFIG
tc-is-cross-compiler || BUILD_CFLAGS=${CFLAGS}
@@ -237,9 +240,6 @@ src_configure() {
}
src_compile() {
- unset KBUILD_OUTPUT #88088
- export SKIP_STRIP=y
-
bbmake busybox
# bug #701512