summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2019-06-23 06:51:00 -0400
committerAaron W. Swenson <titanofold@gentoo.org>2019-06-23 06:51:05 -0400
commit2f0e7d25118845594d6ed87f8e5f257631ea7aab (patch)
treec99fa94c453815f356cb284dacf372f38ab7415b /sys-apps/ack
parentsys-auth/pambase: change homepage to github (diff)
downloadgentoo-2f0e7d25118845594d6ed87f8e5f257631ea7aab.tar.gz
gentoo-2f0e7d25118845594d6ed87f8e5f257631ea7aab.tar.bz2
gentoo-2f0e7d25118845594d6ed87f8e5f257631ea7aab.zip
sys-apps/ack: Bump to 3.0.0
Package-Manager: Portage-2.3.62, Repoman-2.3.11 Signed-off-by: Aaron W. Swenson <titanofold@gentoo.org>
Diffstat (limited to 'sys-apps/ack')
-rw-r--r--sys-apps/ack/Manifest1
-rw-r--r--sys-apps/ack/ack-3.0.0.ebuild28
-rw-r--r--sys-apps/ack/files/ack-3.0.0-gentoo.patch23
3 files changed, 52 insertions, 0 deletions
diff --git a/sys-apps/ack/Manifest b/sys-apps/ack/Manifest
index c038ef88a852..3f16b4177f90 100644
--- a/sys-apps/ack/Manifest
+++ b/sys-apps/ack/Manifest
@@ -2,3 +2,4 @@ DIST ack-2.18.tar.gz 232279 BLAKE2B dc7c347eee2be367a2b1bd4839719661f1c0de68bd3f
DIST ack-2.22.tar.gz 250275 BLAKE2B 52cafe63b6f4aa50feb3a8d68141662fbbec7a73d31b2f06d3d63c7efb9ba681214ac20fbfd299f680d4e3758eaed8b4b9b3cd697f38977f2e0657a90dc0478a SHA512 d0073c424d861f2cfdc2ce8c0dfa149620803b4c30adb6c6f4f8896277ac89bb6d97d3e8e9bdfd1202f95808bd387b2e3a8353a3e7d204cdd61eb9cafde48303
DIST ack-2.24.tar.gz 261289 BLAKE2B 0ec1e280abbcd2319bcc9f0cd83c73f97decd6698928fd1b8be310fe9a81839e02390bf4baabef402cb8603eceb5c005c4c8a1f71a60273cef21e3366efff11c SHA512 3778c1d70ae08852eff9d8dd75688713bbb8dd15d4e72c07a3829cf362c7bfeba1175275e66cfe99265ba28777b6833734ebd6debb4ec4ec79df06ac46a79c24
DIST ack-2.28.tar.gz 263072 BLAKE2B 5bb5c41165dff9140959d7680a79def77b8d95106ee3b70b842579f082c8bf4ca978d05d1128722bd22456be94703ea1e44de1a87071317c46a4fb80d0cab6cb SHA512 04ad599b644ff2cb07abe687f99286f14ddd0628458ac88dea0124d8487792824af470a60718c21be5930083830b463385e13927cc4a680ff34be133256c0f8a
+DIST ack-v3.0.0.tar.gz 238646 BLAKE2B 679cf84c7dffd6f1ec3881de465cbdbebf9ec8958a6e36c5265d11492d84990a67b34af0e42041280b9a9ab6c57d951a2c73ba5b6fe07c9ac8774bac445c10fd SHA512 2bf4e9719d8a5ec56c9d31acbcff647aece7b52ff7ffaacbfec56e59e30efb9ca7397fa379e13a9113a27abe47053261b9adb641b995d3e8579d459c0483fb45
diff --git a/sys-apps/ack/ack-3.0.0.ebuild b/sys-apps/ack/ack-3.0.0.ebuild
new file mode 100644
index 000000000000..28e686602b8c
--- /dev/null
+++ b/sys-apps/ack/ack-3.0.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+DIST_AUTHOR=PETDANCE
+DIST_VERSION="v${PV}"
+inherit perl-module
+
+DESCRIPTION="ack is a tool like grep, optimized for programmers"
+HOMEPAGE="https://beyondgrep.com"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux ~x86-macos"
+IUSE="test"
+
+RDEPEND=">=dev-perl/File-Next-1.160.0"
+DEPEND="${RDEPEND}
+ test? ( dev-perl/IO-Tty )"
+
+PATCHES=( "${FILESDIR}"/${PN}-3.0.0-gentoo.patch )
+
+src_test() {
+ # Tests fail when run in parallel and if dev-perl/IO-Tty is installed
+ # which enables interactive tests that need to read from stdin. If IO-Tty
+ # is not installed the related tests are skipped.
+ MAKEOPTS+=" -j1" perl-module_src_test
+}
diff --git a/sys-apps/ack/files/ack-3.0.0-gentoo.patch b/sys-apps/ack/files/ack-3.0.0-gentoo.patch
new file mode 100644
index 000000000000..09972519ed89
--- /dev/null
+++ b/sys-apps/ack/files/ack-3.0.0-gentoo.patch
@@ -0,0 +1,23 @@
+--- a/lib/App/Ack/ConfigDefault.pm
++++ b/lib/App/Ack/ConfigDefault.pm
+@@ -263,6 +263,10 @@
+ # http://en.wikipedia.org/wiki/Fortran
+ --type-add=fortran:ext:f,f77,f90,f95,f03,for,ftn,fpp
+
++# Gentoo
++# https://www.gentoo.org/
++--type-add=gentoo:ext:ebuild,eclass
++
+ # Go
+ # http://golang.org/
+ --type-add=go:ext:go
+--- a/t/ack-filetypes.t
++++ b/t/ack-filetypes.t
+@@ -26,6 +26,7 @@
+ elisp
+ erlang
+ fortran
++gentoo
+ go
+ groovy
+ gsp