summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-visualization/epix/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-visualization/epix/files')
-rw-r--r--sci-visualization/epix/files/50epix-gentoo.el8
-rw-r--r--sci-visualization/epix/files/epix-1.2.10-autotools.patch85
-rw-r--r--sci-visualization/epix/files/epix-1.2.6-automake.patch27
-rw-r--r--sci-visualization/epix/files/epix-1.2.6-doc-gentoo.patch74
-rw-r--r--sci-visualization/epix/files/epix-1.2.9-autotools.patch94
5 files changed, 288 insertions, 0 deletions
diff --git a/sci-visualization/epix/files/50epix-gentoo.el b/sci-visualization/epix/files/50epix-gentoo.el
new file mode 100644
index 000000000000..eb5d8eb13371
--- /dev/null
+++ b/sci-visualization/epix/files/50epix-gentoo.el
@@ -0,0 +1,8 @@
+;; sci-visualisation/epix site init file
+
+(add-to-list 'load-path "@SITELISP@")
+
+(autoload 'epix-mode "epix" "ePiX editing mode" t)
+(autoload 'flix-mode "epix" "flix editing mode" t)
+(add-to-list 'auto-mode-alist '("\\.xp\\'" . epix-mode))
+(add-to-list 'auto-mode-alist '("\\.flx\\'" . flix-mode))
diff --git a/sci-visualization/epix/files/epix-1.2.10-autotools.patch b/sci-visualization/epix/files/epix-1.2.10-autotools.patch
new file mode 100644
index 000000000000..03f93cd26c9c
--- /dev/null
+++ b/sci-visualization/epix/files/epix-1.2.10-autotools.patch
@@ -0,0 +1,85 @@
+diff -Nur epix-1.2.10.orig/configure.ac epix-1.2.10/configure.ac
+--- epix-1.2.10.orig/configure.ac 2012-11-29 21:04:20.411280150 -0800
++++ epix-1.2.10/configure.ac 2012-11-29 21:14:00.462163755 -0800
+@@ -9,6 +9,7 @@
+ dnl Checks for programs.
+ AC_PROG_CXX
+ AC_PROG_LN_S
++AM_PROG_AR
+ AC_PROG_RANLIB
+ AC_PROG_MAKE_SET
+ AC_PROG_INSTALL
+diff -Nur epix-1.2.10.orig/doc/Makefile.am epix-1.2.10/doc/Makefile.am
+--- epix-1.2.10.orig/doc/Makefile.am 2012-11-29 21:04:20.414280167 -0800
++++ epix-1.2.10/doc/Makefile.am 2012-11-29 21:04:30.491329674 -0800
+@@ -1,7 +1,7 @@
+ # Makefile.am for ePiX v1.x "doc" directory
+ #
+
+-EPIXFLAGS = --no-defaults -I.. -L.. -lepix -v
++EPIXFLAGS = --no-defaults -I.. -L.. -lepix -q
+
+ %.eepic: %.xp
+ ../epix-local $(EPIXFLAGS) $<
+@@ -13,13 +13,13 @@
+ CLEANFILES = *~ *.aux *.dvi *.log *.out *.toc \
+ *.fdx *.flg *.fnd *.idx *.ilg *.ind \
+ epix.info epix.info.bz2 manual_src.tar manual.pdf manual.ps \
+- manual_src.tar.gz manual.pdf.gz manual.ps.gz manual-stamp
++ manual_src.tar.gz manual.pdf manual.ps.gz manual-stamp
+
+ MAINTAINERCLEANFILES = *.eepic *.aux *.dvi *.log *.out *.toc \
+ *.fdx *.flg *.fnd *.idx *.ilg *.ind
+
+ ## Targets ##
+-doc_DATA = manual.pdf.gz manual.ps.gz manual_src.tar.gz
++doc_DATA =
+
+ info_TEXINFOS = epix.texi
+
+@@ -42,8 +42,7 @@
+ gzip -9 -c manual.ps > manual.ps.gz
+
+ #PDF
+-manual.pdf.gz: manual-stamp
+- gzip -9 -c manual.pdf > manual.pdf.gz
++manual.pdf: manual-stamp
+
+ epix.info: manual-stamp epix.texi
+ makeinfo epix.texi 2>&1 >/dev/null
+diff -Nur epix-1.2.10.orig/Makefile.am epix-1.2.10/Makefile.am
+--- epix-1.2.10.orig/Makefile.am 2012-11-29 21:04:20.415280173 -0800
++++ epix-1.2.10/Makefile.am 2012-11-29 21:05:52.489734436 -0800
+@@ -56,7 +56,7 @@
+
+ EPIX_CONFFILES = bash_completions $(EPIX_EL)
+
+-EPIX_NOTEFILES = AUTHORS BUGS ChangeLog COPYING INSTALL NEWS POST-INSTALL \
++EPIX_NOTEFILES = AUTHORS BUGS ChangeLog NEWS POST-INSTALL \
+ README THANKS VERSION
+
+ EXTRA_DIST = $(bin_SCRIPTS) $(man_MANS) $(EPIX_CONFFILES) $(EPIX_NOTEFILES) \
+@@ -85,11 +85,6 @@
+ -e 's%@RUNTIME_COMPILER\@%$(CXX)%;' $< > $@-local
+ chmod a+x $@ $@-local
+
+-# libepix.a
+-libepix.a: $(libepix_a_OBJECTS)
+- ar -ru libepix.a $(libepix_a_OBJECTS)
+- $(RANLIB) libepix.a
+-
+ # object file dependencies
+ $(libepix_a_LIBADD): %.o: %.cc %.h
+
+diff -Nur epix-1.2.10.orig/samples/Makefile.am epix-1.2.10/samples/Makefile.am
+--- epix-1.2.10.orig/samples/Makefile.am 2012-11-29 21:04:20.416280179 -0800
++++ epix-1.2.10/samples/Makefile.am 2012-11-29 21:04:30.491329674 -0800
+@@ -7,7 +7,7 @@
+ CLEANFILES = *~ *.eepic *.eps sample_src.tar sample_src.tar.gz sample-stamp
+
+ ## Targets ##
+-doc_DATA = sample_src.tar.gz
++doc_DATA =
+
+
+ # tar up tex, xp, and eepic files
diff --git a/sci-visualization/epix/files/epix-1.2.6-automake.patch b/sci-visualization/epix/files/epix-1.2.6-automake.patch
new file mode 100644
index 000000000000..80e9fb2b3566
--- /dev/null
+++ b/sci-visualization/epix/files/epix-1.2.6-automake.patch
@@ -0,0 +1,27 @@
+ Makefile.am | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index 366c582..2edbfe0 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -15,7 +15,7 @@ SUBDIRS = . samples doc
+ bin_SCRIPTS = epix elaps flix laps
+
+ pkglib_LIBRARIES = libepix.a
+-pkglib_DATA = epix-lib.sh
++pkgdata_DATA = epix-lib.sh
+ include_HEADERS = epix.h
+
+ libepix_a_CXXSOURCES = active_screen.cc affine.cc angle_units.cc \
+@@ -107,8 +107,8 @@ install-data-local:
+ $(INSTALL_DATA) $(EPIX_CONFFILES) $(DESTDIR)$(docdir)/config
+
+ # This is being installed by install-exec, but should not be executable
+-install-exec-local: install-pkglibDATA
+- chmod a-x $(DESTDIR)$(pkglibdir)/epix-lib.sh
++install-exec-local: install-pkgdataDATA
++ chmod a-x $(DESTDIR)$(pkgdatadir)/epix-lib.sh
+
+ uninstall-local:
+ -rm -rf $(DESTDIR)$(docdir)/notes $(DESTDIR)$(docdir)/config
diff --git a/sci-visualization/epix/files/epix-1.2.6-doc-gentoo.patch b/sci-visualization/epix/files/epix-1.2.6-doc-gentoo.patch
new file mode 100644
index 000000000000..ce0ec81fb71a
--- /dev/null
+++ b/sci-visualization/epix/files/epix-1.2.6-doc-gentoo.patch
@@ -0,0 +1,74 @@
+diff -Nura epix-1.2.6.orig/doc/Makefile.am epix-1.2.6/doc/Makefile.am
+--- epix-1.2.6.orig/doc/Makefile.am 2009-02-16 02:16:58.000000000 +0000
++++ epix-1.2.6/doc/Makefile.am 2009-04-13 18:11:18.310702097 +0100
+@@ -1,7 +1,7 @@
+ # Makefile.am for ePiX v1.x "doc" directory
+ #
+
+-EPIXFLAGS = --no-defaults -I.. -L.. -lepix -v
++EPIXFLAGS = --no-defaults -I.. -L.. -lepix -q
+
+ %.eepic: %.xp
+ ../epix-local $(EPIXFLAGS) $<
+@@ -13,13 +13,13 @@
+ CLEANFILES = *~ *.aux *.dvi *.log *.out *.toc \
+ *.fdx *.flg *.fnd *.idx *.ilg *.ind \
+ epix.info epix.info.bz2 manual_src.tar manual.pdf manual.ps \
+- manual_src.tar.gz manual.pdf.gz manual.ps.gz manual-stamp
++ manual_src.tar.gz manual.pdf manual.ps.gz manual-stamp
+
+ MAINTAINERCLEANFILES = *.eepic *.aux *.dvi *.log *.out *.toc \
+ *.fdx *.flg *.fnd *.idx *.ilg *.ind
+
+ ## Targets ##
+-doc_DATA = manual.pdf.gz manual.ps.gz manual_src.tar.gz
++doc_DATA =
+
+ info_TEXINFOS = epix.texi
+
+@@ -42,8 +42,7 @@
+ gzip -9 -c manual.ps > manual.ps.gz
+
+ #PDF
+-manual.pdf.gz: manual-stamp
+- gzip -9 -c manual.pdf > manual.pdf.gz
++manual.pdf: manual-stamp
+
+ epix.info: manual-stamp epix.texi
+ makeinfo epix.texi 2>&1 >/dev/null
+diff -Nura epix-1.2.6.orig/Makefile.am epix-1.2.6/Makefile.am
+--- epix-1.2.6.orig/Makefile.am 2008-07-01 03:48:22.000000000 +0100
++++ epix-1.2.6/Makefile.am 2009-04-13 17:58:15.273913638 +0100
+@@ -56,7 +56,7 @@
+
+ EPIX_CONFFILES = bash_completions $(EPIX_EL)
+
+-EPIX_NOTEFILES = AUTHORS BUGS ChangeLog COPYING INSTALL NEWS POST-INSTALL \
++EPIX_NOTEFILES = AUTHORS BUGS ChangeLog NEWS POST-INSTALL \
+ README THANKS VERSION
+
+ EXTRA_DIST = $(bin_SCRIPTS) $(man_MANS) $(EPIX_CONFFILES) $(EPIX_NOTEFILES) \
+@@ -102,9 +102,8 @@
+ # Extra things to install
+ install-data-local:
+ @echo; echo "Installing notes and configuration files"
+- ./mkinstalldirs $(DESTDIR)$(docdir)/notes $(DESTDIR)$(docdir)/config
+- $(INSTALL_DATA) $(EPIX_NOTEFILES) $(DESTDIR)$(docdir)/notes
+- $(INSTALL_DATA) $(EPIX_CONFFILES) $(DESTDIR)$(docdir)/config
++ ./mkinstalldirs $(DESTDIR)$(docdir)
++ $(INSTALL_DATA) $(EPIX_NOTEFILES) $(DESTDIR)$(docdir)
+
+ # This is being installed by install-exec, but should not be executable
+ install-exec-local: install-pkglibDATA
+diff -Nura epix-1.2.6.orig/samples/Makefile.am epix-1.2.6/samples/Makefile.am
+--- epix-1.2.6.orig/samples/Makefile.am 2008-07-01 03:55:14.000000000 +0100
++++ epix-1.2.6/samples/Makefile.am 2009-04-13 18:11:31.096963306 +0100
+@@ -7,7 +7,7 @@
+ CLEANFILES = *~ *.eepic *.eps sample_src.tar sample_src.tar.gz sample-stamp
+
+ ## Targets ##
+-doc_DATA = sample_src.tar.gz
++doc_DATA =
+
+
+ # tar up tex, xp, and eepic files
diff --git a/sci-visualization/epix/files/epix-1.2.9-autotools.patch b/sci-visualization/epix/files/epix-1.2.9-autotools.patch
new file mode 100644
index 000000000000..ebceb98dc309
--- /dev/null
+++ b/sci-visualization/epix/files/epix-1.2.9-autotools.patch
@@ -0,0 +1,94 @@
+* disable automatic install of doc and examples
+* update for newer autotools
+Patch by Sebastien Fabbro
+
+diff -Nur epix-1.2.9.orig/doc/Makefile.am epix-1.2.9/doc/Makefile.am
+--- epix-1.2.9.orig/doc/Makefile.am 2009-02-16 02:16:58.000000000 +0000
++++ epix-1.2.9/doc/Makefile.am 2012-02-19 16:46:02.123782104 +0000
+@@ -1,7 +1,7 @@
+ # Makefile.am for ePiX v1.x "doc" directory
+ #
+
+-EPIXFLAGS = --no-defaults -I.. -L.. -lepix -v
++EPIXFLAGS = --no-defaults -I.. -L.. -lepix -q
+
+ %.eepic: %.xp
+ ../epix-local $(EPIXFLAGS) $<
+@@ -13,13 +13,13 @@
+ CLEANFILES = *~ *.aux *.dvi *.log *.out *.toc \
+ *.fdx *.flg *.fnd *.idx *.ilg *.ind \
+ epix.info epix.info.bz2 manual_src.tar manual.pdf manual.ps \
+- manual_src.tar.gz manual.pdf.gz manual.ps.gz manual-stamp
++ manual_src.tar.gz manual.pdf manual.ps.gz manual-stamp
+
+ MAINTAINERCLEANFILES = *.eepic *.aux *.dvi *.log *.out *.toc \
+ *.fdx *.flg *.fnd *.idx *.ilg *.ind
+
+ ## Targets ##
+-doc_DATA = manual.pdf.gz manual.ps.gz manual_src.tar.gz
++doc_DATA =
+
+ info_TEXINFOS = epix.texi
+
+@@ -42,8 +42,7 @@
+ gzip -9 -c manual.ps > manual.ps.gz
+
+ #PDF
+-manual.pdf.gz: manual-stamp
+- gzip -9 -c manual.pdf > manual.pdf.gz
++manual.pdf: manual-stamp
+
+ epix.info: manual-stamp epix.texi
+ makeinfo epix.texi 2>&1 >/dev/null
+diff -Nur epix-1.2.9.orig/Makefile.am epix-1.2.9/Makefile.am
+--- epix-1.2.9.orig/Makefile.am 2010-01-25 02:42:26.000000000 +0000
++++ epix-1.2.9/Makefile.am 2012-02-19 16:50:24.890671835 +0000
+@@ -15,7 +15,8 @@
+ bin_SCRIPTS = epix elaps flix laps
+
+ pkglib_LIBRARIES = libepix.a
+-pkglib_DATA = epix-lib.sh
++pkgepixdir = $(pkglibdir)
++pkgepix_DATA = epix-lib.sh
+ include_HEADERS = epix.h
+
+ libepix_a_CXXSOURCES = active_screen.cc affine.cc angle_units.cc \
+@@ -56,7 +57,7 @@
+
+ EPIX_CONFFILES = bash_completions $(EPIX_EL)
+
+-EPIX_NOTEFILES = AUTHORS BUGS ChangeLog COPYING INSTALL NEWS POST-INSTALL \
++EPIX_NOTEFILES = AUTHORS BUGS ChangeLog NEWS POST-INSTALL \
+ README THANKS VERSION
+
+ EXTRA_DIST = $(bin_SCRIPTS) $(man_MANS) $(EPIX_CONFFILES) $(EPIX_NOTEFILES) \
+@@ -102,13 +103,12 @@
+ # Extra things to install
+ install-data-local:
+ @echo; echo "Installing notes and configuration files"
+- $(mkinstalldirs) $(DESTDIR)$(docdir)/notes $(DESTDIR)$(docdir)/config
+- $(INSTALL_DATA) $(EPIX_NOTEFILES) $(DESTDIR)$(docdir)/notes
+- $(INSTALL_DATA) $(EPIX_CONFFILES) $(DESTDIR)$(docdir)/config
++ $(mkinstalldirs) $(DESTDIR)$(docdir)
++ $(INSTALL_DATA) $(EPIX_NOTEFILES) $(DESTDIR)$(docdir)
+
+ # This is being installed by install-exec, but should not be executable
+-install-exec-local: install-pkglibDATA
+- chmod a-x $(DESTDIR)$(pkglibdir)/epix-lib.sh
++install-exec-local: install-pkgepixDATA
++ chmod a-x $(DESTDIR)$(pkgepixdir)/epix-lib.sh
+
+ uninstall-local:
+ -rm -rf $(DESTDIR)$(docdir)/notes $(DESTDIR)$(docdir)/config
+diff -Nur epix-1.2.9.orig/samples/Makefile.am epix-1.2.9/samples/Makefile.am
+--- epix-1.2.9.orig/samples/Makefile.am 2008-07-01 03:55:14.000000000 +0100
++++ epix-1.2.9/samples/Makefile.am 2012-02-19 16:46:02.123782104 +0000
+@@ -7,7 +7,7 @@
+ CLEANFILES = *~ *.eepic *.eps sample_src.tar sample_src.tar.gz sample-stamp
+
+ ## Targets ##
+-doc_DATA = sample_src.tar.gz
++doc_DATA =
+
+
+ # tar up tex, xp, and eepic files