summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-11-07 12:11:24 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-11-07 12:11:24 +0100
commit45131537163f2bee69d53860869f3548fd30856a (patch)
treec867286459b32ebbb8eae31e40609d26b577fce5 /sci-misc
parentdev-python/pyside2-tools: add 5.15.7 (diff)
downloadgentoo-45131537163f2bee69d53860869f3548fd30856a.tar.gz
gentoo-45131537163f2bee69d53860869f3548fd30856a.tar.bz2
gentoo-45131537163f2bee69d53860869f3548fd30856a.zip
sci-misc/jupyterlab-desktop-bin: add 3.5.0.1
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'sci-misc')
-rw-r--r--sci-misc/jupyterlab-desktop-bin/Manifest1
-rw-r--r--sci-misc/jupyterlab-desktop-bin/jupyterlab-desktop-bin-3.5.0.1.ebuild117
2 files changed, 118 insertions, 0 deletions
diff --git a/sci-misc/jupyterlab-desktop-bin/Manifest b/sci-misc/jupyterlab-desktop-bin/Manifest
index 08276e1d41e9..a49b33220e59 100644
--- a/sci-misc/jupyterlab-desktop-bin/Manifest
+++ b/sci-misc/jupyterlab-desktop-bin/Manifest
@@ -1,2 +1,3 @@
DIST jupyterlab-desktop-bin-3.4.5.1.rpm 335639840 BLAKE2B 6be6792ba7ce8db996701b287c5b4686be6088fdbf7ba3eecdac1bed25c9caba46b81ff61e8a66350558b36f69a27e4ea9559d00a431a9a702b99a0cfe0bf437 SHA512 025e31f7baa1da186343538ea3f9668c0873dfe0081572cac5673aae1691843e6d14145a6fedd7330f043b127d84ec74563436ae08c7a4d3254093ab9560c0c1
DIST jupyterlab-desktop-bin-3.4.6.1.rpm 335746672 BLAKE2B d9c85fe80bba55a6fadfd2cd7ff6ff5f0991df40764c9c28f83eb258fbf7d26a620089ea7aadcb1c5c827c65446eda05861b9c5102edbd4eab2b5d53fd955a5b SHA512 c9a33bc6980afdfe979dbfb45d71e4954ce1913712010c2fdc7ce73ac480e56f005eb289df840524058163a61a79fab01bd27240515ec353c0b23f0b07a32807
+DIST jupyterlab-desktop-bin-3.5.0.1.rpm 331913564 BLAKE2B 1035fb96b7289a465d2b0d3e60dbb975ab4cb76132c8cbe43162b13b5a7950045940b8fb458a0139719dee1b5648249666529c39fdd53da9b04a97b7b2187eb7 SHA512 4e6d146c7448186e38175128c4ef67aed6b0bbc3a47de2734be1ff23dcb2814236aab9aa4820f02aae0d2ea3fd3656e48b0a53a5f3f8c27f33dcdd83908ade48
diff --git a/sci-misc/jupyterlab-desktop-bin/jupyterlab-desktop-bin-3.5.0.1.ebuild b/sci-misc/jupyterlab-desktop-bin/jupyterlab-desktop-bin-3.5.0.1.ebuild
new file mode 100644
index 000000000000..a910f5773855
--- /dev/null
+++ b/sci-misc/jupyterlab-desktop-bin/jupyterlab-desktop-bin-3.5.0.1.ebuild
@@ -0,0 +1,117 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CHROMIUM_LANGS="
+ am ar bg bn ca cs da de el en-GB en-US es es-419 et fa fi fil fr gu he hi
+ hr hu id it ja kn ko lt lv ml mr ms nb nl pl pt-BR pt-PT ro ru sk sl sr sv
+ sw ta te th tr uk vi zh-CN zh-TW
+"
+
+inherit chromium-2 desktop rpm xdg
+
+DESCRIPTION="JupyterLab desktop application, based on Electron"
+HOMEPAGE="https://jupyter.org/"
+SRC_URI="https://github.com/jupyterlab/${PN%%-bin}/releases/download/v$(ver_rs 3 -)/JupyterLab-Setup-Fedora.rpm -> ${P}.rpm"
+S="${WORKDIR}"
+
+KEYWORDS="-* ~amd64"
+# Electron bundles a bunch of things
+LICENSE="
+ MIT BSD BSD-2 BSD-4 AFL-2.1 Apache-2.0 Ms-PL GPL-2 LGPL-2.1 APSL-2
+ unRAR OFL CC-BY-SA-3.0 MPL-2.0 android public-domain all-rights-reserved
+"
+SLOT="0"
+RESTRICT="bindist mirror"
+
+RDEPEND="
+ || (
+ >=app-accessibility/at-spi2-core-2.46.0:2
+ ( app-accessibility/at-spi2-atk dev-libs/atk )
+ )
+ dev-libs/expat
+ dev-libs/glib
+ dev-libs/nspr
+ dev-libs/nss
+ >=dev-python/jupyterlab-$(ver_cut 1-3)
+ media-libs/alsa-lib
+ media-libs/mesa
+ net-print/cups
+ sys-apps/dbus
+ sys-libs/glibc
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:3
+ x11-libs/libdrm
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libxkbcommon
+ x11-libs/libXrandr
+ x11-libs/libxshmfence
+ x11-libs/pango
+"
+
+QA_PREBUILT="opt/JupyterLab/*"
+
+pkg_pretend() {
+ chromium_suid_sandbox_check_kernel_config
+}
+
+src_prepare() {
+ default
+ # cleanup languages
+ pushd "opt/JupyterLab/locales" || die
+ chromium_remove_language_paks
+ popd || die
+}
+
+src_configure() {
+ chromium_suid_sandbox_check_kernel_config
+ default
+}
+
+src_install() {
+ for size in {16,32,48,64,128,256,512}; do
+ doicon -s ${size} "usr/share/icons/hicolor/${size}x${size}/apps/jupyterlab-desktop.png"
+ done
+
+ domenu usr/share/applications/jupyterlab-desktop.desktop
+
+ local DESTDIR="/opt/JupyterLab"
+ pushd "opt/JupyterLab" || die
+
+ exeinto "${DESTDIR}"
+ doexe chrome-sandbox chrome_crashpad_handler jupyterlab-desktop *.so*
+
+ exeinto "${DESTDIR}/swiftshader"
+ doexe swiftshader/*.so*
+
+ insinto "${DESTDIR}"
+ doins *.pak *.bin *.json *.dat
+ insopts -m0755
+ doins -r locales resources
+
+ # Chrome-sandbox requires the setuid bit to be specifically set.
+ # see https://github.com/electron/electron/issues/17972
+ fperms 4755 "${DESTDIR}"/chrome-sandbox
+
+ dosym "${DESTDIR}"/jupyterlab-desktop /opt/bin/jupyterlab-desktop
+ popd || die
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ elog ""
+ elog "On initial startup you will be prompted to select the python environment of"
+ elog "your choice. Either select a specific python version, e.g. /usr/bin/pythonX.Y,"
+ elog "or choose /usr/bin/python to follow the system wide setting in"
+ elog "/etc/python-exec/python-exec.conf."
+ elog "Please note that only python environments corresponding to the enabled"
+ elog "PYTHON_TARGETS on dev-python/jupyterlab will work."
+ elog ""
+}