summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-11-22 07:56:58 +0000
committerSam James <sam@gentoo.org>2022-11-22 07:57:06 +0000
commit89eab812522679c4aa55b7b47a79ef3b42ee1986 (patch)
treed5810a9fc18c290c3dc7d62e53f4bb37672736c1 /sci-mathematics
parentapp-cdr/cuecue: add BDEPEND on flac for macro; enable flac IUSE by default (diff)
downloadgentoo-89eab812522679c4aa55b7b47a79ef3b42ee1986.tar.gz
gentoo-89eab812522679c4aa55b7b47a79ef3b42ee1986.tar.bz2
gentoo-89eab812522679c4aa55b7b47a79ef3b42ee1986.zip
sci-mathematics/jags: add 4.3.1
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/jags/Manifest1
-rw-r--r--sci-mathematics/jags/jags-4.3.1.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/sci-mathematics/jags/Manifest b/sci-mathematics/jags/Manifest
index e30aaf0e29f9..92f5e020e39c 100644
--- a/sci-mathematics/jags/Manifest
+++ b/sci-mathematics/jags/Manifest
@@ -1 +1,2 @@
DIST JAGS-4.3.0.tar.gz 2057409 BLAKE2B 5820c66dd10cc90343d53b901b7dbc1acf85dca0f5f80280864190882f0af865edad877eb2cfd421ec2035d3ae843373da1facee8a10b6735e2fc0387d452949 SHA512 d0564c73ff45484afad532ed788353f9c0945cd9667030eed5be674492bf97524d05903b22d4995c1de8a331dba7b04425d009e114d98a38b4bfce5214518b36
+DIST JAGS-4.3.1.tar.gz 2019687 BLAKE2B dd464675f1aab59d007ffb29844b50ddcc26320cf8159b5ca108bf0e6db9878499aa40e090250b84ff4c8733100149037b2b3cee00b3ff2ec4fb23769157b944 SHA512 dceb97c92ad3ce3ebf62e1e68e822857f170f797f81a79fe5a56d8a81f8ea619e6e06356335e44def8f50ff82af55b2f9f7a880b84e092262a2d78e46c43acf2
diff --git a/sci-mathematics/jags/jags-4.3.1.ebuild b/sci-mathematics/jags/jags-4.3.1.ebuild
new file mode 100644
index 000000000000..3b7d97d08930
--- /dev/null
+++ b/sci-mathematics/jags/jags-4.3.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+MYP="JAGS-${PV}"
+
+DESCRIPTION="Just Another Gibbs Sampler for Bayesian MCMC simulation"
+HOMEPAGE="https://mcmc-jags.sourceforge.io/"
+SRC_URI="mirror://sourceforge/project/mcmc-jags/JAGS/$(ver_cut 1).x/Source/${MYP}.tar.gz"
+S="${WORKDIR}/${MYP}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+RDEPEND="
+ virtual/blas
+ virtual/lapack
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ doc? (
+ virtual/latex-base
+ dev-texlive/texlive-latexextra
+ )
+"
+
+src_configure() {
+ econf \
+ --with-blas="$($(tc-getPKG_CONFIG) --libs blas)" \
+ --with-lapack="$($(tc-getPKG_CONFIG) --libs lapack)"
+}
+
+src_compile() {
+ emake all $(usev doc docs)
+}
+
+src_install() {
+ default
+ use doc && dodoc doc/manual/*.pdf
+ find "${ED}" -name '*.la' -delete || die
+}