summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2024-07-27 18:36:22 -0400
committerMichael Orlitzky <mjo@gentoo.org>2024-07-27 19:12:13 -0400
commit7c8d5f0eec157362bb7b5f6b6a6efbe6a5f102f7 (patch)
treea322b7563e0d9ca539ca6783a28785e71db18778 /sci-mathematics
parentsys-devel/gcc: add 14.1.1_p20240727 (diff)
downloadgentoo-7c8d5f0eec157362bb7b5f6b6a6efbe6a5f102f7.tar.gz
gentoo-7c8d5f0eec157362bb7b5f6b6a6efbe6a5f102f7.tar.bz2
gentoo-7c8d5f0eec157362bb7b5f6b6a6efbe6a5f102f7.zip
sci-mathematics/primesieve: add 12.3
Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/primesieve/Manifest1
-rw-r--r--sci-mathematics/primesieve/primesieve-12.3.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/sci-mathematics/primesieve/Manifest b/sci-mathematics/primesieve/Manifest
index d61583c50cca..d16a3dd0d053 100644
--- a/sci-mathematics/primesieve/Manifest
+++ b/sci-mathematics/primesieve/Manifest
@@ -1 +1,2 @@
DIST primesieve-11.0.tar.gz 125086 BLAKE2B ac425b6435bc95efbfc3d7458b59719af390508db811e0a993a606397166771cfcb9c0269249341fb6f678aafa8bae4a89e7a914176f61a608e6ccdfd0cab22b SHA512 1be9ff9d07068cab1ca69315010238ab15e5ba3b674bd45e9a0e11d20418810ece05a8df3853796118193468ac2ac6e24391f82d6db9581658ce59ddabb5b7fc
+DIST primesieve-12.3.tar.gz 140761 BLAKE2B d93aa8747d43850b9194172a2300942a685797c1aeb503240eb23cbbfe4b99281f3058a622d0e2359017e144ff8200dcecdd56922e16b46366d693b04eb1350a SHA512 b7bd74223ca9abe41de9f6a48102e6cfd1b1989fb291292c13f5c751a31f8df93e1faaadee318f169cfe81fa4dc4d5b0678fe7556f77043941d8ae749c6e8cc7
diff --git a/sci-mathematics/primesieve/primesieve-12.3.ebuild b/sci-mathematics/primesieve/primesieve-12.3.ebuild
new file mode 100644
index 000000000000..97d6b8bae298
--- /dev/null
+++ b/sci-mathematics/primesieve/primesieve-12.3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="CLI and library for quickly generating prime numbers"
+HOMEPAGE="https://github.com/kimwalisch/primesieve"
+SRC_URI="https://github.com/kimwalisch/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="BSD-2"
+SLOT="0/12" # subslot is first component of libprimesieve.so version
+KEYWORDS="~amd64"
+IUSE="doc +executable test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="doc? ( app-text/doxygen app-text/texlive media-gfx/graphviz )"
+
+DOCS=(
+ ChangeLog
+ README.md
+ doc/ALGORITHMS.md
+ doc/CPP_API.md
+ doc/C_API.md
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_DOC="$(usex doc)"
+ -DBUILD_PRIMESIEVE="$(usex executable)"
+ -DBUILD_STATIC_LIBS="OFF"
+ -DBUILD_TESTS="$(usex test)"
+ )
+
+ if use doc; then
+ DOCS+=(
+ "${BUILD_DIR}/doc/html"
+ "${BUILD_DIR}/doc/latex/refman.pdf"
+ )
+ fi
+
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+ use doc && cmake_build doc
+}