summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2018-05-27 09:36:39 +0200
committerDavid Seifert <soap@gentoo.org>2018-05-27 09:54:19 +0200
commit45e8a9d6dbbd8e18332f8b500fdb97ae7c9a4648 (patch)
tree5edd7331b266c8d2248d8bab081101fb52e40ee5 /sci-mathematics
parentprofiles: package.mask <dev-perl/DBD-mysql-4.44.0 re bug #623942 (diff)
downloadgentoo-45e8a9d6dbbd8e18332f8b500fdb97ae7c9a4648.tar.gz
gentoo-45e8a9d6dbbd8e18332f8b500fdb97ae7c9a4648.tar.bz2
gentoo-45e8a9d6dbbd8e18332f8b500fdb97ae7c9a4648.zip
sci-mathematics/lpsolve: Port to EAPI 6
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/lpsolve/lpsolve-5.5.2.0.ebuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/sci-mathematics/lpsolve/lpsolve-5.5.2.0.ebuild b/sci-mathematics/lpsolve/lpsolve-5.5.2.0.ebuild
index dd828ca40d5a..5de810343b29 100644
--- a/sci-mathematics/lpsolve/lpsolve-5.5.2.0.ebuild
+++ b/sci-mathematics/lpsolve/lpsolve-5.5.2.0.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=6
DESCRIPTION="Mixed Integer Linear Programming (MILP) solver"
HOMEPAGE="https://sourceforge.net/projects/lpsolve/"
@@ -17,12 +17,14 @@ RDEPEND="${DEPEND}"
src_configure() {
econf \
- $(use_enable static-libs static) \
- --docdir="${EPREFIX}/usr/share/doc/${PF}"
+ $(use_enable static-libs static)
}
src_install() {
default
+
# required because it does not provide .pc file
- use static-libs || find "${ED}" -name '*.la' -exec rm -f {} +
+ if ! use static-libs; then
+ find "${D}" -name '*.la' -delete || die
+ fi
}