summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-12-10 23:02:54 +0100
committerMichał Górny <mgorny@gentoo.org>2019-12-11 00:22:38 +0100
commit064af661d0c9a31cecdf348632bc5603333a9149 (patch)
tree2202373a7cafcb8a761d32747d4f62263aed64d5 /sci-mathematics
parentdev-python/passlib: keyworded 1.7.1-r2 for hppa, bug #700918 (diff)
downloadgentoo-064af661d0c9a31cecdf348632bc5603333a9149.tar.gz
gentoo-064af661d0c9a31cecdf348632bc5603333a9149.tar.bz2
gentoo-064af661d0c9a31cecdf348632bc5603333a9149.zip
*/*: [QA] Fix trivial cases of MissingTestRestrict
The result was achieved via the following pipeline: pkgcheck scan -c RestrictTestCheck -R FormatReporter \ --format '{category}/{package}/{package}-{version}.ebuild' | xargs -n32 grep -L RESTRICT | xargs -n32 sed -i -e '/^IUSE=.*test/aRESTRICT="!test? ( test )"' The resulting metadata was compared before and after the change. Few Go ebuilds had to be fixed manually due to implicit RESTRICT=strip added by the eclass. Two ebuilds have to be fixed because of multiline IUSE. Suggested-by: Robin H. Johnson <robbat2@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/13942 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/dunshire/dunshire-0.1.1.ebuild1
-rw-r--r--sci-mathematics/gmp-ecm/gmp-ecm-6.4.4-r1.ebuild1
-rw-r--r--sci-mathematics/gmp-ecm/gmp-ecm-7.0.4-r1.ebuild1
-rw-r--r--sci-mathematics/gmp-ecm/gmp-ecm-9999.ebuild1
-rw-r--r--sci-mathematics/maxima/maxima-5.43.0.ebuild1
-rw-r--r--sci-mathematics/nauty/nauty-2.6.7.ebuild3
-rw-r--r--sci-mathematics/pymc3/pymc3-3.1.ebuild1
-rw-r--r--sci-mathematics/yacas/yacas-1.7.0-r1.ebuild1
8 files changed, 9 insertions, 1 deletions
diff --git a/sci-mathematics/dunshire/dunshire-0.1.1.ebuild b/sci-mathematics/dunshire/dunshire-0.1.1.ebuild
index 4bbee157ef79..32b83f053c80 100644
--- a/sci-mathematics/dunshire/dunshire-0.1.1.ebuild
+++ b/sci-mathematics/dunshire/dunshire-0.1.1.ebuild
@@ -15,6 +15,7 @@ LICENSE="AGPL-3+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc test"
+RESTRICT="!test? ( test )"
RDEPEND="dev-python/cvxopt[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
diff --git a/sci-mathematics/gmp-ecm/gmp-ecm-6.4.4-r1.ebuild b/sci-mathematics/gmp-ecm/gmp-ecm-6.4.4-r1.ebuild
index 29e28d2fc9cf..463c145bb3c8 100644
--- a/sci-mathematics/gmp-ecm/gmp-ecm-6.4.4-r1.ebuild
+++ b/sci-mathematics/gmp-ecm/gmp-ecm-6.4.4-r1.ebuild
@@ -13,6 +13,7 @@ LICENSE="GPL-3 LGPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="+blas +custom-tune -openmp static-libs test"
+RESTRICT="!test? ( test )"
DEPEND="
dev-libs/gmp:0=
diff --git a/sci-mathematics/gmp-ecm/gmp-ecm-7.0.4-r1.ebuild b/sci-mathematics/gmp-ecm/gmp-ecm-7.0.4-r1.ebuild
index 67ee92316610..e650e69207f7 100644
--- a/sci-mathematics/gmp-ecm/gmp-ecm-7.0.4-r1.ebuild
+++ b/sci-mathematics/gmp-ecm/gmp-ecm-7.0.4-r1.ebuild
@@ -13,6 +13,7 @@ LICENSE="GPL-3 LGPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="+blas +custom-tune -openmp static-libs test"
+RESTRICT="!test? ( test )"
DEPEND="
dev-libs/gmp:0=
diff --git a/sci-mathematics/gmp-ecm/gmp-ecm-9999.ebuild b/sci-mathematics/gmp-ecm/gmp-ecm-9999.ebuild
index 728b19ecd527..2856746b2ef3 100644
--- a/sci-mathematics/gmp-ecm/gmp-ecm-9999.ebuild
+++ b/sci-mathematics/gmp-ecm/gmp-ecm-9999.ebuild
@@ -14,6 +14,7 @@ LICENSE="GPL-3 LGPL-3"
SLOT="0"
KEYWORDS=""
IUSE="blas -openmp test"
+RESTRICT="!test? ( test )"
DEPEND="
dev-libs/gmp:0=
diff --git a/sci-mathematics/maxima/maxima-5.43.0.ebuild b/sci-mathematics/maxima/maxima-5.43.0.ebuild
index 3d2e01212877..177564b4b5f1 100644
--- a/sci-mathematics/maxima/maxima-5.43.0.ebuild
+++ b/sci-mathematics/maxima/maxima-5.43.0.ebuild
@@ -23,6 +23,7 @@ CONF_FLAG=( . . . ecl ccl . )
PATCH_V=( 2 1 . 3 3 1 )
IUSE="emacs tk nls unicode X test ${LISPS[*]}"
+RESTRICT="!test? ( test )"
# Languages
LANGS="de es pt pt_BR"
diff --git a/sci-mathematics/nauty/nauty-2.6.7.ebuild b/sci-mathematics/nauty/nauty-2.6.7.ebuild
index 2e01267a151a..13acc2d602be 100644
--- a/sci-mathematics/nauty/nauty-2.6.7.ebuild
+++ b/sci-mathematics/nauty/nauty-2.6.7.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -19,6 +19,7 @@ LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~arm ~x86"
IUSE="test"
+RESTRICT="!test? ( test )"
DEPEND="dev-libs/gmp:0
sys-libs/zlib"
diff --git a/sci-mathematics/pymc3/pymc3-3.1.ebuild b/sci-mathematics/pymc3/pymc3-3.1.ebuild
index 7a7638126043..c246e0768bb9 100644
--- a/sci-mathematics/pymc3/pymc3-3.1.ebuild
+++ b/sci-mathematics/pymc3/pymc3-3.1.ebuild
@@ -19,6 +19,7 @@ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
LICENSE="AFL-3.0"
IUSE="test"
+RESTRICT="!test? ( test )"
RDEPEND="
<=dev-python/commonmark-0.5.4[${PYTHON_USEDEP}]
diff --git a/sci-mathematics/yacas/yacas-1.7.0-r1.ebuild b/sci-mathematics/yacas/yacas-1.7.0-r1.ebuild
index fdba42ce0213..0d808f23ce18 100644
--- a/sci-mathematics/yacas/yacas-1.7.0-r1.ebuild
+++ b/sci-mathematics/yacas/yacas-1.7.0-r1.ebuild
@@ -14,6 +14,7 @@ LICENSE="GPL-2 gui? ( MIT Apache-2.0 OFL-1.1 )"
SLOT="0/1"
KEYWORDS="~amd64 ~x86"
IUSE="gui +jupyter static-libs test"
+RESTRICT="!test? ( test )"
DEPEND="
gui? (