summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2024-10-14 08:10:22 -0400
committerMichael Orlitzky <mjo@gentoo.org>2024-10-14 08:44:24 -0400
commit02b9512fa2ef34cf631f752b2544e6ea01085094 (patch)
treec12a8be165a329739356e78db9dbd2a2c43c8e4e /sci-mathematics
parentdev-python/pexpect: Enable python3_13t (diff)
downloadgentoo-02b9512fa2ef34cf631f752b2544e6ea01085094.tar.gz
gentoo-02b9512fa2ef34cf631f752b2544e6ea01085094.tar.bz2
gentoo-02b9512fa2ef34cf631f752b2544e6ea01085094.zip
sci-mathematics/flint: fix the flint.pc location again
I fixed this upstream a while ago, but it's missing from the current release, so we need to patch it again. Straight to stable because we've done this all before. Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/flint/files/flint-3.1.3_p1-fix-pc-location.patch26
-rw-r--r--sci-mathematics/flint/flint-3.1.3_p1-r1.ebuild (renamed from sci-mathematics/flint/flint-3.1.3_p1.ebuild)1
2 files changed, 27 insertions, 0 deletions
diff --git a/sci-mathematics/flint/files/flint-3.1.3_p1-fix-pc-location.patch b/sci-mathematics/flint/files/flint-3.1.3_p1-fix-pc-location.patch
new file mode 100644
index 000000000000..82c9fc27d8f2
--- /dev/null
+++ b/sci-mathematics/flint/files/flint-3.1.3_p1-fix-pc-location.patch
@@ -0,0 +1,26 @@
+From f4e0dfda90f6574048578f112bea1013d54f0987 Mon Sep 17 00:00:00 2001
+From: Michael Orlitzky <michael@orlitzky.com>
+Date: Sun, 10 Mar 2024 21:48:51 -0400
+Subject: [PATCH] CMakeLists.txt: install the pkg-config file to the configured
+ libdir
+
+Currently it installs to lib/pkgconfig, which can be incorrect on
+systems where (for example) the normal libdir is lib64 and "lib" is
+reserved for 32-bit libraries.
+---
+ CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 30935cef47..d8dfee38df 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -537,7 +537,7 @@ set(PACKAGE_NAME ${PROJECT_NAME})
+ set(PACKAGE_VERSION ${PROJECT_VERSION})
+ configure_file(flint.pc.in flint.pc @ONLY)
+
+-install(FILES ${CMAKE_CURRENT_BINARY_DIR}/flint.pc DESTINATION lib/pkgconfig)
++install(FILES ${CMAKE_CURRENT_BINARY_DIR}/flint.pc DESTINATION ${CMAKE_INSTALL_LIBDIR}/pkgconfig)
+
+ if(BUILD_TESTING)
+ set(FLINT_SRC ${CMAKE_CURRENT_SOURCE_DIR}/src) # To get src/test/main
diff --git a/sci-mathematics/flint/flint-3.1.3_p1.ebuild b/sci-mathematics/flint/flint-3.1.3_p1-r1.ebuild
index 4f60961ecba2..bca7c62b7b66 100644
--- a/sci-mathematics/flint/flint-3.1.3_p1.ebuild
+++ b/sci-mathematics/flint/flint-3.1.3_p1-r1.ebuild
@@ -48,6 +48,7 @@ DOCS="AUTHORS README.md doc/source/*.rst"
PATCHES=(
"${FILESDIR}/flint-3.0.1-find-cblas.patch"
"${FILESDIR}/flint-3.1.3_p1-c99-I.patch"
+ "${FILESDIR}/flint-3.1.3_p1-fix-pc-location.patch"
)
src_configure() {