summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2022-05-08 11:33:03 -0400
committerMichael Orlitzky <mjo@gentoo.org>2022-05-08 12:33:26 -0400
commita19d0d5d6c440cb475e14288136f7ac71f7616a9 (patch)
treea8400865b3f33d65612643917ab14d048b88941d /sci-mathematics/normaliz
parentvirtual/rubygems: keyword 16 for ~loong (diff)
downloadgentoo-a19d0d5d6c440cb475e14288136f7ac71f7616a9.tar.gz
gentoo-a19d0d5d6c440cb475e14288136f7ac71f7616a9.tar.bz2
gentoo-a19d0d5d6c440cb475e14288136f7ac71f7616a9.zip
sci-mathematics/normaliz: new upstream version 3.9.3.
* EAPI=8 * No more autotools.eclass (upstream provides a real release). * Install the quick reference doc. * Support USE=nauty for automorphism group computation. * Pass --without-foo for remaining unsupported options. * Use the default src_test(). * Fix QA warning about pre-stripped files. Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'sci-mathematics/normaliz')
-rw-r--r--sci-mathematics/normaliz/Manifest1
-rw-r--r--sci-mathematics/normaliz/metadata.xml8
-rw-r--r--sci-mathematics/normaliz/normaliz-3.9.3.ebuild63
3 files changed, 71 insertions, 1 deletions
diff --git a/sci-mathematics/normaliz/Manifest b/sci-mathematics/normaliz/Manifest
index 683077b4d89a..526cf8e4b9a9 100644
--- a/sci-mathematics/normaliz/Manifest
+++ b/sci-mathematics/normaliz/Manifest
@@ -1,2 +1,3 @@
DIST normaliz-3.1.3.tar.gz 3075453 BLAKE2B 0860b466dfa5335a58a496c21f7567e7e4682b07c73e36dbbd947eb65500e03758577d32355adb02fa4e271ca2f49bc5cb0449e26f1bdd11eab2dd5dbafd8f17 SHA512 c7fb1620e758dc59de88f0d7c55f50db0f67be772a00af27205e478f30c3836b7cf012a16a8adfdee3f0367d3adb4e3f887dc7d03793a7ca1601968ddb1946ce
DIST normaliz-3.8.10.tar.gz 5086191 BLAKE2B b40de665718dc1cee8a7246ccfb9b8496bdfa0754408f0260421352f1b4776133047ed1a5e8e0f044bdc15dde63a9f7d9ea1721773f36ecdccce3a8575493772 SHA512 8755011b1305b571d6bef7b6200e01bb56dbadce3f67de022fae0ef42c69c095b1f7cd2a2a432282098277ee39aa17caeffda15c806b28a6060a737930d5b82c
+DIST normaliz-3.9.3.tar.gz 4946498 BLAKE2B 3faff64fda86216ee11b0f55ba1341d70988472f65eedafe5b52bf6b05abd817add2dbab45144de0a43d02c501caf3c4a89d66c2b2d621b81188a2a5100d158f SHA512 5d6866cc35835c196d22d6b4b0d5f0e3e2e00f772553115fbbabd8415b20388cf367cf9a282904a72c03c2ef482b804f7009d67e3334add4fc37f3bab675da6c
diff --git a/sci-mathematics/normaliz/metadata.xml b/sci-mathematics/normaliz/metadata.xml
index e7b4f0b40e9a..802b12e6eb3d 100644
--- a/sci-mathematics/normaliz/metadata.xml
+++ b/sci-mathematics/normaliz/metadata.xml
@@ -6,7 +6,13 @@
<name>Gentoo Mathematics Project</name>
</maintainer>
<use>
- <flag name="extras"> Install Macaulay2 and <pkg>sci-mathematics/singular</pkg>packages as shipped by upstream</flag>
+ <flag name="extras">
+ Install Macaulay2 and <pkg>sci-mathematics/singular</pkg>packages
+ as shipped by upstream
+ </flag>
+ <flag name="nauty">
+ Use <pkg>sci-mathematics/nauty</pkg> to compute automorphism groups.
+ </flag>
</use>
<longdescription lang="en">
Normaliz is a (command line) tool for computations in affine
diff --git a/sci-mathematics/normaliz/normaliz-3.9.3.ebuild b/sci-mathematics/normaliz/normaliz-3.9.3.ebuild
new file mode 100644
index 000000000000..7b7436eeb4e9
--- /dev/null
+++ b/sci-mathematics/normaliz/normaliz-3.9.3.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Tool for computations in affine monoids and more"
+HOMEPAGE="https://www.normaliz.uni-osnabrueck.de/"
+SRC_URI="https://github.com/Normaliz/Normaliz/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0/3"
+KEYWORDS="~amd64 ~arm ~riscv ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc extras nauty openmp"
+
+RDEPEND="
+ dev-libs/gmp:=[cxx(+)]
+ nauty? ( sci-mathematics/nauty )
+"
+DEPEND="
+ ${RDEPEND}
+ dev-libs/boost
+"
+# Only a boost header is needed -> not RDEPEND
+
+pkg_setup() {
+ use openmp && tc-check-openmp
+}
+
+src_configure() {
+ # flint (and arb, which doesn't make an appearance in ./configure --help)
+ # is somehow connected to e-antic, which we do not yet package. Likewise
+ # we have no packages for cocoalib or hashlibrary.
+ econf \
+ $(use_enable openmp) \
+ $(use_with nauty) \
+ --without-cocoalib \
+ --without-hashlibrary \
+ --without-flint \
+ --without-e-antic \
+ --disable-static
+}
+
+src_compile() {
+ # Clobber the default "AM_LDFLAGS = -Wl,-s" to avoid QA warnings
+ # about pre-stripped binaries.
+ emake AM_LDFLAGS=""
+}
+
+src_install() {
+ default
+
+ use doc && dodoc doc/Normaliz.pdf doc/NmzShortRef.pdf
+ if use extras; then
+ newdoc Singular/normaliz.pdf singular-normaliz.pdf
+ insinto /usr/share/${PN}
+ doins Singular/normaliz.lib
+ doins Macaulay2/Normaliz.m2
+ fi
+
+ find "${ED}" -type f -name "*.la" -delete || die
+}