summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2024-05-26 11:46:54 +0200
committerConrad Kostecki <conikost@gentoo.org>2024-05-26 23:29:02 +0200
commit64997011aadab4e1e059b69e6fa2e4887c8b0f4e (patch)
treefa153ada64fc963d17284404b04dead9ff9465f2 /sci-mathematics/mathmod
parentapp-misc/devtodo: EAPI8 bump, fix IndirectInherits (diff)
downloadgentoo-64997011aadab4e1e059b69e6fa2e4887c8b0f4e.tar.gz
gentoo-64997011aadab4e1e059b69e6fa2e4887c8b0f4e.tar.bz2
gentoo-64997011aadab4e1e059b69e6fa2e4887c8b0f4e.zip
sci-mathematics/mathmod: add 11.1
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'sci-mathematics/mathmod')
-rw-r--r--sci-mathematics/mathmod/Manifest1
-rw-r--r--sci-mathematics/mathmod/mathmod-11.1.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/sci-mathematics/mathmod/Manifest b/sci-mathematics/mathmod/Manifest
index 21ab44616ece..77e6820fca96 100644
--- a/sci-mathematics/mathmod/Manifest
+++ b/sci-mathematics/mathmod/Manifest
@@ -1 +1,2 @@
+DIST mathmod-11.1.tar.gz 7934535 BLAKE2B ccb5ba1ee74b0e6f2d605bf76f107ce43f695f2dc81fe0ef8498fdb29978f3da214178ed433eea9536f3ee801c24887988e0c1064833a6a1069e0349fb209a05 SHA512 50485094a5c0f08077a27215d4189ba28085ad9d6cc3323043955d63723271adf80ba2c8a75afd0b50ea7443a55f5d4efd8f8d5eae32a9c0718450784ff728ab
DIST mathmod-4.1.src.zip 974709 BLAKE2B f7fa5579b670b2512eab4fd7b706a0ca2282fb63356ea44ea2ddc6204b73ae2b7cd6f837d7622ebf0e51ba2b0127437b1836b59780df6c4b8e704fcb92e8680e SHA512 e7a170f5b57384cca4e755a0bb3691ec3fe29e9b22027534f1e84ed656905495c70eea8c69262f31a937ca508c34177d33adc23f5a8a3c91db1eceb2aa283a6d
diff --git a/sci-mathematics/mathmod/mathmod-11.1.ebuild b/sci-mathematics/mathmod/mathmod-11.1.ebuild
new file mode 100644
index 000000000000..54833f046640
--- /dev/null
+++ b/sci-mathematics/mathmod/mathmod-11.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop qmake-utils xdg
+
+DESCRIPTION="Plot parametric and implicit surfaces"
+HOMEPAGE="https://github.com/parisolab/mathmod
+ https://sourceforge.net/projects/mathmod/
+ https://www.facebook.com/parisolab"
+SRC_URI="https://github.com/parisolab/mathmod/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+ GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtopengl:5
+ dev-qt/qtwidgets:5"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ eqmake5 MathMod.pro
+}
+
+src_install() {
+ exeinto /usr/bin
+ doexe MathMod
+ insinto /usr/share/${P}
+ doins mathmodconfig.js mathmodcollection.js advancedmodels.js
+ newicon -s 16 images/icon/catenoid_mini_16x16.png catenoid.png
+ newicon -s 32 images/icon/catenoid_mini_32x32.png catenoid.png
+ newicon -s 64 images/icon/catenoid_mini_64x64.png catenoid.png
+ make_desktop_entry MathMod MathMod catenoid
+}