summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-09-30 19:51:50 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-09-30 20:22:54 +0200
commit7a0fddf2cf98ea53117f839682f8d986e2568280 (patch)
treea0c8acd5ecf003cee350a786750e71356602bacc /sci-mathematics/boolector
parentsci-mathematics/vampire: bump to 4.9 (diff)
downloadgentoo-7a0fddf2cf98ea53117f839682f8d986e2568280.tar.gz
gentoo-7a0fddf2cf98ea53117f839682f8d986e2568280.tar.bz2
gentoo-7a0fddf2cf98ea53117f839682f8d986e2568280.zip
sci-mathematics/boolector: bump to 3.2.4
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'sci-mathematics/boolector')
-rw-r--r--sci-mathematics/boolector/Manifest1
-rw-r--r--sci-mathematics/boolector/boolector-3.2.4.ebuild86
2 files changed, 87 insertions, 0 deletions
diff --git a/sci-mathematics/boolector/Manifest b/sci-mathematics/boolector/Manifest
index d16abf470fde..0d1d99691dc4 100644
--- a/sci-mathematics/boolector/Manifest
+++ b/sci-mathematics/boolector/Manifest
@@ -1 +1,2 @@
DIST boolector-3.2.3.tar.gz 1566566 BLAKE2B 1c9adb1272c2289af6afce0149b11ce36a42aef47f1b3353f5f9dbaf12287718f29e45415b82b723bd37fb0438517c48d64a12f0c038105edeb6036f49189ac7 SHA512 a85c10edf05455e2911614f9d8f2b214a136470852b31a631c96247416dab822efcc6d9047f3a85c85aff499e8eb62fb36e52f2633511c5b42d287c4962c4239
+DIST boolector-3.2.4.tar.gz 1567983 BLAKE2B c74e6b7be2931ae164b3cde5ff3c9b60b12ad49b4be23ddb2931f5a71ffbfb5bb98a29ea46780275414bbe2e3e65b6108e489254251f8fd820a89162dc6eaae5 SHA512 57ba34264abd1d4350403b45995b040bd792dbea7d07a1c64d067ddbddeb3944d8515ce667ae4ffef70d35b5be68cfc5938acd6a8a7b242a09f218474024b821
diff --git a/sci-mathematics/boolector/boolector-3.2.4.ebuild b/sci-mathematics/boolector/boolector-3.2.4.ebuild
new file mode 100644
index 000000000000..2a1d832b43c3
--- /dev/null
+++ b/sci-mathematics/boolector/boolector-3.2.4.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit python-single-r1 cmake
+
+DESCRIPTION="Fast SMT solver for bit-vectors, arrays and uninterpreted functions"
+HOMEPAGE="https://boolector.github.io/
+ https://github.com/Boolector/boolector/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/Boolector/${PN}.git"
+else
+ SRC_URI="https://github.com/Boolector/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="cryptominisat examples +gmp minisat +picosat python test"
+REQUIRED_USE="
+ python? ( ${PYTHON_REQUIRED_USE} )
+ || ( cryptominisat minisat picosat )
+"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ sci-mathematics/btor2tools:=
+ cryptominisat? ( sci-mathematics/cryptominisat:= )
+ gmp? ( dev-libs/gmp:= )
+ minisat? ( sci-mathematics/minisat:= )
+ picosat? ( sci-mathematics/picosat:= )
+ python? ( ${PYTHON_DEPS} )
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ test? ( dev-cpp/gtest )
+"
+
+PATCHES=( "${FILESDIR}/${PN}-3.2.3-cmake-std.patch" )
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ local -a mycmakeargs=(
+ -DBUILD_SHARED_LIBS=ON
+ -DBtor2Tools_LIBRARIES=/usr/$(get_libdir)/libbtor2parser.so
+ -DUSE_PYTHON2=OFF
+ -DPYTHON=$(usex python)
+ -DTESTING=$(usex test)
+ -DUSE_GMP=$(usex gmp)
+ -DUSE_PYTHON3=$(usex python)
+
+ # Integration with other SMT solvers
+ -DUSE_LINGELING=OFF # Not packaged yet.
+ -DUSE_CADICAL=OFF # Fails to link.
+ -DUSE_CMS=$(usex cryptominisat)
+ -DUSE_MINISAT=$(usex minisat)
+ -DUSE_PICOSAT=$(usex picosat)
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ if use examples ; then
+ dodoc -r examples
+ fi
+
+ if [[ "$(get_libdir)" != lib ]] ; then
+ dodir "/usr/$(get_libdir)"
+ mv "${ED}/usr/lib"/*.so "${ED}/usr/$(get_libdir)/" || die
+ fi
+}