summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2024-10-27 14:44:41 +0100
committerAlfredo Tupone <tupone@gentoo.org>2024-10-27 14:44:41 +0100
commit67a2c55cf70328f76b08611c6445031c029188d2 (patch)
treeb6ec5d72b6686bc1ab153396e5c9d422f5dd15d9 /sci-libs
parentsci-libs/tokenizers: drop other network tests (diff)
downloadgentoo-67a2c55cf70328f76b08611c6445031c029188d2.tar.gz
gentoo-67a2c55cf70328f76b08611c6445031c029188d2.tar.bz2
gentoo-67a2c55cf70328f76b08611c6445031c029188d2.zip
sci-libs/pytorch: drop 2.3.0, 2.3.1
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/pytorch/Manifest2
-rw-r--r--sci-libs/pytorch/files/pytorch-1.7.1-torch_shm_manager.patch13
-rw-r--r--sci-libs/pytorch/files/pytorch-2.0.0-global-dlopen.patch20
-rw-r--r--sci-libs/pytorch/files/pytorch-2.1.1-dontbuildagain.patch17
-rw-r--r--sci-libs/pytorch/pytorch-2.3.0.ebuild66
-rw-r--r--sci-libs/pytorch/pytorch-2.3.1.ebuild66
6 files changed, 0 insertions, 184 deletions
diff --git a/sci-libs/pytorch/Manifest b/sci-libs/pytorch/Manifest
index abce85ddf365..df910a695333 100644
--- a/sci-libs/pytorch/Manifest
+++ b/sci-libs/pytorch/Manifest
@@ -1,4 +1,2 @@
-DIST pytorch-2.3.0.tar.gz 117029829 BLAKE2B 8f9c0d71ee0a9219b495eddccdcc65107f7ad537c43c68100b229f3d27b0e6c01ccb1659c7fffc356a48d80f2adc0a10361305dc8f1df20446de837d380f89f6 SHA512 67f7e9a096c3ffb952206ebf9105bedebb68c24ad82456083adf1d1d210437fcaa9dd52b68484cfc97d408c9eebc9541c76868c34a7c9982494dc3f424cfb07c
-DIST pytorch-2.3.1.tar.gz 117035696 BLAKE2B d419d7fa1342f1fb317ffce09ec9dc1447414627cc83d36578fe60f68c283c620b2b4d49f414cd206d537b90b16432a06cd1941662720db05d5e2b6c493325f5 SHA512 e1bcae44f9939fc7ccb1360a9b1970d92426f25e5de73e36964df3dd15ad5d8d9f5bd2f9a7dda6b8f64e2bba3674005bd869f542489cc442ad0125a02676f587
DIST pytorch-2.4.0.tar.gz 115031093 BLAKE2B d206477963977011627df284efa01482fbf57e9fcb5f58f51d679c742b8e5dde6aa6affd8745ab817fcd09477d129a81e74e07be576b5d3585eaca1c735b8e01 SHA512 804d25944035f33de6591fd942fbda44d3de037717a4397d38a97474b01775d30eaf93d16dd708a832c0119050d24d73b90990fd3e3773be79d26ada25244d22
DIST pytorch-2.4.1.tar.gz 115029469 BLAKE2B c2909ff27d527bc57cba56b780d3b8cd07a043ab045caa6c6b27857a16f9ad10aaab2116b26226b1e46ee08ffb44007965d914464418e4ae14ca48c3f3f383bb SHA512 7e9b4485e242eaf0d648765c6621d73d95e7107b766646a098175436d1ab2e2b864badd0757a3bab6b7c318233f2120bad9ac07b39bb9e357897919580c87631
diff --git a/sci-libs/pytorch/files/pytorch-1.7.1-torch_shm_manager.patch b/sci-libs/pytorch/files/pytorch-1.7.1-torch_shm_manager.patch
deleted file mode 100644
index 69c2ddc5947e..000000000000
--- a/sci-libs/pytorch/files/pytorch-1.7.1-torch_shm_manager.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/torch/__init__.py b/torch/__init__.py
-index 03f6eca622..297fb169a4 100644
---- a/torch/__init__.py
-+++ b/torch/__init__.py
-@@ -412,7 +412,7 @@ def manager_path():
-
-
- # Shared memory manager needs to know the exact location of manager executable
--_C._initExtension(manager_path())
-+_C._initExtension(b"/usr/bin/torch_shm_manager")
- del manager_path
-
- # Appease the type checker: it can't deal with direct setting of globals().
diff --git a/sci-libs/pytorch/files/pytorch-2.0.0-global-dlopen.patch b/sci-libs/pytorch/files/pytorch-2.0.0-global-dlopen.patch
deleted file mode 100644
index 0f1b400e234d..000000000000
--- a/sci-libs/pytorch/files/pytorch-2.0.0-global-dlopen.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- a/torch/__init__.py 2023-04-05 11:12:25.682681130 +0200
-+++ b/torch/__init__.py 2023-04-05 11:13:00.640170307 +0200
-@@ -165,7 +165,7 @@
- lib_path = os.path.join(os.path.dirname(here), 'lib', lib_name)
-
- try:
-- ctypes.CDLL(lib_path, mode=ctypes.RTLD_GLOBAL)
-+ ctypes.CDLL(lib_name, mode=ctypes.RTLD_GLOBAL)
- except OSError as err:
- # Can only happen for wheel with cuda libs as PYPI deps
- # As PyTorch is not purelib, but nvidia-*-cu11 is
-@@ -187,7 +187,7 @@
- raise err
- for lib_folder, lib_name in cuda_libs.items():
- _preload_cuda_deps(lib_folder, lib_name)
-- ctypes.CDLL(lib_path, mode=ctypes.RTLD_GLOBAL)
-+ ctypes.CDLL(lib_name, mode=ctypes.RTLD_GLOBAL)
-
-
- if (USE_RTLD_GLOBAL_WITH_LIBTORCH or os.getenv('TORCH_USE_RTLD_GLOBAL')) and \
diff --git a/sci-libs/pytorch/files/pytorch-2.1.1-dontbuildagain.patch b/sci-libs/pytorch/files/pytorch-2.1.1-dontbuildagain.patch
deleted file mode 100644
index f031a7345c69..000000000000
--- a/sci-libs/pytorch/files/pytorch-2.1.1-dontbuildagain.patch
+++ /dev/null
@@ -1,17 +0,0 @@
---- a/setup.py 2023-12-07 20:38:21.247250326 +0100
-+++ b/setup.py 2023-12-07 20:38:30.707272148 +0100
-@@ -455,14 +455,6 @@
- check_submodules()
- check_pydep("yaml", "pyyaml")
-
-- build_caffe2(
-- version=version,
-- cmake_python_library=cmake_python_library,
-- build_python=True,
-- rerun_cmake=RERUN_CMAKE,
-- cmake_only=CMAKE_ONLY,
-- cmake=cmake,
-- )
-
- if CMAKE_ONLY:
- report(
diff --git a/sci-libs/pytorch/pytorch-2.3.0.ebuild b/sci-libs/pytorch/pytorch-2.3.0.ebuild
deleted file mode 100644
index 75fbde095842..000000000000
--- a/sci-libs/pytorch/pytorch-2.3.0.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 2022-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
-DISTUTILS_SINGLE_IMPL=1
-DISTUTILS_EXT=1
-inherit distutils-r1 prefix
-
-DESCRIPTION="Tensors and Dynamic neural networks in Python"
-HOMEPAGE="https://pytorch.org/"
-SRC_URI="https://github.com/pytorch/${PN}/archive/refs/tags/v${PV}.tar.gz
- -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64"
-RESTRICT="test"
-
-REQUIRED_USE=${PYTHON_REQUIRED_USE}
-RDEPEND="
- ${PYTHON_DEPS}
- ~sci-libs/caffe2-${PV}[${PYTHON_SINGLE_USEDEP}]
- $(python_gen_cond_dep '
- dev-python/typing-extensions[${PYTHON_USEDEP}]
- dev-python/sympy[${PYTHON_USEDEP}]
- ')
-"
-DEPEND="${RDEPEND}
- $(python_gen_cond_dep '
- dev-python/pyyaml[${PYTHON_USEDEP}]
- ')
-"
-
-src_prepare() {
- eapply \
- "${FILESDIR}"/${PN}-2.1.1-dontbuildagain.patch \
- "${FILESDIR}"/pytorch-1.9.0-Change-library-directory-according-to-CMake-build.patch \
- "${FILESDIR}"/${PN}-2.0.0-global-dlopen.patch \
- "${FILESDIR}"/pytorch-1.7.1-torch_shm_manager.patch \
- "${FILESDIR}"/${PN}-1.13.0-setup.patch \
- "${FILESDIR}"/${PN}-2.2.1-emptyso.patch \
-
- # Set build dir for pytorch's setup
- sed -i \
- -e "/BUILD_DIR/s|build|/var/lib/caffe2/|" \
- tools/setup_helpers/env.py \
- || die
- distutils-r1_src_prepare
-
- hprefixify tools/setup_helpers/env.py
-}
-
-python_compile() {
- PYTORCH_BUILD_VERSION=${PV} \
- PYTORCH_BUILD_NUMBER=0 \
- USE_SYSTEM_LIBS=ON \
- CMAKE_BUILD_DIR="${BUILD_DIR}" \
- distutils-r1_python_compile develop sdist
-}
-
-python_install() {
- USE_SYSTEM_LIBS=ON distutils-r1_python_install
-}
diff --git a/sci-libs/pytorch/pytorch-2.3.1.ebuild b/sci-libs/pytorch/pytorch-2.3.1.ebuild
deleted file mode 100644
index 75fbde095842..000000000000
--- a/sci-libs/pytorch/pytorch-2.3.1.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 2022-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
-DISTUTILS_SINGLE_IMPL=1
-DISTUTILS_EXT=1
-inherit distutils-r1 prefix
-
-DESCRIPTION="Tensors and Dynamic neural networks in Python"
-HOMEPAGE="https://pytorch.org/"
-SRC_URI="https://github.com/pytorch/${PN}/archive/refs/tags/v${PV}.tar.gz
- -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64"
-RESTRICT="test"
-
-REQUIRED_USE=${PYTHON_REQUIRED_USE}
-RDEPEND="
- ${PYTHON_DEPS}
- ~sci-libs/caffe2-${PV}[${PYTHON_SINGLE_USEDEP}]
- $(python_gen_cond_dep '
- dev-python/typing-extensions[${PYTHON_USEDEP}]
- dev-python/sympy[${PYTHON_USEDEP}]
- ')
-"
-DEPEND="${RDEPEND}
- $(python_gen_cond_dep '
- dev-python/pyyaml[${PYTHON_USEDEP}]
- ')
-"
-
-src_prepare() {
- eapply \
- "${FILESDIR}"/${PN}-2.1.1-dontbuildagain.patch \
- "${FILESDIR}"/pytorch-1.9.0-Change-library-directory-according-to-CMake-build.patch \
- "${FILESDIR}"/${PN}-2.0.0-global-dlopen.patch \
- "${FILESDIR}"/pytorch-1.7.1-torch_shm_manager.patch \
- "${FILESDIR}"/${PN}-1.13.0-setup.patch \
- "${FILESDIR}"/${PN}-2.2.1-emptyso.patch \
-
- # Set build dir for pytorch's setup
- sed -i \
- -e "/BUILD_DIR/s|build|/var/lib/caffe2/|" \
- tools/setup_helpers/env.py \
- || die
- distutils-r1_src_prepare
-
- hprefixify tools/setup_helpers/env.py
-}
-
-python_compile() {
- PYTORCH_BUILD_VERSION=${PV} \
- PYTORCH_BUILD_NUMBER=0 \
- USE_SYSTEM_LIBS=ON \
- CMAKE_BUILD_DIR="${BUILD_DIR}" \
- distutils-r1_python_compile develop sdist
-}
-
-python_install() {
- USE_SYSTEM_LIBS=ON distutils-r1_python_install
-}