summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2023-06-18 01:14:36 -0500
committerMatthias Maier <tamiko@gentoo.org>2023-06-18 01:15:49 -0500
commit350a29229a4f46312a027e90b35f0a023432ad30 (patch)
tree8097df0e0d711311404a5095c0f9c487cfabf8d2 /sci-libs
parentx11-themes/papirus-icon-theme: drop 20230104 (diff)
downloadgentoo-350a29229a4f46312a027e90b35f0a023432ad30.tar.gz
gentoo-350a29229a4f46312a027e90b35f0a023432ad30.tar.bz2
gentoo-350a29229a4f46312a027e90b35f0a023432ad30.zip
sci-libs/trilinos: fix compilation with gcc 13
Closes: https://bugs.gentoo.org/900677 Signed-off-by: Matthias Maier <tamiko@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/trilinos/files/trilinos-14.0.0-missing_includes_gcc_13.patch24
-rw-r--r--sci-libs/trilinos/trilinos-14.0.0.ebuild1
2 files changed, 25 insertions, 0 deletions
diff --git a/sci-libs/trilinos/files/trilinos-14.0.0-missing_includes_gcc_13.patch b/sci-libs/trilinos/files/trilinos-14.0.0-missing_includes_gcc_13.patch
new file mode 100644
index 000000000000..ee9836d84249
--- /dev/null
+++ b/sci-libs/trilinos/files/trilinos-14.0.0-missing_includes_gcc_13.patch
@@ -0,0 +1,24 @@
+diff --git a/packages/teuchos/core/src/Teuchos_BigUIntDecl.hpp b/packages/teuchos/core/src/Teuchos_BigUIntDecl.hpp
+index e82e8be9..b41b0d03 100644
+--- a/packages/teuchos/core/src/Teuchos_BigUIntDecl.hpp
++++ b/packages/teuchos/core/src/Teuchos_BigUIntDecl.hpp
+@@ -43,6 +43,7 @@
+ #define TEUCHOS_BIG_UINT_DECL_HPP
+
+ #include <iosfwd>
++#include <cstdint>
+
+ /*! \file Teuchos_BigUIntDecl.hpp
+ \brief Arbitrary-precision unsigned integer declaration.
+diff --git a/packages/teuchos/core/src/Teuchos_PrintDouble.hpp b/packages/teuchos/core/src/Teuchos_PrintDouble.hpp
+index cf2fe0f3..7c95b1b5 100644
+--- a/packages/teuchos/core/src/Teuchos_PrintDouble.hpp
++++ b/packages/teuchos/core/src/Teuchos_PrintDouble.hpp
+@@ -43,6 +43,7 @@
+ #define TEUCHOS_PRINT_DOUBLE_HPP
+
+ #include <iosfwd>
++#include <cstdint>
+
+ /*! \file Teuchos_PrintDouble.hpp
+ \brief Declares Teuchos::print_double
diff --git a/sci-libs/trilinos/trilinos-14.0.0.ebuild b/sci-libs/trilinos/trilinos-14.0.0.ebuild
index 4ba10c76e0d2..9c6599250eda 100644
--- a/sci-libs/trilinos/trilinos-14.0.0.ebuild
+++ b/sci-libs/trilinos/trilinos-14.0.0.ebuild
@@ -65,6 +65,7 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/Trilinos-${PN}-release-${MY_PV}"
PATCHES=(
+ "${FILESDIR}"/${P}-missing_includes_gcc_13.patch
)
pkg_pretend() {