summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-03-15 05:30:40 +0000
committerSam James <sam@gentoo.org>2023-03-15 05:45:00 +0000
commit2b47cf6a9cf25289bbbaf6c0fce6da22d6ec01d5 (patch)
tree619d908ff73686ed379e8115121d858525a516f6 /sci-libs
parentprofiles/base: mask ~net-misc/wget-1.21.3[verify-sig] (diff)
downloadgentoo-2b47cf6a9cf25289bbbaf6c0fce6da22d6ec01d5.tar.gz
gentoo-2b47cf6a9cf25289bbbaf6c0fce6da22d6ec01d5.tar.bz2
gentoo-2b47cf6a9cf25289bbbaf6c0fce6da22d6ec01d5.zip
sci-libs/netcdf: add 4.9.2
- Drop no strict aliasing workaround as fixes landed in 4.9.2 - Force serial tests again, the fixes in 4.9.1 weren't enough - Unconditionally build tools, as they're needed for tests + have no extra deps. Bug: https://bugs.gentoo.org/621486 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/netcdf/Manifest1
-rw-r--r--sci-libs/netcdf/netcdf-4.9.2.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/sci-libs/netcdf/Manifest b/sci-libs/netcdf/Manifest
index d9168835e81a..34422ad04e04 100644
--- a/sci-libs/netcdf/Manifest
+++ b/sci-libs/netcdf/Manifest
@@ -1,3 +1,4 @@
DIST netcdf-4.8.1.tar.gz 18957280 BLAKE2B 05fc6cd10cb5cbb11dc077b9a884fbc63c4cb840b241e782702da58ad9831fba065a6f1e97c2be092437735d39658482285850a00618d0582d6e4728d64c4402 SHA512 c97207867abf10d414abf34624268710f5b812c26c38f97e73afe00558b3f07917331fbc7fdb9e70b09813acf15a9a09bae2c432a3266ce10a791b9472f87a42
DIST netcdf-4.9.0.tar.gz 19491744 BLAKE2B b669f7ccb2f7a8def9d5b944a97d101ea7b7307d6e1495a97c0966b4ac9722b404d6039dee192da759d14d52259be2ff4f49be3bfb6cbbfac48732684cbff9c3 SHA512 62cb593b99a6e9c56426175d141907572d3974de8dc39549c85337acf410539f9b7dcd9a375808e271da1d0dc93fce7586b955eddd2bb45901d9cc48a72db705
DIST netcdf-4.9.1.tar.gz 19525310 BLAKE2B 711083c0e001ec12ec11ecc1d27b373a6e0bc4fd62a3cfe3768f607abcbd465b8485ab0b70f339964694f87f58923a34f66000043b330a6ae03504d176587ae6 SHA512 5ac41c1ce72c730db7864891aca04d9b5f3e3e5bb265801b5972ae21f0039df6b24a96c9999d35b892fb6a7347b9a313ce4fba6c05391483d642abb23a5598e0
+DIST netcdf-c-4.9.2.tar.gz 7142536 BLAKE2B b24135070d2f1f0b53fe738f8839039547eceba16d36905bb8cd7be983ce0c1127b7b01ae37dbde50087aa82fd56f00fab9bfa75c7d94fd4478031bb8a6da247 SHA512 7a96bcf673d5a9e1537d660aaf085a1dfaefc7dfb0fc96358462d92e7bbfe541184583681797e6a54d11b8588504b7d8a9b0b9bd850eecd02ed73aa2eb5ffa0d
diff --git a/sci-libs/netcdf/netcdf-4.9.2.ebuild b/sci-libs/netcdf/netcdf-4.9.2.ebuild
new file mode 100644
index 000000000000..442b1e8e7f40
--- /dev/null
+++ b/sci-libs/netcdf/netcdf-4.9.2.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Scientific library and interface for array oriented data access"
+HOMEPAGE="https://www.unidata.ucar.edu/software/netcdf/"
+SRC_URI="https://downloads.unidata.ucar.edu/netcdf-c/${PV}/${PN}-c-${PV}.tar.gz"
+S="${WORKDIR}"/${PN}-c-${PV}
+
+LICENSE="UCAR-Unidata"
+# SONAME of libnetcdf.so
+SLOT="0/19"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 -riscv ~x86 ~amd64-linux ~x86-linux"
+IUSE="+dap doc examples hdf +hdf5 mpi szip test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/libxml2
+ dap? ( net-misc/curl:= )
+ hdf? (
+ media-libs/libjpeg-turbo:=
+ sci-libs/hdf:=
+ sci-libs/hdf5:=
+ )
+ hdf5? ( sci-libs/hdf5:=[hl(+),mpi=,szip=,zlib] )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen[dot] )
+"
+
+REQUIRED_USE="
+ szip? ( hdf5 )
+ mpi? ( hdf5 )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.7.4-big-endian-test.patch
+)
+
+src_configure() {
+ use mpi && export CC=mpicc
+
+ local mycmakeargs=(
+ -DENABLE_DAP_REMOTE_TESTS=OFF
+ #-DENABLE_HDF4_FILE_TESTS=OFF
+ -DENABLE_LIBXML2=ON
+ -DBUILD_UTILITIES=ON
+ -DENABLE_DAP=$(usex dap)
+ -DENABLE_DOXYGEN=$(usex doc)
+ -DENABLE_EXAMPLES=$(usex examples)
+ -DENABLE_HDF4=$(usex hdf)
+ -DENABLE_NETCDF_4=$(usex hdf5)
+ -DENABLE_TESTS=$(usex test)
+ )
+
+ cmake_src_configure
+}
+
+src_test() {
+ # Still needs -j1 as of 4.9.2, see bug #621486 (fixes in 4.9.1 weren't enough)
+ cmake_src_test -j1
+}
+
+src_install() {
+ cmake_src_install
+
+ # bug #827188
+ sed -i -e "s:${EPREFIX}/usr/$(get_libdir)/libdl.so;:dl;:" "${ED}/usr/$(get_libdir)/cmake/netCDF/netCDFTargets.cmake" || die
+}