summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2020-06-11 18:59:06 -0400
committerMichael Orlitzky <mjo@gentoo.org>2020-06-11 19:25:16 -0400
commit18d842851da452a7c6acaa3ea9fc61158bb6bb50 (patch)
tree1d4ad0e06032c5457e2fca623ef26646f7f9d9a1 /sci-libs
parentsci-libs/openblas: earn respect for CFLAGS/FFLAGS. (diff)
downloadgentoo-18d842851da452a7c6acaa3ea9fc61158bb6bb50.tar.gz
gentoo-18d842851da452a7c6acaa3ea9fc61158bb6bb50.tar.bz2
gentoo-18d842851da452a7c6acaa3ea9fc61158bb6bb50.zip
sci-libs/openblas: disable -fcheck=all as well.
We already had to disable -fcheck-bounds, but -fcheck=all enables the bounds checks in addition to whatever else it enables, so we have to filter that flag too. Bug: https://bugs.gentoo.org/726474 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/openblas/openblas-0.3.9-r1.ebuild2
1 files changed, 1 insertions, 1 deletions
diff --git a/sci-libs/openblas/openblas-0.3.9-r1.ebuild b/sci-libs/openblas/openblas-0.3.9-r1.ebuild
index cb255367b636..b0daf6becad6 100644
--- a/sci-libs/openblas/openblas-0.3.9-r1.ebuild
+++ b/sci-libs/openblas/openblas-0.3.9-r1.ebuild
@@ -34,7 +34,7 @@ pkg_setup() {
# We need to filter these while building the library, and not just
# while building the test suite. Will hopefully get fixed upstream:
# https://github.com/xianyi/OpenBLAS/issues/2657
- use test && filter-flags "-fbounds-check" "-fcheck=bounds"
+ use test && filter-flags "-fbounds-check" "-fcheck=bounds" "-fcheck=all"
export CC=$(tc-getCC) FC=$(tc-getFC)