summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2022-02-05 17:49:41 -0800
committerJason Zaman <perfinion@gentoo.org>2022-02-06 17:56:46 -0800
commitfd7e2ae235f5a470ae5fb0e0d070e8484a83ba5e (patch)
tree4ac2703bc569ea97a6bf5ab42eb8844c4a165412 /sci-libs/tensorflow-estimator
parentsci-libs/tensorflow: Bump 2.8.0 (diff)
downloadgentoo-fd7e2ae235f5a470ae5fb0e0d070e8484a83ba5e.tar.gz
gentoo-fd7e2ae235f5a470ae5fb0e0d070e8484a83ba5e.tar.bz2
gentoo-fd7e2ae235f5a470ae5fb0e0d070e8484a83ba5e.zip
sci-libs/tensorflow-estimator: bump 2.8.0
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Jason Zaman <perfinion@gentoo.org>
Diffstat (limited to 'sci-libs/tensorflow-estimator')
-rw-r--r--sci-libs/tensorflow-estimator/Manifest1
-rw-r--r--sci-libs/tensorflow-estimator/tensorflow-estimator-2.8.0.ebuild77
2 files changed, 78 insertions, 0 deletions
diff --git a/sci-libs/tensorflow-estimator/Manifest b/sci-libs/tensorflow-estimator/Manifest
index cfb73ee3708b..0fad4e701ca4 100644
--- a/sci-libs/tensorflow-estimator/Manifest
+++ b/sci-libs/tensorflow-estimator/Manifest
@@ -4,3 +4,4 @@ DIST bazelbuild-rules_cc-b1c40e1de81913a3c40e5948f78719c28152486d.zip 201360 BLA
DIST bazelbuild-rules_java-7cf3cefd652008d0a64a419c34c13bdca6c8f178.zip 9422 BLAKE2B bbc45c97551ee8126335b611ffca6574dac843d4db9b3221b10d26487f8eecfe38ba0cd67a4039a3ad921c25fea6294c43e4f4e7a57a060a30791acd6c4f9d39 SHA512 ba06242feb711e7fb6e821fd9ac029248b4f3e466fb1acf971d0db8196f3efe4d114ef137acbe4913073f8cbe8ccab4d47d8bafa21b867b2d6a6d57f5a647f0c
DIST tensorflow-estimator-2.5.0.tar.gz 689339 BLAKE2B 6fb491b047cabed6edf67cccc913de54e4c2337eb052ba833239b72b07facaf33410b8a57a8f95fc0e2c225190d9b26b7955579d77883dbc236519cb784784c3 SHA512 dc49d92f4d2e63770dd901b272d7c62db50bfef7107e38f6525b6a458ad9915d1cbcdc9961c70c6ef88b9a38361f7b6712f6a2d30e240a35aab4bb25ffe17e71
DIST tensorflow-estimator-2.7.0.tar.gz 691956 BLAKE2B 8a6cdc88fadbac6275d1c766c4b183dc7d1d374a1e898651ecdf0802d2f5c5bbc01d437a85826e3ef5dc0700b44c69ff84d8610fdf7ac3150fa4c0541f901707 SHA512 e02ee93baf2e36f2e42dec71bd2e31486dc96a7ff25d813fbbe3aae1d0eb1fccdda2cfcad46a87c6cdcd143c1b88915b95bc158ac3240a36734b725b3f89bda3
+DIST tensorflow-estimator-2.8.0.tar.gz 691913 BLAKE2B 7c8059ec3c5e94f67b7fbb49b508e313f0a12eac0627b04471fe1ac82c26aaae2a120a834ce3dc5a16931119ffc31a9d96935b8f727d851885fa132eb08fa2ea SHA512 02a3009fd8f9f560dea6190989af7c58402777a414cd4bf036d24546fc4a747bb8a5515a5d6fea3bdb848cb9604239b19d43096c5f125a1fa434ae8fee44cf0a
diff --git a/sci-libs/tensorflow-estimator/tensorflow-estimator-2.8.0.ebuild b/sci-libs/tensorflow-estimator/tensorflow-estimator-2.8.0.ebuild
new file mode 100644
index 000000000000..fcc862dd41a7
--- /dev/null
+++ b/sci-libs/tensorflow-estimator/tensorflow-estimator-2.8.0.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8,9} )
+MY_PN="estimator"
+MY_PV=${PV/_rc/-rc}
+MY_P=${MY_PN}-${MY_PV}
+
+inherit bazel distutils-r1
+
+DESCRIPTION="A high-level TensorFlow API that greatly simplifies machine learning programming"
+HOMEPAGE="https://www.tensorflow.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+bazel_external_uris="
+ https://github.com/bazelbuild/rules_cc/archive/b1c40e1de81913a3c40e5948f78719c28152486d.zip -> bazelbuild-rules_cc-b1c40e1de81913a3c40e5948f78719c28152486d.zip
+ https://github.com/bazelbuild/rules_java/archive/7cf3cefd652008d0a64a419c34c13bdca6c8f178.zip -> bazelbuild-rules_java-7cf3cefd652008d0a64a419c34c13bdca6c8f178.zip"
+
+SRC_URI="https://github.com/tensorflow/${MY_PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz
+ ${bazel_external_uris}"
+
+RDEPEND="
+ sci-libs/tensorflow[python,${PYTHON_USEDEP}]
+ sci-libs/keras[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ app-arch/unzip
+ dev-java/java-config
+ >=dev-util/bazel-4.2.2"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS=( CONTRIBUTING.md README.md )
+
+src_unpack() {
+ unpack "${P}.tar.gz"
+ bazel_load_distfiles "${bazel_external_uris}"
+}
+
+src_prepare() {
+ bazel_setup_bazelrc
+ default
+ python_copy_sources
+}
+
+src_compile() {
+ export JAVA_HOME=$(java-config --jre-home)
+
+ do_compile() {
+ ebazel build //tensorflow_estimator/tools/pip_package:build_pip_package
+ ebazel shutdown
+
+ local srcdir="${T}/src-${EPYTHON/./_}"
+ mkdir -p "${srcdir}" || die
+ bazel-bin/tensorflow_estimator/tools/pip_package/build_pip_package --src "${srcdir}" || die
+ }
+
+ python_foreach_impl run_in_build_dir do_compile
+}
+
+src_install() {
+ do_install() {
+ cd "${T}/src-${EPYTHON/./_}" || die
+ esetup.py install
+ python_optimize
+ }
+ python_foreach_impl do_install
+
+ cd "${S}" || die
+ einstalldocs
+}