summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz@gentoo.org>2024-08-26 00:47:38 -0400
committerEli Schwartz <eschwartz@gentoo.org>2024-08-26 09:12:42 -0400
commit1b8914c4c9d21b6a095d2c43aa852a11b09ba18b (patch)
tree7f40055634018e1e580858e3fddf592cc67f1817 /sci-libs/spqr
parentsci-libs/spqr: make sure elibtoolize is applied (diff)
downloadgentoo-1b8914c4c9d21b6a095d2c43aa852a11b09ba18b.tar.gz
gentoo-1b8914c4c9d21b6a095d2c43aa852a11b09ba18b.tar.bz2
gentoo-1b8914c4c9d21b6a095d2c43aa852a11b09ba18b.zip
sci-libs/spqr: update EAPI 7 -> 8
Signed-off-by: Eli Schwartz <eschwartz@gentoo.org>
Diffstat (limited to 'sci-libs/spqr')
-rw-r--r--sci-libs/spqr/spqr-2.0.9-r4.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/sci-libs/spqr/spqr-2.0.9-r4.ebuild b/sci-libs/spqr/spqr-2.0.9-r4.ebuild
new file mode 100644
index 000000000000..92082b0cee2e
--- /dev/null
+++ b/sci-libs/spqr/spqr-2.0.9-r4.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit libtool
+
+DESCRIPTION="Multithreaded multifrontal sparse QR factorization library"
+HOMEPAGE="https://people.engr.tamu.edu/davis/suitesparse.html"
+SRC_URI="http://202.36.178.9/sage/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc partition tbb"
+
+BDEPEND="virtual/pkgconfig
+ doc? ( virtual/latex-base )"
+# We require the cholmod supernodal module that is enabled with
+# USE=lapack, and cholmod has to have partition support if spqr is going
+# to have it (the ./configure script for spqr checks this). Note that
+# spqr links to metis directly, too.
+DEPEND="
+ virtual/lapack
+ =sci-libs/cholmod-3*[lapack,partition?]
+ partition? ( >=sci-libs/metis-5.1.0 )
+ tbb? ( <dev-cpp/tbb-2021:= )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ elibtoolize
+}
+
+src_configure() {
+ econf \
+ $(use_with doc) \
+ $(use_with partition) \
+ $(use_with tbb)
+}
+
+src_install() {
+ default
+
+ # no static archives
+ find "${D}" -name '*.la' -delete || die
+}