summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYiyangWu <xgreenlandforwyy@gmail.com>2021-12-21 11:35:10 +0800
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-03-05 21:51:47 +0100
commitc77c85267c21ac3091492a5bb5354f7bc5da66d6 (patch)
tree5d648c6ff0ebcd8cb7d3a2e1fc1f31d088902236 /sci-libs/rocBLAS
parentsci-chemistry/avogadro2: Drop 1.93.0 (diff)
downloadgentoo-c77c85267c21ac3091492a5bb5354f7bc5da66d6.tar.gz
gentoo-c77c85267c21ac3091492a5bb5354f7bc5da66d6.tar.bz2
gentoo-c77c85267c21ac3091492a5bb5354f7bc5da66d6.zip
sci-libs/rocBLAS: let TensileCreateLibrary respects MAKEOPTS
Originaly TensileCreateLibrary consumes all cpu detected. This modification will inject $(makeopts_jobs) into TensileCreateLibrary.py so it respects MAKEOPTS Closes: https://bugs.gentoo.org/822828 Package-Manager: Portage-3.0.22, Repoman-3.0.3 Signed-off-by: Yiyang Wu <xgreenlandforwyy@gmail.com> Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'sci-libs/rocBLAS')
-rw-r--r--sci-libs/rocBLAS/rocBLAS-4.3.0.ebuild3
1 files changed, 2 insertions, 1 deletions
diff --git a/sci-libs/rocBLAS/rocBLAS-4.3.0.ebuild b/sci-libs/rocBLAS/rocBLAS-4.3.0.ebuild
index 48945fe72456..50891c285775 100644
--- a/sci-libs/rocBLAS/rocBLAS-4.3.0.ebuild
+++ b/sci-libs/rocBLAS/rocBLAS-4.3.0.ebuild
@@ -5,7 +5,7 @@ EAPI=7
PYTHON_COMPAT=( python3_{6..9} )
-inherit cmake prefix python-any-r1
+inherit cmake multiprocessing prefix python-any-r1
DESCRIPTION="AMD's library for BLAS on ROCm"
HOMEPAGE="https://github.com/ROCmSoftwarePlatform/rocBLAS"
@@ -54,6 +54,7 @@ src_prepare() {
pushd "${WORKDIR}"/Tensile-rocm-${PV} || die
eapply "${FILESDIR}/Tensile-${PV}-hsaco-compile-specified-arch.patch" # backported from upstream, should remove after 4.3.0
eapply "${FILESDIR}/Tensile-4.3.0-output-commands.patch"
+ sed -e "/Number of parallel jobs to launch/s:default=-1:default=$(makeopts_jobs):" -i Tensile/TensileCreateLibrary.py || die
popd || die
# Fit for Gentoo FHS rule