summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-11-04 20:33:38 +0000
committerSam James <sam@gentoo.org>2021-11-04 20:34:09 +0000
commit28078997c912c4034ebc66afa7bccd81812ac2b3 (patch)
tree30ccfc365019e22ee2d7fe8efdf6ce62d90c6a3f /sci-libs/pcl
parentdev-python/pycson: enable tests, ebuild cleanup (diff)
downloadgentoo-28078997c912c4034ebc66afa7bccd81812ac2b3.tar.gz
gentoo-28078997c912c4034ebc66afa7bccd81812ac2b3.tar.bz2
gentoo-28078997c912c4034ebc66afa7bccd81812ac2b3.zip
sci-libs/pcl: fix build with newer VTK
Closes: https://bugs.gentoo.org/810853 See: https://github.com/PointCloudLibrary/pcl/pull/5012 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-libs/pcl')
-rw-r--r--sci-libs/pcl/files/pcl-1.12.0-cmake-targets.patch26
-rw-r--r--sci-libs/pcl/pcl-1.12.0.ebuild4
2 files changed, 30 insertions, 0 deletions
diff --git a/sci-libs/pcl/files/pcl-1.12.0-cmake-targets.patch b/sci-libs/pcl/files/pcl-1.12.0-cmake-targets.patch
new file mode 100644
index 000000000000..408216747792
--- /dev/null
+++ b/sci-libs/pcl/files/pcl-1.12.0-cmake-targets.patch
@@ -0,0 +1,26 @@
+https://github.com/PointCloudLibrary/pcl/pull/5012
+https://bugs.gentoo.org/810853
+
+From: Maarten de Vries <maarten@de-vri.es>
+Date: Wed, 3 Nov 2021 21:40:19 +0100
+Subject: [PATCH] Limit VTK_LIBRARIES to wanted components for VTK 9.0.
+
+--- a/cmake/pcl_find_vtk.cmake
++++ b/cmake/pcl_find_vtk.cmake
+@@ -119,6 +119,15 @@ else()
+ unset(HAVE_QVTK)
+ endif()
+
++# Overwrite VTK_LIBRARIES with only the set we actually want for VTK >= 9.0.
++# Otherwise, it will contain ALL available components.
++if(NOT (VTK_VERSION VERSION_LESS 9.0))
++ set(VTK_LIBRARIES)
++ foreach(vtkComponent ${PCL_VTK_COMPONENTS})
++ list(APPEND VTK_LIBRARIES VTK::${vtkComponent})
++ endforeach()
++endif()
++
+ if(PCL_SHARED_LIBS OR (NOT (PCL_SHARED_LIBS) AND NOT (VTK_BUILD_SHARED_LIBS)))
+ if(VTK_VERSION VERSION_LESS 9.0)
+ if(VTK_USE_FILE)
+
diff --git a/sci-libs/pcl/pcl-1.12.0.ebuild b/sci-libs/pcl/pcl-1.12.0.ebuild
index 1ab0b8e362ff..e3cd374256f5 100644
--- a/sci-libs/pcl/pcl-1.12.0.ebuild
+++ b/sci-libs/pcl/pcl-1.12.0.ebuild
@@ -61,6 +61,10 @@ REQUIRED_USE="
tutorials? ( doc )
"
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.12.0-cmake-targets.patch
+)
+
src_configure() {
local mycmakeargs=(
"-DLIB_INSTALL_DIR=$(get_libdir)"