summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-libs/openfoam/openfoam-2.2.1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-libs/openfoam/openfoam-2.2.1.ebuild')
-rw-r--r--sci-libs/openfoam/openfoam-2.2.1.ebuild109
1 files changed, 109 insertions, 0 deletions
diff --git a/sci-libs/openfoam/openfoam-2.2.1.ebuild b/sci-libs/openfoam/openfoam-2.2.1.ebuild
new file mode 100644
index 000000000000..b6894ec27581
--- /dev/null
+++ b/sci-libs/openfoam/openfoam-2.2.1.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils versionator multilib toolchain-funcs multiprocessing
+
+MY_PN="OpenFOAM"
+MY_PV=$(get_version_component_range 1-2)
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Open Field Operation and Manipulation - CFD Simulation Toolbox"
+HOMEPAGE="http://www.openfoam.org"
+SRC_URI="http://downloads.sourceforge.net/foam/${MY_P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="2.2"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples opendx src"
+
+RDEPEND="!=sci-libs/openfoam-bin-${MY_PV}*
+ !=sci-libs/openfoam-kernel-${MY_PV}*
+ !=sci-libs/openfoam-meta-${MY_PV}*
+ !=sci-libs/openfoam-solvers-${MY_PV}*
+ !=sci-libs/openfoam-utilities-${MY_PV}*
+ !=sci-libs/openfoam-wmake-${MY_PV}*
+ sci-libs/parmetis
+ sci-libs/parmgridgen
+ sci-libs/scotch
+ virtual/mpi
+ opendx? ( sci-visualization/opendx )"
+DEPEND="${DEPEND}
+ doc? ( app-doc/doxygen[dot] )"
+
+S=${WORKDIR}/${MY_P}
+INSDIR="/usr/$(get_libdir)/${MY_PN}/${MY_P}"
+
+pkg_setup() {
+ # just to be sure the right profile is selected (gcc-config)
+ if ! version_is_at_least 4.3 $(gcc-version) ; then
+ die "${PN} requires >=sys-devel/gcc-4.3 to compile."
+ fi
+
+ elog
+ elog "In order to use ${MY_PN} you should add the following line to ~/.bashrc :"
+ elog
+ elog "alias startOF$(delete_all_version_separators ${MY_PV})='source ${INSDIR}/etc/bashrc'"
+ elog
+ elog "And everytime you want to use OpenFOAM you have to execute startOF$(delete_all_version_separators ${MY_PV})"
+ ewarn
+ ewarn "FoamX is deprecated since ${MY_PN}-1.5! "
+ ewarn
+}
+
+src_configure() {
+ if has_version sys-cluster/mpich2 ; then
+ export WM_MPLIB=MPICH
+ elif has_version sys-cluster/openmpi ; then
+ export WM_MPLIB=OPENMPI
+ else
+ die "You need one of the following mpi implementations: openmpi or mpich2"
+ fi
+
+ sed -i -e "s|WM_MPLIB:=OPENMPI|WM_MPLIB:="${WM_MPLIB}"|" etc/bashrc
+ sed -i -e "s|setenv WM_MPLIB OPENMPI|setenv WM_MPLIB "${WM_MPLIB}"|" etc/cshrc
+
+ sed -i -e "s|^foamInstall=\$HOME|foamInstall=/usr/$(get_libdir)|" etc/bashrc
+ sed -i -e "s|^set foamInstall = \$HOME|set foamInstall = /usr/$(get_libdir)|" etc/cshrc
+}
+
+src_compile() {
+ export WM_NCOMPPROCS=$(makeopts_jobs)
+
+ export FOAM_INST_DIR=${WORKDIR}
+ source etc/bashrc
+
+ find wmake -name dirToString -exec rm -rf {} +
+ find wmake -name wmkdep -exec rm -rf {}+
+
+ if use doc ; then
+ ./Allwmake doc || die "could not build"
+ else
+ ./Allwmake || die "could not build"
+ fi
+}
+
+src_test() {
+ cd bin
+ ./foamInstallationTest
+}
+
+src_install() {
+ insinto ${INSDIR}
+ doins -r etc
+
+ use examples && doins -r tutorials
+
+ use src && doins -r src
+
+ insopts -m0755
+ doins -r bin applications platforms wmake
+
+ dodoc README.html doc/Guides-a4/*.pdf
+
+ if use doc ; then
+ dohtml -r doc/Doxygen
+ fi
+}