summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-libs/libh2oxx
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-libs/libh2oxx')
-rw-r--r--sci-libs/libh2oxx/Manifest1
-rw-r--r--sci-libs/libh2oxx/libh2oxx-0.2.ebuild27
-rw-r--r--sci-libs/libh2oxx/libh2oxx-9999.ebuild39
-rw-r--r--sci-libs/libh2oxx/metadata.xml16
4 files changed, 83 insertions, 0 deletions
diff --git a/sci-libs/libh2oxx/Manifest b/sci-libs/libh2oxx/Manifest
new file mode 100644
index 000000000000..52c5f2cb532e
--- /dev/null
+++ b/sci-libs/libh2oxx/Manifest
@@ -0,0 +1 @@
+DIST libh2oxx-0.2.tar.bz2 266320 SHA256 deb3923f352bb6d80d908d6117a1538f0d8125001f21b2a23d5933f669e0dea5 SHA512 37b5eb713eed9a41f001add0ed3415fb4e1d6a19917de7fe36017f9a8b102394ac86b47fa845b18d7c4c63ad94e270f28e0883c9e9503c1952fdefbfdb6cc3a3 WHIRLPOOL d94d7981887d8671b367e85411a817d43861f975015cf938fd7acaa5f9d17bb6245fbf30a8161dfd0a253fdf907cc5487cc245c2196ead93863ee5a9a7703f29
diff --git a/sci-libs/libh2oxx/libh2oxx-0.2.ebuild b/sci-libs/libh2oxx/libh2oxx-0.2.ebuild
new file mode 100644
index 000000000000..f7188e7eb2e6
--- /dev/null
+++ b/sci-libs/libh2oxx/libh2oxx-0.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit autotools-utils
+
+DESCRIPTION="C++ bindings for libh2o"
+HOMEPAGE="https://bitbucket.org/mgorny/libh2oxx/"
+SRC_URI="https://www.bitbucket.org/mgorny/${PN}/downloads/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug static-libs"
+
+RDEPEND=">=sci-libs/libh2o-0.2"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable debug)
+ )
+
+ autotools-utils_src_configure
+}
diff --git a/sci-libs/libh2oxx/libh2oxx-9999.ebuild b/sci-libs/libh2oxx/libh2oxx-9999.ebuild
new file mode 100644
index 000000000000..20efc7ee0894
--- /dev/null
+++ b/sci-libs/libh2oxx/libh2oxx-9999.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+#if LIVE
+AUTOTOOLS_AUTORECONF=yes
+EGIT_REPO_URI="http://bitbucket.org/mgorny/${PN}.git"
+
+inherit git-r3
+#endif
+
+inherit autotools-utils
+
+DESCRIPTION="C++ bindings for libh2o"
+HOMEPAGE="https://bitbucket.org/mgorny/libh2oxx/"
+SRC_URI="https://www.bitbucket.org/mgorny/${PN}/downloads/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug static-libs"
+
+RDEPEND=">=sci-libs/libh2o-0.2:0="
+DEPEND="${RDEPEND}"
+
+#if LIVE
+KEYWORDS=
+SRC_URI=
+#endif
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable debug)
+ )
+
+ autotools-utils_src_configure
+}
diff --git a/sci-libs/libh2oxx/metadata.xml b/sci-libs/libh2oxx/metadata.xml
new file mode 100644
index 000000000000..c09fed962692
--- /dev/null
+++ b/sci-libs/libh2oxx/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+ <upstream>
+ <maintainer status="active">
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+ <bugs-to>https://bitbucket.org/mgorny/libh2oxx/issues/</bugs-to>
+ <remote-id type="bitbucket">mgorny/libh2oxx</remote-id>
+ </upstream>
+</pkgmetadata>