summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2024-03-01 19:31:04 +0100
committerAlfredo Tupone <tupone@gentoo.org>2024-03-01 19:31:04 +0100
commitab9ec50262cc4bfe300af030c08abd46832a4f64 (patch)
treeebf7dedb454fab57ad895291385073cf550ae5ff /sci-libs/ideep
parentdev-ada/gprbuild: add doc (diff)
downloadgentoo-ab9ec50262cc4bfe300af030c08abd46832a4f64.tar.gz
gentoo-ab9ec50262cc4bfe300af030c08abd46832a4f64.tar.bz2
gentoo-ab9ec50262cc4bfe300af030c08abd46832a4f64.zip
sci-libs/ideep: new package, add 3.1.1
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'sci-libs/ideep')
-rw-r--r--sci-libs/ideep/Manifest1
-rw-r--r--sci-libs/ideep/files/ideep-3.1.1-20230825.patch36
-rw-r--r--sci-libs/ideep/ideep-3.1.1.ebuild22
-rw-r--r--sci-libs/ideep/metadata.xml11
4 files changed, 70 insertions, 0 deletions
diff --git a/sci-libs/ideep/Manifest b/sci-libs/ideep/Manifest
new file mode 100644
index 000000000000..6139a10e440e
--- /dev/null
+++ b/sci-libs/ideep/Manifest
@@ -0,0 +1 @@
+DIST ideep-3.1.1.tar.gz 57015 BLAKE2B 054bb0363b5a6e8c40bf1192d557163f2e90195cbf3387562d5bf05a18eb0f3f2a45e5398ed0895ecc07807e753ab4f1a6375b12ede06aea33cc22e1e1d9cdb4 SHA512 1d636072512d90c1c47c0a976787a1fdaecdbd993ee319c40a2fbbc702143a0a752128e76e99f483d5628f64814684aa39b7355b2df675a4247037ddeeff03e5
diff --git a/sci-libs/ideep/files/ideep-3.1.1-20230825.patch b/sci-libs/ideep/files/ideep-3.1.1-20230825.patch
new file mode 100644
index 000000000000..a8625e758b00
--- /dev/null
+++ b/sci-libs/ideep/files/ideep-3.1.1-20230825.patch
@@ -0,0 +1,36 @@
+From 6f4d653802bd43bc4eda515460df9f90353dbebe Mon Sep 17 00:00:00 2001
+From: leslie-fang-intel <leslie.fang@intel.com>
+Date: Fri, 25 Aug 2023 13:37:20 +0800
+Subject: [PATCH] reland remove conv weight scale reciprocal (#226)
+
+---
+ include/ideep.hpp | 2 +-
+ include/ideep/operators/conv.hpp | 3 ---
+ 2 files changed, 1 insertion(+), 4 deletions(-)
+
+diff --git a/include/ideep.hpp b/include/ideep.hpp
+index 7e02c366..a11c3553 100644
+--- a/include/ideep.hpp
++++ b/include/ideep.hpp
+@@ -48,6 +48,6 @@
+ #define IDEEP_VERSION_MAJOR DNNL_VERSION_MAJOR
+ #define IDEEP_VERSION_MINOR DNNL_VERSION_MINOR
+ #define IDEEP_VERSION_PATCH DNNL_VERSION_PATCH
+-#define IDEEP_VERSION_REVISION 0
++#define IDEEP_VERSION_REVISION 1
+
+ #endif
+diff --git a/include/ideep/operators/conv.hpp b/include/ideep/operators/conv.hpp
+index 49677ff6..27ee84b6 100644
+--- a/include/ideep/operators/conv.hpp
++++ b/include/ideep/operators/conv.hpp
+@@ -161,9 +161,6 @@ struct conv_deconv_utils {
+ weights_scales_in.size(), oc_per_group, groups, is_deconv);
+ auto wei_scales = weights_scales_in;
+ if (!std::all_of(wei_scales.begin(), wei_scales.end(), [](float i){ return i == 1.0f; })) {
+- for (auto& s : wei_scales) {
+- s = 1.0 / s;
+- }
+ op_attr.set_scales(DNNL_ARG_WEIGHTS, wei_scale_mask, wei_scales);
+ }
+ if (dst_scales_in[0] != 1.0f) {
diff --git a/sci-libs/ideep/ideep-3.1.1.ebuild b/sci-libs/ideep/ideep-3.1.1.ebuild
new file mode 100644
index 000000000000..8f892eea0ed5
--- /dev/null
+++ b/sci-libs/ideep/ideep-3.1.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MYP=pytorch-rls-v${PV}
+DESCRIPTION="Intel® Optimization for Chainer"
+HOMEPAGE="https://github.com/intel/ideep"
+SRC_URI="https://github.com/intel/${PN}/archive/refs/tags/${MYP}.tar.gz
+ -> ${PF}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+PATCHES=( "${FILESDIR}"/${P}-20230825.patch )
+
+S="${WORKDIR}"/ideep-${MYP}
+
+src_install() {
+ doheader -r include/*
+}
diff --git a/sci-libs/ideep/metadata.xml b/sci-libs/ideep/metadata.xml
new file mode 100644
index 000000000000..953b04a60d15
--- /dev/null
+++ b/sci-libs/ideep/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>tupone@gentoo.org</email>
+ <name>Tupone Alfredo</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">intel/ideep</remote-id>
+ </upstream>
+</pkgmetadata>