summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2024-04-05 11:02:46 +0200
committerAlfredo Tupone <tupone@gentoo.org>2024-04-05 11:02:59 +0200
commit7503c0185a08afe6b9094d5df17d123defbbf255 (patch)
tree14aa1ea4bafa77472f29d48357661c7c9ba9cfc7 /sci-libs/huggingface_hub
parentdev-libs/tree-sitter-typescript: fix test invocation (diff)
downloadgentoo-7503c0185a08afe6b9094d5df17d123defbbf255.tar.gz
gentoo-7503c0185a08afe6b9094d5df17d123defbbf255.tar.bz2
gentoo-7503c0185a08afe6b9094d5df17d123defbbf255.zip
sci-libs/huggingface_hub: add 0.21.4
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'sci-libs/huggingface_hub')
-rw-r--r--sci-libs/huggingface_hub/Manifest1
-rw-r--r--sci-libs/huggingface_hub/huggingface_hub-0.21.4.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/sci-libs/huggingface_hub/Manifest b/sci-libs/huggingface_hub/Manifest
index 93ca38234cec..3c604dceedeb 100644
--- a/sci-libs/huggingface_hub/Manifest
+++ b/sci-libs/huggingface_hub/Manifest
@@ -1 +1,2 @@
DIST huggingface_hub-0.20.3.gh.tar.gz 3276706 BLAKE2B 2dd9fe557db4e88481bcc675dd1d6d35ec26244b723ea6bed01555e20fcba1dfa269ab3a1de9c8afa21d25b57550f822ca05bfd9d54db7e7b4740116c5ea3469 SHA512 b6eb9875da4d3c0b7190e61beee14ba913fb0f967967a70a6a65e5d42881e06710fb132e471c6e9b0ea1cd0987b2ebd31754d90aded3a84f4ddcfb0a0efe2f21
+DIST huggingface_hub-0.21.4.gh.tar.gz 3565936 BLAKE2B 8aac3ca36369040fe8f7b628cc07a5d890b845d3bfec0dcf6cf7fc477c5c30d680c2dc0531d92c5e814d86f098fad87c80113f37719b41a1eac696f6abd82372 SHA512 886e553c474b59a47d1c5e04c7429ca5c1eb6bcb88a0f7ed6f1396d43c3195bb1f376093384f40497f18fb2220e3e0d9c4b7787c009b84d1d38b6d706307f67f
diff --git a/sci-libs/huggingface_hub/huggingface_hub-0.21.4.ebuild b/sci-libs/huggingface_hub/huggingface_hub-0.21.4.ebuild
new file mode 100644
index 000000000000..c033a2a89d94
--- /dev/null
+++ b/sci-libs/huggingface_hub/huggingface_hub-0.21.4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+inherit distutils-r1
+
+DESCRIPTION="a client library to interact with the Hugging Face Hub"
+HOMEPAGE="
+ https://pypi.org/project/huggingface_hub/
+"
+SRC_URI="https://github.com/huggingface/${PN}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="test" #Several modules not yet packaged
+
+RDEPEND="
+ dev-python/filelock[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/tqdm[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest