summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2017-10-24 17:24:30 +0700
committerAndrey Grozin <grozin@gentoo.org>2017-10-24 17:24:30 +0700
commit8b549d5e1df24d0d3a36e7454b84d04f7bec281b (patch)
tree70a1d9edbefd30c6d76e621e5ef8feaeed5f465d /sci-geosciences/routino
parentdev-perl/Getopt-GUI-Long: keyword ~arm (diff)
downloadgentoo-8b549d5e1df24d0d3a36e7454b84d04f7bec281b.tar.gz
gentoo-8b549d5e1df24d0d3a36e7454b84d04f7bec281b.tar.bz2
gentoo-8b549d5e1df24d0d3a36e7454b84d04f7bec281b.zip
sci-geosciences/routino: making QA checks happy
Suggested-by: Fabio Rossi <rossi.f@inwind.it> Closes: https://bugs.gentoo.org/628398 Package-Manager: Portage-2.3.11, Repoman-2.3.3
Diffstat (limited to 'sci-geosciences/routino')
-rw-r--r--sci-geosciences/routino/files/routino-3.1.1.patch38
-rw-r--r--sci-geosciences/routino/files/routino-3.2.patch42
-rw-r--r--sci-geosciences/routino/routino-3.1.1.ebuild17
-rw-r--r--sci-geosciences/routino/routino-3.2.ebuild15
4 files changed, 89 insertions, 23 deletions
diff --git a/sci-geosciences/routino/files/routino-3.1.1.patch b/sci-geosciences/routino/files/routino-3.1.1.patch
index 15ba41b73feb..ac54fcf9f887 100644
--- a/sci-geosciences/routino/files/routino-3.1.1.patch
+++ b/sci-geosciences/routino/files/routino-3.1.1.patch
@@ -1,17 +1,22 @@
-diff -r -U1 routino-3.1.1.orig/Makefile.conf routino-3.1.1/Makefile.conf
---- routino-3.1.1.orig/Makefile.conf 2016-03-05 19:49:21.000000000 +0600
-+++ routino-3.1.1/Makefile.conf 2016-07-16 20:09:22.208869580 +0600
-@@ -47,3 +47,3 @@
+--- routino-3.1.1/Makefile.conf 2017-10-22 15:55:10.420531850 +0200
++++ routino-3.1.1/Makefile.conf.new 2017-10-22 15:55:32.180533067 +0200
+@@ -45,11 +45,11 @@
+ # Installation locations (edit if required)
+
ifneq ($(HOST),MINGW)
-prefix=/usr/local
+prefix=/usr
bindir=$(prefix)/bin
-@@ -51,3 +51,3 @@
+ incdir=$(prefix)/include
libdir=$(prefix)/lib
-docdir=$(prefix)/doc/routino
+docdir=$(prefix)/share/doc/$(PF)
datadir=$(prefix)/share/routino
-@@ -76,6 +76,6 @@
+ else
+ prefix="c:/Program Files/Routino"
+@@ -74,16 +74,16 @@
+
+
# Maths library
-LDFLAGS=-lm
+LDFLAGS+=-lm
@@ -20,15 +25,32 @@ diff -r -U1 routino-3.1.1.orig/Makefile.conf routino-3.1.1/Makefile.conf
-CFLAGS=-std=c99
+CFLAGS+=-std=c99
-@@ -85,3 +85,3 @@
+ # Warning options
+ CFLAGS+=-Wall -Wmissing-prototypes -Wextra -Wno-unused-parameter -pedantic
+
# Optimisation options
-CFLAGS+=-O3
+#CFLAGS+=-O3
CFLAGS+=-ffast-math
-@@ -141,4 +141,4 @@
+
+ # Optimisation option (only works if compilation and execution use exactly the same CPU architecture).
+@@ -118,7 +118,7 @@
+ endif
+
+ # Put the current directory in the shared library path for the router using libroutino
+-LDFLAGS_LDSO=-Wl,-R.
++#LDFLAGS_LDSO=-Wl,-R.
+
+
+ # Required for multi-threaded support (comment these two lines out if not required)
+@@ -139,8 +139,8 @@
+
+
# Required for xz support (uncomment these two lines if required)
-#CFLAGS+=-DUSE_XZ
-#LDFLAGS+=-llzma
+CFLAGS+=-DUSE_XZ
+LDFLAGS+=-llzma
+
+ # Required to use stdio with files > 2GiB on 32-bit system.
diff --git a/sci-geosciences/routino/files/routino-3.2.patch b/sci-geosciences/routino/files/routino-3.2.patch
index 484b61b68f10..81b6c4d938c9 100644
--- a/sci-geosciences/routino/files/routino-3.2.patch
+++ b/sci-geosciences/routino/files/routino-3.2.patch
@@ -1,30 +1,56 @@
-diff -r -U1 routino-3.2.orig/Makefile.conf routino-3.2/Makefile.conf
---- routino-3.2.orig/Makefile.conf 2016-11-22 20:22:52.000000000 +0100
-+++ routino-3.2/Makefile.conf 2017-04-01 23:58:23.835905270 +0200
-@@ -47,3 +47,3 @@
+--- routino-3.2/Makefile.conf 2017-10-22 16:03:29.917559780 +0200
++++ routino-3.2/Makefile.conf.new 2017-10-22 16:04:23.877562797 +0200
+@@ -45,11 +45,11 @@
+ # Installation locations (edit if required)
+
ifneq ($(HOST),MINGW)
-prefix=/usr/local
+prefix=/usr
bindir=$(prefix)/bin
-@@ -51,3 +51,3 @@
+ incdir=$(prefix)/include
libdir=$(prefix)/lib
-docdir=$(prefix)/doc/routino
+docdir=$(prefix)/share/doc/$(PF)
datadir=$(prefix)/share/routino
-@@ -79,3 +79,3 @@
+ else
+ prefix="c:/Program Files/Routino"
+@@ -74,16 +74,16 @@
+
+
+ # Maths library
+-LDFLAGS=-lm
++LDFLAGS+=-lm
+
# Language dialect selection
-CFLAGS=-std=c99
+CFLAGS+=-std=c99
-@@ -85,3 +85,3 @@
+ # Warning options
+ CFLAGS+=-Wall -Wmissing-prototypes -Wextra -Wno-unused-parameter -pedantic
+
# Optimisation options
-CFLAGS+=-O3
+#CFLAGS+=-O3
CFLAGS+=-ffast-math
-@@ -141,4 +141,4 @@
+
+ # Optimisation option (only works if compilation and execution use exactly the same CPU architecture).
+@@ -118,7 +118,7 @@
+ endif
+
+ # Put the current directory in the shared library path for the router using libroutino
+-LDFLAGS_LDSO=-Wl,-R.
++#LDFLAGS_LDSO=-Wl,-R.
+
+
+ # Required for multi-threaded support (comment these two lines out if not required)
+@@ -139,8 +139,8 @@
+
+
# Required for xz support (uncomment these two lines if required)
-#CFLAGS+=-DUSE_XZ
-#LDFLAGS+=-llzma
+CFLAGS+=-DUSE_XZ
+LDFLAGS+=-llzma
+
+ # Required to use stdio with files > 2GiB on 32-bit system.
diff --git a/sci-geosciences/routino/routino-3.1.1.ebuild b/sci-geosciences/routino/routino-3.1.1.ebuild
index 54aadaee9dd2..724e40b20799 100644
--- a/sci-geosciences/routino/routino-3.1.1.ebuild
+++ b/sci-geosciences/routino/routino-3.1.1.ebuild
@@ -1,7 +1,10 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
+
EAPI=6
+inherit toolchain-funcs
+
DESCRIPTION="Routing application based on openstreetmap data"
HOMEPAGE="http://www.routino.org/"
SRC_URI="http://www.routino.org/download/${P}.tgz"
@@ -10,10 +13,16 @@ SLOT="0"
KEYWORDS="amd64 x86"
IUSE=""
DEPEND=""
-PATCHES=( "${FILESDIR}"/${P}.patch )
-src_configure() {
- :
+src_prepare() {
+ eapply "${FILESDIR}"/${P}.patch
+
+ sed -i -e "s@libdir=\(.*\)@libdir=\$(prefix)/$(get_libdir)@" \
+ -e "s@CC=gcc@CC=$(tc-getCC)@" \
+ -e "s@LD=gcc@LD=$(tc-getCC)@" \
+ Makefile.conf || die "failed sed"
+
+ eapply_user
}
src_compile() {
diff --git a/sci-geosciences/routino/routino-3.2.ebuild b/sci-geosciences/routino/routino-3.2.ebuild
index cb1ceff2cd3c..19512b20efa7 100644
--- a/sci-geosciences/routino/routino-3.2.ebuild
+++ b/sci-geosciences/routino/routino-3.2.ebuild
@@ -1,7 +1,10 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
+
EAPI=6
+inherit toolchain-funcs
+
DESCRIPTION="Routing application based on openstreetmap data"
HOMEPAGE="http://www.routino.org/"
SRC_URI="http://www.routino.org/download/${P}.tgz"
@@ -10,10 +13,16 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
DEPEND=""
-PATCHES=( "${FILESDIR}"/${P}.patch )
-src_configure() {
- :
+src_prepare() {
+ eapply "${FILESDIR}"/${P}.patch
+
+ sed -i -e "s@libdir=\(.*\)@libdir=\$(prefix)/$(get_libdir)@" \
+ -e "s@CC=gcc@CC=$(tc-getCC)@" \
+ -e "s@LD=gcc@LD=$(tc-getCC)@" \
+ Makefile.conf || die "failed sed"
+
+ eapply_user
}
src_compile() {