summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-geosciences/libtcd
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-geosciences/libtcd')
-rw-r--r--sci-geosciences/libtcd/Manifest2
-rw-r--r--sci-geosciences/libtcd/libtcd-2.2.5_p2.ebuild33
-rw-r--r--sci-geosciences/libtcd/libtcd-2.2.6.ebuild33
-rw-r--r--sci-geosciences/libtcd/metadata.xml8
4 files changed, 76 insertions, 0 deletions
diff --git a/sci-geosciences/libtcd/Manifest b/sci-geosciences/libtcd/Manifest
new file mode 100644
index 000000000000..ab7f11f0e001
--- /dev/null
+++ b/sci-geosciences/libtcd/Manifest
@@ -0,0 +1,2 @@
+DIST libtcd-2.2.5-r2.tar.bz2 294449 SHA256 021d9f87986d41aa52c5318c04c49a36e6e122f6b1d16f1d91b82438ff8e767c SHA512 125b8f4258c576d82f86f75c9dec4e6e0dba8d46e897835ff8ee57cb58495c3f2ae42040719aa8a6f0fa70be40dbc3eb082250cfa197f15f0b23d2ee37a47fbd WHIRLPOOL 136c829b564382d0cbc07cdcf6fec885f7da67d2a1fade9405d5fe105d4c9274796d8efde22dc4e1f2697f5690775a17f2b6c7275ec809edb643a3669856ebfe
+DIST libtcd-2.2.6.tar.bz2 300738 SHA256 6cce7dd18c9f04d40837010d1dded08faf07754cd2595073ef165e2e14dd0c14 SHA512 e0c5c35a72617c013fa2cfe94c0aff16c9d14870aa1b3ab14bf1a01715df8f8d9e9acbfa07c60275ea95266f1debbe1b61aa46e47344bba38ec64286bf2ca1eb WHIRLPOOL 796fc95d044b0b3db34c06d8ceae38f554a2c1f3108f62523aa25a795a628b39ddec2872f895397011678f84837ecb254214ec762d55737dd8d9e37f2979cc54
diff --git a/sci-geosciences/libtcd/libtcd-2.2.5_p2.ebuild b/sci-geosciences/libtcd/libtcd-2.2.5_p2.ebuild
new file mode 100644
index 000000000000..b53ae5ae02a4
--- /dev/null
+++ b/sci-geosciences/libtcd/libtcd-2.2.5_p2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+MY_P=${PN}-${PV/_p/-r}
+DESCRIPTION="Library for reading and writing Tide Constituent Database (TCD) files"
+HOMEPAGE="http://www.flaterco.com/xtide/libtcd.html"
+SRC_URI="ftp://ftp.flaterco.com/xtide/${MY_P}.tar.bz2"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc static-libs"
+
+DEPEND=">=sci-geosciences/harmonics-dwf-free-20120302"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"/${P%_*}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ use static-libs || prune_libtool_files
+ use doc && dohtml libtcd.html
+}
diff --git a/sci-geosciences/libtcd/libtcd-2.2.6.ebuild b/sci-geosciences/libtcd/libtcd-2.2.6.ebuild
new file mode 100644
index 000000000000..e0e50ff791f0
--- /dev/null
+++ b/sci-geosciences/libtcd/libtcd-2.2.6.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+MY_P=${PN}-${PV/_p/-r}
+DESCRIPTION="Library for reading and writing Tide Constituent Database (TCD) files"
+HOMEPAGE="http://www.flaterco.com/xtide/libtcd.html"
+SRC_URI="ftp://ftp.flaterco.com/xtide/${MY_P}.tar.bz2"
+
+LICENSE="public-domain"
+SLOT="0/1"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc static-libs"
+
+DEPEND=">=sci-geosciences/harmonics-dwf-free-20120302"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"/${P%_*}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ use static-libs || prune_libtool_files
+ use doc && dohtml libtcd.html
+}
diff --git a/sci-geosciences/libtcd/metadata.xml b/sci-geosciences/libtcd/metadata.xml
new file mode 100644
index 000000000000..e96e35b1a37c
--- /dev/null
+++ b/sci-geosciences/libtcd/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
+