summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-geosciences/gpscorrelate
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-geosciences/gpscorrelate')
-rw-r--r--sci-geosciences/gpscorrelate/Manifest1
-rw-r--r--sci-geosciences/gpscorrelate/files/gpscorrelate-1.6.1-makefile.patch47
-rw-r--r--sci-geosciences/gpscorrelate/gpscorrelate-1.6.1.ebuild50
-rw-r--r--sci-geosciences/gpscorrelate/metadata.xml8
4 files changed, 106 insertions, 0 deletions
diff --git a/sci-geosciences/gpscorrelate/Manifest b/sci-geosciences/gpscorrelate/Manifest
new file mode 100644
index 000000000000..6c7b82318dfc
--- /dev/null
+++ b/sci-geosciences/gpscorrelate/Manifest
@@ -0,0 +1 @@
+DIST gpscorrelate-1.6.1.tar.gz 154531 RMD160 a0642c882e347793488a3b279a9b4384ce8ae57a SHA1 f7f0b42018759ee42b31113a70e17764f21e0de4 SHA256 966285c0a6df5ac2cc63c1f9650e65c70e303cf11d08dc283357bcd745cb5201
diff --git a/sci-geosciences/gpscorrelate/files/gpscorrelate-1.6.1-makefile.patch b/sci-geosciences/gpscorrelate/files/gpscorrelate-1.6.1-makefile.patch
new file mode 100644
index 000000000000..f48dba1882f2
--- /dev/null
+++ b/sci-geosciences/gpscorrelate/files/gpscorrelate-1.6.1-makefile.patch
@@ -0,0 +1,47 @@
+diff -urN gpscorrelate-1.6.1.old/Makefile gpscorrelate-1.6.1/Makefile
+--- gpscorrelate-1.6.1.old/Makefile 2011-06-08 13:51:06.000000000 +0200
++++ gpscorrelate-1.6.1/Makefile 2011-06-08 14:13:18.000000000 +0200
+@@ -4,11 +4,15 @@
+
+ COBJS = main-command.o unixtime.o gpx-read.o correlate.o exif-gps.o
+ GOBJS = main-gui.o gui.o unixtime.o gpx-read.o correlate.o exif-gps.o
+-CFLAGS = -Wall
+-override CFLAGS += $(shell pkg-config --cflags libxml-2.0 gtk+-2.0) -I/usr/include/exiv2
+-OFLAGS = -Wall
+-override OFLAGS += $(shell pkg-config --libs libxml-2.0 gtk+-2.0) -lm -lexiv2
+-prefix = /usr/local
++CFLAGS += $(shell pkg-config --cflags libxml-2.0) -I/usr/include/exiv2
++CXXFLAGS += $(shell pkg-config --cflags libxml-2.0) -I/usr/include/exiv2
++CLIBS = $(shell pkg-config --libs libxml-2.0) -lm -lexiv2 -lstdc++
++ifdef BUILD_GUI
++CXXFLAGS += $(shell pkg-config --cflags gtk+-2.0)
++CFLAGS += $(shell pkg-config --cflags gtk+-2.0)
++CLIBS += $(shell pkg-config --libs gtk+-2.0)
++endif
++prefix ?= /usr/local
+ bindir = $(prefix)/bin
+ datadir = $(prefix)/share
+ mandir = $(datadir)/man
+@@ -18,16 +22,16 @@
+ all: gpscorrelate gpscorrelate-gui gpscorrelate.1
+
+ gpscorrelate: $(COBJS)
+- g++ $(OFLAGS) -o $@ $(COBJS)
++ $(CXX) $(LDFLAGS) $(COBJS) $(CLIBS) -o $@
+
+ gpscorrelate-gui: $(GOBJS)
+- g++ $(OFLAGS) -o $@ $(GOBJS)
++ $(CXX) $(LDFLAGS) $(GOBJS) $(CLIBS) -o $@
+
+-.c.o:
+- gcc $(CFLAGS) -c -o $*.o $<
++%.o: %.c
++ $(CC) -c -o $@ $< $(CFLAGS)
+
+-.cpp.o:
+- g++ $(CFLAGS) -c -o $*.o $<
++%.o: %.cpp $(DEPS)
++ $(CXX) -c -o $@ $< $(CXXFLAGS)
+
+ clean:
+ rm -f *.o gpscorrelate{,.exe} gpscorrelate-gui{,.exe}
diff --git a/sci-geosciences/gpscorrelate/gpscorrelate-1.6.1.ebuild b/sci-geosciences/gpscorrelate/gpscorrelate-1.6.1.ebuild
new file mode 100644
index 000000000000..9de48fcb77cb
--- /dev/null
+++ b/sci-geosciences/gpscorrelate/gpscorrelate-1.6.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Tool for adjusting EXIF tags of your photos with a recorded GPS trace"
+HOMEPAGE="http://freefoote.dview.net/linux_gpscorr.html"
+SRC_URI="http://freefoote.dview.net/linux/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+IUSE="doc gtk"
+
+RDEPEND="dev-libs/libxml2:2
+ media-gfx/exiv2
+ gtk? ( x11-libs/gtk+:2 )
+"
+DEPEND="${RDEPEND}
+ app-text/docbook-xml-dtd:4.2
+ dev-libs/libxslt
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-1.6.1-makefile.patch"
+}
+
+src_compile() {
+ tc-export CC CXX
+ local opts="gpscorrelate gpscorrelate.1"
+ use gtk && opts+=" gpscorrelate-gui BUILD_GUI=1"
+ emake ${opts}
+}
+
+src_install() {
+ dobin ${PN}
+ if use gtk; then
+ dobin ${PN}-gui
+ doicon ${PN}-gui.svg
+ domenu ${PN}.desktop
+ fi
+ if use doc; then
+ dohtml doc/*
+ fi
+ doman ${PN}.1
+}
diff --git a/sci-geosciences/gpscorrelate/metadata.xml b/sci-geosciences/gpscorrelate/metadata.xml
new file mode 100644
index 000000000000..3beda91ba209
--- /dev/null
+++ b/sci-geosciences/gpscorrelate/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-geosciences</herd>
+ <maintainer>
+ <email>hanno@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>