summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2025-01-02 18:32:15 +0000
committerSam James <sam@gentoo.org>2025-01-02 18:32:15 +0000
commit4844ae6805cc0eae91579bb9a8350e3c0a3f77e6 (patch)
treea18f621160219086a792a49402dd2a8f9d8955bf /sci-electronics
parenttoolchain.eclass: cleanup /etc/clang/gentoo-gcc-install.cfg on removing last GCC (diff)
downloadgentoo-4844ae6805cc0eae91579bb9a8350e3c0a3f77e6.tar.gz
gentoo-4844ae6805cc0eae91579bb9a8350e3c0a3f77e6.tar.bz2
gentoo-4844ae6805cc0eae91579bb9a8350e3c0a3f77e6.zip
sci-electronics/pulseview: build w/ -std=c++17
As Jannik mentions in the bug, modern Boost needs >= C++14, so crank up the version used. This is fixed upstream in the git repo but not in a release. Closes: https://bugs.gentoo.org/946610 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/pulseview/pulseview-0.4.2-r1.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/sci-electronics/pulseview/pulseview-0.4.2-r1.ebuild b/sci-electronics/pulseview/pulseview-0.4.2-r1.ebuild
index 0b5446455b34..97332060d41f 100644
--- a/sci-electronics/pulseview/pulseview-0.4.2-r1.ebuild
+++ b/sci-electronics/pulseview/pulseview-0.4.2-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2024 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="8"
@@ -50,6 +50,10 @@ src_prepare() {
}
src_configure() {
+ # Needed for modern Boost (bug #946610).
+ # Drop this on bump > 0.4.2.
+ sed -i -e 's:-std=c++11:-std=c++17:' CMakeLists.txt || die
+
local mycmakeargs=(
-DDISABLE_WERROR=TRUE
-DENABLE_DECODE=$(usex decode)