summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-electronics/qucs
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-electronics/qucs')
-rw-r--r--sci-electronics/qucs/Manifest1
-rw-r--r--sci-electronics/qucs/metadata.xml12
-rw-r--r--sci-electronics/qucs/qucs-0.0.17.130503.ebuild33
3 files changed, 46 insertions, 0 deletions
diff --git a/sci-electronics/qucs/Manifest b/sci-electronics/qucs/Manifest
new file mode 100644
index 000000000000..ee0a91f27678
--- /dev/null
+++ b/sci-electronics/qucs/Manifest
@@ -0,0 +1 @@
+DIST qucs-0.0.17.130503.tar.gz 10380925 SHA256 28dff7da734d9910b362a0f3e4594aefb9986bde3f37e15aff2b9068e41ad774 SHA512 93ed20b34a5fa0c8dac7711d6797d373e5da90e727822b96c268f8fb284928bbde397274db2c638a5190d5916ca2bf55e849de95f327e0c55b3877b8897bb765 WHIRLPOOL ea590687cb44318473179c63704305720c0c5f3cc4c9816d798617ef745e5ee1dae3b4494e351bcdcc924eba25601c97e7cdfe8a2704c5c5b353dee6ac87a38c
diff --git a/sci-electronics/qucs/metadata.xml b/sci-electronics/qucs/metadata.xml
new file mode 100644
index 000000000000..cf8c179db29c
--- /dev/null
+++ b/sci-electronics/qucs/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-electronics</herd>
+ <maintainer>
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">qucs</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sci-electronics/qucs/qucs-0.0.17.130503.ebuild b/sci-electronics/qucs/qucs-0.0.17.130503.ebuild
new file mode 100644
index 000000000000..7de4da3f285f
--- /dev/null
+++ b/sci-electronics/qucs/qucs-0.0.17.130503.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-utils flag-o-matic toolchain-funcs
+
+DESCRIPTION="Quite Universal Circuit Simulator in Qt4"
+HOMEPAGE="http://qucs.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-qt/qtcore:4[qt3support]
+ dev-qt/qtgui:4[qt3support]
+ dev-qt/qt3support:4
+ x11-libs/libX11"
+DEPEND="${RDEPEND}"
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+src_configure() {
+ # the package doesn't use pkg-config on Linux, only on Darwin
+ # very smart of upstream...
+ append-ldflags $( $(tc-getPKG_CONFIG) --libs-only-L \
+ QtCore QtGui QtXml Qt3Support )
+
+ autotools-utils_src_configure
+}