summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-electronics/gplcver
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-electronics/gplcver')
-rw-r--r--sci-electronics/gplcver/Manifest2
-rw-r--r--sci-electronics/gplcver/gplcver-2.11a.ebuild59
-rw-r--r--sci-electronics/gplcver/gplcver-2.12a.ebuild65
-rw-r--r--sci-electronics/gplcver/metadata.xml12
4 files changed, 138 insertions, 0 deletions
diff --git a/sci-electronics/gplcver/Manifest b/sci-electronics/gplcver/Manifest
new file mode 100644
index 000000000000..37212f666370
--- /dev/null
+++ b/sci-electronics/gplcver/Manifest
@@ -0,0 +1,2 @@
+DIST gplcver-2.11a.src.tar.bz2 1189439 SHA256 b64eea22f354bee2de09532309c6a1e3f3658c427fe2d063ef3921c1042fa380
+DIST gplcver-2.12a.src.tar.bz2 1224470 SHA256 f7d94677677f10c2d1e366eda2d01a652ef5f30d167660905c100f52f1a46e75 SHA512 62835fd32c37865590c56e4e04cdd2b1e0918551a927fafe35a2b0838082af2af903e714d2afc0f28d76eb5c077e5b3f56cbf671dee5f38717ddea68a35753e5 WHIRLPOOL 55f681d8f52fff0637b2e9ba93c9c1551353a21a064a71d5f269a20bbf1d400837512809eeadc083f3f18595a510182bd0227ad9662d4d33d83efd81a3bd2e3f
diff --git a/sci-electronics/gplcver/gplcver-2.11a.ebuild b/sci-electronics/gplcver/gplcver-2.11a.ebuild
new file mode 100644
index 000000000000..91b176e402bf
--- /dev/null
+++ b/sci-electronics/gplcver/gplcver-2.11a.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+MY_PN=gpl-cver
+
+DESCRIPTION="Verilog simulator"
+HOMEPAGE="http://www.pragmatic-c.com/${MY_PN}"
+SRC_URI="http://www.pragmatic-c.com/${MY_PN}/downloads/${P}.src.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ~ppc"
+IUSE=""
+S=${WORKDIR}/${P}.src
+
+src_unpack() {
+ unpack ${A}
+ sed -i -e "s/^\(CFLAGS= .*\)/#\1\nCFLAGS=\$(WARNS) \$(INCS) ${CFLAGS}/" ${S}/src/makefile.lnx
+ sed -i -e "s/^\(CFLAGS= .*\)/#\1\nCFLAGS= ${CFLAGS}/" ${S}/vcddiff.dir/src/makefile.lnx
+}
+
+src_compile(){
+ cd ${S}/src
+ emake -f makefile.lnx || die
+ cd ${S}/vcddiff.dir/src
+ emake -f makefile.lnx || die
+}
+
+src_install() {
+ dodir /usr
+ dodir /usr/bin
+ dobin bin/cver bin/vcddiff || die
+ doman doc/systasks.1
+ dodoc doc/README doc/cver*[!htm] doc/dbg.hlp doc/systasks.pdf vcddiff.dir/README.vcddiff
+ dohtml doc/cver.faq.htm
+ dodir /usr/include/cver_pli_incs
+ insinto /usr/include/cver_pli_incs
+ doins pli_incs/*.h
+}
+
+src_test() {
+ # fixme: make tests die if something fails
+ cd ${S}/tests_and_examples/
+ # first verify install
+ cd install.tst
+ ./inst_tst.sh
+ # now individual tests
+ cd ../capacity.tst
+ ../../bin/cver -f lfsr.vc
+ diff verilog.log lfsr.plg
+ cd ../examples.acc
+ ./inst_pli.sh lnx
+ #opt_inst_pli.sh lnx
+ cd ../examples.tf
+ ./inst_pli.sh lnx
+ #opt_inst_pli.sh lnx
+ cd ../examples.vpi
+ ./inst_pli.sh lnx
+}
diff --git a/sci-electronics/gplcver/gplcver-2.12a.ebuild b/sci-electronics/gplcver/gplcver-2.12a.ebuild
new file mode 100644
index 000000000000..767eb05426d9
--- /dev/null
+++ b/sci-electronics/gplcver/gplcver-2.12a.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+MY_PN=gpl-cver
+
+DESCRIPTION="Verilog simulator"
+HOMEPAGE="http://sourceforge.net/projects/${PN}"
+SRC_URI="http://www.pragmatic-c.com/${MY_PN}/downloads/${P}.src.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+S=${WORKDIR}/${P}.src
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e "s/^CFLAGS/#CFLAGS/" \
+ -e "s/(CFLAGS)/(INCS) \$(CFLAGS)/" \
+ -e "s/(LFLAGS)/(LFLAGS) \$(LDFLAGS)/" \
+ src/makefile.* || die "sed failed"
+ sed -i \
+ -e "s/^CFLAGS/#CFLAGS/" \
+ -e "s/(OPTFLGS) vcddiff.o/(LDFLAGS) vcddiff.o/" \
+ vcddiff.dir/src/makefile.* || die "sed failed"
+}
+
+src_compile(){
+ cd "${S}"/src
+ emake -f makefile.lnx || die "emake failed"
+ cd "${S}"/vcddiff.dir/src
+ emake -f makefile.lnx || die "emake failed"
+}
+
+src_install() {
+ dobin bin/cver bin/vcddiff || die "Failed installing binaries"
+ doman doc/systasks.1
+ dodoc doc/README doc/cver*[!htm] doc/dbg.hlp doc/systasks.pdf vcddiff.dir/README.vcddiff
+ dohtml doc/cver.faq.htm
+ dodir /usr/include/cver_pli_incs
+ insinto /usr/include/cver_pli_incs
+ doins pli_incs/*.h
+}
+
+src_test() {
+ # fixme: make tests die if something fails
+ cd "${S}"/tests_and_examples/
+ # first verify install
+ cd install.tst
+ ./inst_tst.sh
+ # now individual tests
+ cd ../capacity.tst
+ ../../bin/cver -f lfsr.vc
+ diff verilog.log lfsr.plg
+ cd ../examples.acc
+ ./inst_pli.sh lnx
+ #opt_inst_pli.sh lnx
+ cd ../examples.tf
+ ./inst_pli.sh lnx
+ #opt_inst_pli.sh lnx
+ cd ../examples.vpi
+ ./inst_pli.sh lnx
+}
diff --git a/sci-electronics/gplcver/metadata.xml b/sci-electronics/gplcver/metadata.xml
new file mode 100644
index 000000000000..f07e8be172e6
--- /dev/null
+++ b/sci-electronics/gplcver/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-electronics</herd>
+ <longdescription>
+ GPL Cver is a Verilog HDL simulator that is released under the GNU General
+ Public License. GPL Cver is a full 1995 P1364 Verilog standard HDL simulator.
+ It also implements some of the 2001 P1364 standard features including all
+ three PLI interfaces (tf_, acc_ and vpi_) as defined in the 2001 Language
+ Reference Manual (LRM).
+ </longdescription>
+</pkgmetadata>