summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-electronics/geda
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-electronics/geda')
-rw-r--r--sci-electronics/geda/Manifest3
-rw-r--r--sci-electronics/geda/geda-1.8.1.ebuild81
-rw-r--r--sci-electronics/geda/geda-1.8.2.ebuild82
-rw-r--r--sci-electronics/geda/geda-1.9.1.ebuild84
-rw-r--r--sci-electronics/geda/metadata.xml22
5 files changed, 272 insertions, 0 deletions
diff --git a/sci-electronics/geda/Manifest b/sci-electronics/geda/Manifest
new file mode 100644
index 000000000000..ac941c81c417
--- /dev/null
+++ b/sci-electronics/geda/Manifest
@@ -0,0 +1,3 @@
+DIST geda-gaf-1.8.1.tar.gz 11197244 SHA256 026888ce21cb83a3543a7554de0ddc610cc8dc6ce2341df17c5b3305d6dcbb10 SHA512 16f88af81d514c3504625765c64ad1d2a45d3da6a4c75f68db30f51776ff56d907ce97fb69e39cc6347ee9bfa4b591a62240fec6cfc73c0f54b61285e118b35b WHIRLPOOL da6743d97428deb81dd80dad9ca2f8476643f21bb34386681e54edd1dccb241f5d016d8b3d1640a80aaab1233a1cc23f835fc340955b1524d2085cc5b50abc71
+DIST geda-gaf-1.8.2.tar.gz 11282353 SHA256 bbf4773aef1b5a51a8d6f4c3fa288c047340cc62dd6e14d7928fcc6e4051b721 SHA512 3a6fad455c3fd2b62e9788ff04ca33242f2e4701ec24089d8c4304ad5ca44af4901fc1c396b3f840e14a0be0729ff08561a82c6911e1d23ac4b8636534b4e764 WHIRLPOOL e4e6db1b7f6d2f37d99027f9a55797f7ac5a304bb4be474d6d57091121672a86e8dfa5131e830f9bc6335f57cb3864716ef17793b550b0df064e9d2c2b158038
+DIST geda-gaf-1.9.1.tar.gz 11566302 SHA256 563c4ae8ba72824e873094d9133425b8f142f7e5b25cd6da33f69b2d99c980a3 SHA512 1c10662162365f902e61ef0ff225aeff8620c02f9507d33d5656c4aa240e7371fab5576bd5d68139390ce583548f34304f75893e1b8ab8fbacee25ddbdb93719 WHIRLPOOL 1594b98889dae9a6a61a9e76a7a4561c4f211199646b4064d361c0cfa56fc9a24ff834d73bbf10c6c44164f05c1b8a70007023958398fae4c856c6a60a41bc2a
diff --git a/sci-electronics/geda/geda-1.8.1.ebuild b/sci-electronics/geda/geda-1.8.1.ebuild
new file mode 100644
index 000000000000..fc1219ec14c1
--- /dev/null
+++ b/sci-electronics/geda/geda-1.8.1.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils fdo-mime gnome2-utils versionator
+
+MY_PN=${PN}-gaf
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="GPL Electronic Design Automation (gEDA):gaf core package"
+HOMEPAGE="http://www.gpleda.org/"
+SRC_URI="http://ftp.geda-project.org/${MY_PN}/stable/v$(get_version_component_range 1-2)/${PV}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="debug doc examples nls stroke threads"
+
+CDEPEND="
+ dev-libs/glib:2
+ x11-libs/gtk+:2
+ >=x11-libs/cairo-1.2.0
+ >=dev-scheme/guile-1.8[deprecated]
+ nls? ( virtual/libintl )
+ stroke? ( >=dev-libs/libstroke-0.5.1 )"
+
+DEPEND="${CDEPEND}
+ sys-apps/groff
+ dev-util/desktop-file-utils
+ x11-misc/shared-mime-info
+ virtual/pkgconfig
+ nls? ( >=sys-devel/gettext-0.16 )"
+
+RDEPEND="${CDEPEND}
+ sci-electronics/electronics-menu"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS="AUTHORS NEWS README"
+
+src_prepare() {
+ if ! use doc ; then
+ sed -i -e '/^SUBDIRS = /s/docs//' Makefile.in || die
+ fi
+ if ! use examples ; then
+ sed -i -e 's/\texamples$//' Makefile.in || die
+ fi
+}
+
+src_configure() {
+ econf \
+ --docdir=/usr/share/doc/${PF} \
+ $(use_enable threads threads posix) \
+ $(use_with stroke libstroke) \
+ $(use_enable nls) \
+ $(use_enable debug assert) \
+ --disable-doxygen \
+ --disable-rpath \
+ --disable-update-xdg-database
+}
+
+src_test() {
+ emake -j1 check
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ gnome2_icon_cache_update
+}
diff --git a/sci-electronics/geda/geda-1.8.2.ebuild b/sci-electronics/geda/geda-1.8.2.ebuild
new file mode 100644
index 000000000000..292cd959e56d
--- /dev/null
+++ b/sci-electronics/geda/geda-1.8.2.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils fdo-mime flag-o-matic gnome2-utils versionator
+
+MY_PN=${PN}-gaf
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="GPL Electronic Design Automation (gEDA):gaf core package"
+HOMEPAGE="http://www.gpleda.org/"
+SRC_URI="http://ftp.geda-project.org/${MY_PN}/stable/v$(get_version_component_range 1-2)/${PV}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="debug doc examples nls stroke threads"
+
+CDEPEND="
+ dev-libs/glib:2
+ x11-libs/gtk+:2
+ >=x11-libs/cairo-1.2.0
+ >=dev-scheme/guile-1.8[deprecated]
+ nls? ( virtual/libintl )
+ stroke? ( >=dev-libs/libstroke-0.5.1 )"
+
+DEPEND="${CDEPEND}
+ sys-apps/groff
+ dev-util/desktop-file-utils
+ x11-misc/shared-mime-info
+ virtual/pkgconfig
+ nls? ( >=sys-devel/gettext-0.16 )"
+
+RDEPEND="${CDEPEND}
+ sci-electronics/electronics-menu"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS="AUTHORS NEWS README"
+
+src_prepare() {
+ append-libs -lgio-2.0
+ if ! use doc ; then
+ sed -i -e '/^SUBDIRS = /s/docs//' Makefile.in || die
+ fi
+ if ! use examples ; then
+ sed -i -e 's/\texamples$//' Makefile.in || die
+ fi
+}
+
+src_configure() {
+ econf \
+ --docdir=/usr/share/doc/${PF} \
+ $(use_enable threads threads posix) \
+ $(use_with stroke libstroke) \
+ $(use_enable nls) \
+ $(use_enable debug assert) \
+ --disable-doxygen \
+ --disable-rpath \
+ --disable-update-xdg-database
+}
+
+src_test() {
+ emake -j1 check
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ gnome2_icon_cache_update
+}
diff --git a/sci-electronics/geda/geda-1.9.1.ebuild b/sci-electronics/geda/geda-1.9.1.ebuild
new file mode 100644
index 000000000000..3ea743dc181c
--- /dev/null
+++ b/sci-electronics/geda/geda-1.9.1.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils fdo-mime gnome2-utils versionator
+
+MY_PN=${PN}-gaf
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="GPL Electronic Design Automation (gEDA):gaf core package"
+HOMEPAGE="http://www.gpleda.org/"
+SRC_URI="http://ftp.geda-project.org/${MY_PN}/unstable/v$(get_version_component_range 1-2)/${PV}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug doc examples nls stroke threads"
+
+CDEPEND="
+ dev-libs/glib:2
+ x11-libs/gtk+:2
+ x11-libs/pango
+ >=x11-libs/cairo-1.2.0
+ x11-libs/gdk-pixbuf
+ >=dev-scheme/guile-1.8:12[deprecated]
+ nls? ( virtual/libintl )
+ stroke? ( >=dev-libs/libstroke-0.5.1 )"
+
+DEPEND="${CDEPEND}
+ sys-apps/groff
+ dev-util/desktop-file-utils
+ x11-misc/shared-mime-info
+ virtual/pkgconfig
+ nls? ( >=sys-devel/gettext-0.16 )"
+
+RDEPEND="${CDEPEND}
+ sci-electronics/electronics-menu"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS="AUTHORS NEWS README"
+
+src_prepare() {
+ append-libs -lgio-2.0
+ if ! use doc ; then
+ sed -i -e '/^SUBDIRS = /s/docs//' Makefile.in || die
+ fi
+ if ! use examples ; then
+ sed -i -e 's/\texamples$//' Makefile.in || die
+ fi
+}
+
+src_configure() {
+ econf \
+ --docdir=/usr/share/doc/${PF} \
+ $(use_enable threads threads posix) \
+ $(use_with stroke libstroke) \
+ $(use_enable nls) \
+ $(use_enable debug assert) \
+ --disable-doxygen \
+ --disable-rpath \
+ --disable-update-xdg-database
+}
+
+src_test() {
+ emake -j1 check
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ gnome2_icon_cache_update
+}
diff --git a/sci-electronics/geda/metadata.xml b/sci-electronics/geda/metadata.xml
new file mode 100644
index 000000000000..d8f1c8ca5dbd
--- /dev/null
+++ b/sci-electronics/geda/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-electronics</herd>
+ <longdescription>
+ The GPL Electronic Design Automation (gEDA) project has produced and
+ continues working on a full GPL'd suite and toolkit of Electronic
+ Design Automation tools. These tools are used for electrical circuit
+ design, schematic capture, simulation, prototyping, and
+ production. Currently, the gEDA project offers a mature suite of free
+ software applications for electronics design, including schematic
+ capture, attribute management, bill of materials (BOM) generation,
+ netlisting into over 20 netlist formats, analog and digital
+ simulation, and printed circuit board (PCB) layout.
+ The gEDA/gaf suite (this package) provides schematic capture,
+ netlisting, bill of materials generation, and many other features.
+ </longdescription>
+ <use>
+ <flag name='stroke'>enable mouse gesture support</flag>
+ </use>
+</pkgmetadata>
+