summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2017-07-06 16:20:30 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2017-07-06 21:31:12 +0000
commitb17325e1e27755c2f71c41776819887dbed294c6 (patch)
tree71c3c2e0aeb234cbd4d26ad75570e94c515d4395 /sci-astronomy/sofa_c/sofa_c-20170420.ebuild
parentsci-astronomy/casa-data: syntax header (diff)
downloadgentoo-b17325e1e27755c2f71c41776819887dbed294c6.tar.gz
gentoo-b17325e1e27755c2f71c41776819887dbed294c6.tar.bz2
gentoo-b17325e1e27755c2f71c41776819887dbed294c6.zip
sci-astronomy/sofa_c: version bump
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'sci-astronomy/sofa_c/sofa_c-20170420.ebuild')
-rw-r--r--sci-astronomy/sofa_c/sofa_c-20170420.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/sci-astronomy/sofa_c/sofa_c-20170420.ebuild b/sci-astronomy/sofa_c/sofa_c-20170420.ebuild
new file mode 100644
index 000000000000..d8382b0d7524
--- /dev/null
+++ b/sci-astronomy/sofa_c/sofa_c-20170420.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+YYYY=${PV:0:4}
+MMDD=${PV:4:4}
+#PP=${PV:8:1}
+MYPV=${YYYY}${MMDD}
+
+DESCRIPTION="Library for algorithms for models in fundamental astronomy"
+HOMEPAGE=" http://www.iausofa.org/current_C.html"
+SRC_URI="http://www.iausofa.org/${YYYY}_${MMDD}_C/${PN}-${MYPV}.tar.gz"
+
+LICENSE="SOFA"
+SLOT=0
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+RDEPEND=""
+DEPEND=""
+
+PATCHES=( "${FILESDIR}"/${PN}-makefile.patch )
+
+S="${WORKDIR}/sofa/${MYPV}/c/src"
+
+src_prepare() {
+ default
+ sed -i -e "s:/lib:/$(get_libdir):" makefile || die
+ tc-export CC
+}
+
+src_install() {
+ emake DESTDIR="${ED}" install
+ cd ..
+ dodoc 00READ.ME
+ use doc && dodoc doc/*.lis doc/*.pdf
+}