summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMario Haustein <mario.haustein@hrz.tu-chemnitz.de>2024-07-25 00:25:41 +0200
committerJoonas Niilola <juippis@gentoo.org>2024-08-04 11:16:30 +0300
commit0866832878a994a65d8d85a39a29e199dc411049 (patch)
treee4beced49572fbe2c944f78d394ca5b5eddf6e8b /sci-astronomy/sirilic
parentx11-themes/adwaita-icon-theme: Fix install for Gentoo Prefix systems. (diff)
downloadgentoo-0866832878a994a65d8d85a39a29e199dc411049.tar.gz
gentoo-0866832878a994a65d8d85a39a29e199dc411049.tar.bz2
gentoo-0866832878a994a65d8d85a39a29e199dc411049.zip
sci-astronomy/sirilic: add 1.15.9
Signed-off-by: Mario Haustein <mario.haustein@hrz.tu-chemnitz.de> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sci-astronomy/sirilic')
-rw-r--r--sci-astronomy/sirilic/Manifest1
-rw-r--r--sci-astronomy/sirilic/sirilic-1.15.9.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/sci-astronomy/sirilic/Manifest b/sci-astronomy/sirilic/Manifest
index 2e3a91f67cd9..51c636b88565 100644
--- a/sci-astronomy/sirilic/Manifest
+++ b/sci-astronomy/sirilic/Manifest
@@ -1,2 +1,3 @@
DIST sirilic-V1.15.7.tar.bz2 147712 BLAKE2B 9d7c87a65dffc122db7b33487d1fd509d012b9acee654db4c00cb485b329b4b584ae84f10e9510a69064d04833cfcbf796ada0984a9113d783116ec5381e6234 SHA512 6021986ade7b8f5e1cb7b7e8cee77706258f9dd9c5bf2c426518c93aab053f27a1733c664db86ca3c3a46c9752ba3e118c0c3698bd45785bb646e60b528a8eb1
DIST sirilic-V1.15.8.tar.bz2 148215 BLAKE2B b943091d15934266c99a6aa7a145b1d79af2145582bb66b76955eb028bf46a545a7ee0d53fce3123829d037741cd81253e194495319628c0da5d69486f4b2dfc SHA512 539158dce3f0120289859a01fdbda08257e7b32a5279ecd107cef3492ce3a36f5e4709c420b4a9abca7fd0ba270449d647c050d05d8272ec65d9ebcbd55da297
+DIST sirilic-V1.15.9.tar.bz2 146812 BLAKE2B 8701b35018abb6cc70761f29ab10ed99188def5b3db5b1728c75a682fec8d874a7a5d335ccd7ee097a25bd134e3307ee4bdd9bff050d4e5ab3459d65ad3f520f SHA512 12464c64660acd076e06ccb43b4eb285e4935eb9c483e841b29f5551710ddea1c3a30a98f32aff84809a8eaf860861db966fa04bc7e6c411c5a34ea9b8667786
diff --git a/sci-astronomy/sirilic/sirilic-1.15.9.ebuild b/sci-astronomy/sirilic/sirilic-1.15.9.ebuild
new file mode 100644
index 000000000000..dd5dcb825cc7
--- /dev/null
+++ b/sci-astronomy/sirilic/sirilic-1.15.9.ebuild
@@ -0,0 +1,23 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+inherit distutils-r1
+
+DESCRIPTION="Preparing acquisition files for processing with the SiriL software"
+HOMEPAGE="https://gitlab.com/free-astro/sirilic"
+SRC_URI="https://gitlab.com/free-astro/sirilic/-/archive/V${PV}/${PN}-V${PV}.tar.bz2"
+S="${WORKDIR}/${PN}-V${PV}"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ dev-python/requests[${PYTHON_USEDEP}]
+ >=dev-python/wxpython-4.2:4.0[${PYTHON_USEDEP}]
+"
+RDEPEND="${DEPEND}"