summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZero_Chaos <zerochaos@gentoo.org>2017-05-11 17:24:34 -0400
committerZero_Chaos <zerochaos@gentoo.org>2017-05-11 17:24:34 -0400
commitd35608850a2761df04267a501c7817134d7df4ca (patch)
tree90fc2a3756355a7a7a6679d7acb7385a0c9a5c73 /net-wireless/urh/urh-1.6.2.6.ebuild
parentnet-analyzer/metasploit: sure is nice when metasploit finally works (diff)
downloadgentoo-d35608850a2761df04267a501c7817134d7df4ca.tar.gz
gentoo-d35608850a2761df04267a501c7817134d7df4ca.tar.bz2
gentoo-d35608850a2761df04267a501c7817134d7df4ca.zip
net-wireless/urh: bump
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'net-wireless/urh/urh-1.6.2.6.ebuild')
-rw-r--r--net-wireless/urh/urh-1.6.2.6.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-wireless/urh/urh-1.6.2.6.ebuild b/net-wireless/urh/urh-1.6.2.6.ebuild
new file mode 100644
index 000000000000..ea9cce67800f
--- /dev/null
+++ b/net-wireless/urh/urh-1.6.2.6.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{3_4,3_5} )
+inherit distutils-r1 eutils
+
+DESCRIPTION="Universal Radio Hacker: investigate wireless protocols like a boss"
+HOMEPAGE="https://github.com/jopohl/urh"
+SRC_URI="https://github.com/jopohl/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="hackrf rtlsdr"
+
+DEPEND="${PYTHON_DEPS}
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/pyzmq[${PYTHON_USEDEP}]
+ hackrf? ( net-libs/libhackrf )
+ rtlsdr? ( net-wireless/rtl-sdr )"
+RDEPEND="${DEPEND}
+ dev-python/PyQt5[${PYTHON_USEDEP}]
+ net-wireless/gr-osmosdr"
+
+python_configure_all() {
+ mydistutilsargs=(
+ $(use_with hackrf)
+ $(use_with rtlsdr)
+ --without-airspy
+ --without-limesdr
+ )
+}