summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-wireless/cpyrit-opencl
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-wireless/cpyrit-opencl')
-rw-r--r--net-wireless/cpyrit-opencl/Manifest1
-rw-r--r--net-wireless/cpyrit-opencl/cpyrit-opencl-0.4.0-r1.ebuild30
-rw-r--r--net-wireless/cpyrit-opencl/cpyrit-opencl-0.4.0.ebuild27
-rw-r--r--net-wireless/cpyrit-opencl/metadata.xml13
4 files changed, 71 insertions, 0 deletions
diff --git a/net-wireless/cpyrit-opencl/Manifest b/net-wireless/cpyrit-opencl/Manifest
new file mode 100644
index 000000000000..8f18f47c2081
--- /dev/null
+++ b/net-wireless/cpyrit-opencl/Manifest
@@ -0,0 +1 @@
+DIST cpyrit-opencl-0.4.0.tar.gz 22851 SHA256 aac593bce3f00ea7fd3d558083dbd7e168332a92736e51a621a0459d1bc042fa SHA512 105c735089c23850f46fc349d4393bc038ca676ed9437545af7d23d98786e52a6ed88a09eeb9b7e2ef3654eaa71e0172a64478f8a37177714b3060ad3af49e5a WHIRLPOOL 522311339e52e10eac4bb724e31e9b277dd831c85ad011121ea3e251a1314afdef45f518b4b47d1ad542b5b65a0f5abbeed47c6379b329fcc72aeded221041fe
diff --git a/net-wireless/cpyrit-opencl/cpyrit-opencl-0.4.0-r1.ebuild b/net-wireless/cpyrit-opencl/cpyrit-opencl-0.4.0-r1.ebuild
new file mode 100644
index 000000000000..88f58edbca9b
--- /dev/null
+++ b/net-wireless/cpyrit-opencl/cpyrit-opencl-0.4.0-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+DISTUTILS_SINGLE_IMPL=1
+
+inherit distutils-r1
+
+DESCRIPTION="A sub-package that adds OpenCL-capability to Pyrit"
+HOMEPAGE="http://code.google.com/p/pyrit/"
+SRC_URI="http://pyrit.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-libs/openssl:=
+ sys-libs/zlib
+ virtual/opencl"
+RDEPEND="${DEPEND}"
+PDEPEND="~net-wireless/pyrit-${PV}"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
diff --git a/net-wireless/cpyrit-opencl/cpyrit-opencl-0.4.0.ebuild b/net-wireless/cpyrit-opencl/cpyrit-opencl-0.4.0.ebuild
new file mode 100644
index 000000000000..326be8e253f3
--- /dev/null
+++ b/net-wireless/cpyrit-opencl/cpyrit-opencl-0.4.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+PYTHON_DEPEND="2:2.5"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils eutils
+
+DESCRIPTION="A sub-package that adds OpenCL-capability to Pyrit"
+HOMEPAGE="http://code.google.com/p/pyrit/"
+SRC_URI="http://pyrit.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-libs/openssl
+ sys-libs/zlib
+ virtual/opencl"
+RDEPEND="${DEPEND}"
+PDEPEND="~net-wireless/pyrit-${PV}"
diff --git a/net-wireless/cpyrit-opencl/metadata.xml b/net-wireless/cpyrit-opencl/metadata.xml
new file mode 100644
index 000000000000..81f3a278efce
--- /dev/null
+++ b/net-wireless/cpyrit-opencl/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>proxy-maintainers</herd>
+<maintainer>
+ <email>oleg@kaa.org.ua</email>
+ <name>Oleg Kravchenko</name>
+</maintainer>
+<maintainer>
+ <email>maksbotan@gentoo.org</email>
+ <name>Maxim Koltsov</name>
+</maintainer>
+</pkgmetadata>