summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan-Espen Oversand <sigsegv@radiotube.org>2022-12-16 21:16:44 +0100
committerSam James <sam@gentoo.org>2022-12-16 22:57:10 +0000
commitc89929c39b281565db5dd4fd51c7c1509db976d6 (patch)
tree5f7ea6ee0c6a17abc21ed3f282f16d5423c91eca /net-vpn
parentapp-forensics/volatility3: use canonical function definition style (diff)
downloadgentoo-c89929c39b281565db5dd4fd51c7c1509db976d6.tar.gz
gentoo-c89929c39b281565db5dd4fd51c7c1509db976d6.tar.bz2
gentoo-c89929c39b281565db5dd4fd51c7c1509db976d6.zip
net-vpn/vtun: Fix bashism in shell script
Fix shell script compatibility issue in rc script (bashism). Closes: https://bugs.gentoo.org/849446 Signed-off-by: Jan-Espen Oversand <sigsegv@radiotube.org> Closes: https://github.com/gentoo/gentoo/pull/28682 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-vpn')
-rw-r--r--net-vpn/vtun/files/vtun.rc3
-rw-r--r--net-vpn/vtun/vtun-3.0.3-r4.ebuild (renamed from net-vpn/vtun/vtun-3.0.3-r3.ebuild)0
-rw-r--r--net-vpn/vtun/vtun-3.0.4-r2.ebuild (renamed from net-vpn/vtun/vtun-3.0.4-r1.ebuild)0
3 files changed, 2 insertions, 1 deletions
diff --git a/net-vpn/vtun/files/vtun.rc b/net-vpn/vtun/files/vtun.rc
index 7ef322985043..9d081eeb4f06 100644
--- a/net-vpn/vtun/files/vtun.rc
+++ b/net-vpn/vtun/files/vtun.rc
@@ -7,7 +7,8 @@ depend() {
}
start() {
- IFS=$'\n'
+ IFS=$(printf '\n.'); # Set separator (IFS) to <newline><dot>
+ IFS=${IFS%.}; # Remove <dot> - The <dot> was because shells remove trailing newlines with $(..)
for line in `grep -v '^[[:space:]]*#' /etc/vtund-start.conf | grep -v '^[[:space:]]*$'`
do
echo $line |
diff --git a/net-vpn/vtun/vtun-3.0.3-r3.ebuild b/net-vpn/vtun/vtun-3.0.3-r4.ebuild
index aeebc636d14f..aeebc636d14f 100644
--- a/net-vpn/vtun/vtun-3.0.3-r3.ebuild
+++ b/net-vpn/vtun/vtun-3.0.3-r4.ebuild
diff --git a/net-vpn/vtun/vtun-3.0.4-r1.ebuild b/net-vpn/vtun/vtun-3.0.4-r2.ebuild
index 800d5d0feb11..800d5d0feb11 100644
--- a/net-vpn/vtun/vtun-3.0.4-r1.ebuild
+++ b/net-vpn/vtun/vtun-3.0.4-r2.ebuild