summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-04-15 08:41:20 +0100
committerSam James <sam@gentoo.org>2024-04-15 08:41:20 +0100
commit6e604b1d706779f2a93bf349380d4531c5eede5a (patch)
tree823b7b055d295c07dc2f43cf036f4037b63ab838 /net-vpn/tor
parentnet-vpn/tor: add 0.4.8.11 (diff)
downloadgentoo-6e604b1d706779f2a93bf349380d4531c5eede5a.tar.gz
gentoo-6e604b1d706779f2a93bf349380d4531c5eede5a.tar.bz2
gentoo-6e604b1d706779f2a93bf349380d4531c5eede5a.zip
net-vpn/tor: skip known-broken sandbox tests on arm32
The seccomp support in Tor, just like seccomp in general, is known to be brittle and seccomp isn't enabled by default (bug #713690). It's therefore not a serious failure even if we'd like it to get fixed. Bug: https://bugs.gentoo.org/713690 Closes: https://bugs.gentoo.org/920905 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-vpn/tor')
-rw-r--r--net-vpn/tor/tor-0.4.7.16-r1.ebuild13
-rw-r--r--net-vpn/tor/tor-0.4.8.10.ebuild11
-rw-r--r--net-vpn/tor/tor-0.4.8.11.ebuild11
-rw-r--r--net-vpn/tor/tor-9999.ebuild13
4 files changed, 46 insertions, 2 deletions
diff --git a/net-vpn/tor/tor-0.4.7.16-r1.ebuild b/net-vpn/tor/tor-0.4.7.16-r1.ebuild
index 57d57b897505..35d6f8e5b028 100644
--- a/net-vpn/tor/tor-0.4.7.16-r1.ebuild
+++ b/net-vpn/tor/tor-0.4.7.16-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -144,6 +144,17 @@ src_test() {
:sandbox/openat_filename
)
+ if use arm ; then
+ skip_tests+=(
+ # bug #920905
+ # https://gitlab.torproject.org/tpo/core/tor/-/issues/40912
+ :sandbox/opendir_dirname
+ :sandbox/openat_filename
+ :sandbox/chmod_filename
+ :sandbox/rename_filename
+ )
+ fi
+
# The makefile runs these by parallel by chunking them with a script
# but that means we lose verbosity and can't skip individual tests easily
# either.
diff --git a/net-vpn/tor/tor-0.4.8.10.ebuild b/net-vpn/tor/tor-0.4.8.10.ebuild
index b57e148142a3..a7d8e3404faa 100644
--- a/net-vpn/tor/tor-0.4.8.10.ebuild
+++ b/net-vpn/tor/tor-0.4.8.10.ebuild
@@ -153,6 +153,17 @@ src_test() {
:sandbox/openat_filename
)
+ if use arm ; then
+ skip_tests+=(
+ # bug #920905
+ # https://gitlab.torproject.org/tpo/core/tor/-/issues/40912
+ :sandbox/opendir_dirname
+ :sandbox/openat_filename
+ :sandbox/chmod_filename
+ :sandbox/rename_filename
+ )
+ fi
+
# The makefile runs these by parallel by chunking them with a script
# but that means we lose verbosity and can't skip individual tests easily
# either.
diff --git a/net-vpn/tor/tor-0.4.8.11.ebuild b/net-vpn/tor/tor-0.4.8.11.ebuild
index 9d5a1b0e9d6e..7d9d0b0a91ee 100644
--- a/net-vpn/tor/tor-0.4.8.11.ebuild
+++ b/net-vpn/tor/tor-0.4.8.11.ebuild
@@ -153,6 +153,17 @@ src_test() {
:sandbox/openat_filename
)
+ if use arm ; then
+ skip_tests+=(
+ # bug #920905
+ # https://gitlab.torproject.org/tpo/core/tor/-/issues/40912
+ :sandbox/opendir_dirname
+ :sandbox/openat_filename
+ :sandbox/chmod_filename
+ :sandbox/rename_filename
+ )
+ fi
+
# The makefile runs these by parallel by chunking them with a script
# but that means we lose verbosity and can't skip individual tests easily
# either.
diff --git a/net-vpn/tor/tor-9999.ebuild b/net-vpn/tor/tor-9999.ebuild
index 009e202668a5..7d9d0b0a91ee 100644
--- a/net-vpn/tor/tor-9999.ebuild
+++ b/net-vpn/tor/tor-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -153,6 +153,17 @@ src_test() {
:sandbox/openat_filename
)
+ if use arm ; then
+ skip_tests+=(
+ # bug #920905
+ # https://gitlab.torproject.org/tpo/core/tor/-/issues/40912
+ :sandbox/opendir_dirname
+ :sandbox/openat_filename
+ :sandbox/chmod_filename
+ :sandbox/rename_filename
+ )
+ fi
+
# The makefile runs these by parallel by chunking them with a script
# but that means we lose verbosity and can't skip individual tests easily
# either.