summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-voip/homer
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-voip/homer')
-rw-r--r--net-voip/homer/Manifest3
-rw-r--r--net-voip/homer/files/homer-0.24.1-libav-9.patch101
-rw-r--r--net-voip/homer/files/homer-0.25-ffmpeg-avstream.patch24
-rw-r--r--net-voip/homer/homer-0.24.1-r1.ebuild67
-rw-r--r--net-voip/homer/homer-0.25-r1.ebuild80
-rw-r--r--net-voip/homer/homer-9999.ebuild73
-rw-r--r--net-voip/homer/metadata.xml14
7 files changed, 362 insertions, 0 deletions
diff --git a/net-voip/homer/Manifest b/net-voip/homer/Manifest
new file mode 100644
index 000000000000..2cae7746d133
--- /dev/null
+++ b/net-voip/homer/Manifest
@@ -0,0 +1,3 @@
+DIST homer-0.24.1.tar.gz 1297045 SHA256 738cd4a1e8b437936c904bdea649c0ee12ecca2caa1bef5c585925eabe84ff44 SHA512 ea2d1a5224048668e20a62f142370910f337b3b56b94c9a92a9b7530652ceed67a59223fac57ee0d835c31545d2d06c21329a0463680936d32a1455dbb2fac33 WHIRLPOOL b16ccdea6c5ea0845aca4f31a2d6258cf6a71258c531ee36a02b2844814df73b26229ffc96129532b4f9c1f2070a9cd279b720b7286e691e488bc7b524c47278
+DIST homer-0.25-ffmpeg2.patch 65617 SHA256 ce1327a59dc20c2fbe23e968786ecce21126cdb2119916bf2227594dc8c0a229 SHA512 fb4ca0bd161c94999b54b86337220f3f018672e4a5031788d8292273515fe68d4364574645d96e04b19bdb64f1b032119503cf823c7604d625015ba0cdabf030 WHIRLPOOL 909069e830b9ef473a006f686a5e5e9f7279c5b0fc8fb8f212a30b767106055970441fa4fdbe2d443fce500024bc00494c112ebb3b95a65a475b2731e8d361c7
+DIST homer-0.25.tar.gz 1404242 SHA256 1c3e67a7f7134a317bc32dfb691679a2997fbfa129c70d5d165ccfd0272a752d SHA512 92254f9cc133589760a4c3081e1636232ace8eb972f7800c4fb5aaeba52e22546c6772e4c93625aa31a5d7b366f441cf8155f52d85ca44dade60edebf98b6340 WHIRLPOOL 944277b8248a1037dd27881456b6fb304d19d2f12cc7bc4268ba3dbf876de668fde25749dfbfd424950fe641d7dc65f5f14a29e9d14d5c1e738dc555af201ffe
diff --git a/net-voip/homer/files/homer-0.24.1-libav-9.patch b/net-voip/homer/files/homer-0.24.1-libav-9.patch
new file mode 100644
index 000000000000..985145e06540
--- /dev/null
+++ b/net-voip/homer/files/homer-0.24.1-libav-9.patch
@@ -0,0 +1,101 @@
+--- HomerMultimedia/include/Header_Ffmpeg.h
++++ HomerMultimedia/include/Header_Ffmpeg.h
+@@ -173,4 +173,16 @@
+ #endif
+ }
+
++inline AVStream *HM_avformat_new_stream(AVFormatContext *s, int id)
++{
++ #if LIBAVCODEC_VERSION_INT < AV_VERSION_INT(53, 10, 0)
++ return av_new_stream(s, c);
++ #else
++ AVStream *st = avformat_new_stream(s, NULL);
++ if (st)
++ st->id = id;
++ return st;
++ #endif
++}
++
+ #endif
+--- HomerMultimedia/src/MediaSource.cpp
++++ HomerMultimedia/src/MediaSource.cpp
+@@ -236,11 +236,19 @@
+ {
+ if (tCodec->type == AVMEDIA_TYPE_VIDEO)
+ {
++ #ifndef FF_API_OLD_ENCODE_AUDIO
+ bool tEncode = (tCodec->encode != NULL);
++ #else
++ bool tEncode = (tCodec->encode2 != NULL);
++ #endif
+ bool tDecode = (tCodec->decode != NULL);
+ if ((tNextCodec != NULL) && (strcmp(tCodec->name, tNextCodec->name) == 0))
+ {
++ #ifndef FF_API_OLD_ENCODE_AUDIO
+ tEncode |= (tNextCodec->encode != NULL);
++ #else
++ tEncode |= (tNextCodec->encode2 != NULL);
++ #endif
+ tDecode |= (tNextCodec->decode != NULL);
+ tCodec = tNextCodec;
+ }
+@@ -296,11 +304,19 @@
+ // tNextCodec->encode ? "E" : " ",
+ // tNextCodec->name,
+ // tNextCodec->long_name ? tCodec->long_name : "");
++ #ifndef FF_API_OLD_ENCODE_AUDIO
+ bool tEncode = (tCodec->encode != NULL);
++ #else
++ bool tEncode = (tCodec->encode2 != NULL);
++ #endif
+ bool tDecode = (tCodec->decode != NULL);
+ if ((tNextCodec != NULL) && (strcmp(tCodec->name, tNextCodec->name) == 0))
+ {
++ #ifndef FF_API_OLD_ENCODE_AUDIO
+ tEncode |= (tNextCodec->encode != NULL);
++ #else
++ tEncode |= (tNextCodec->encode2 != NULL);
++ #endif
+ tDecode |= (tNextCodec->decode != NULL);
+ tCodec = tNextCodec;
+ }
+@@ -1622,7 +1638,7 @@
+ sprintf(mRecorderFormatContext->filename, "%s", pSaveFileName.c_str());
+
+ // allocate new stream structure
+- tStream = av_new_stream(mRecorderFormatContext, 0);
++ tStream = HM_avformat_new_stream(mRecorderFormatContext, 0);
+ mRecorderCodecContext = tStream->codec;
+
+ // put sample parameters
+--- HomerMultimedia/src/MediaSourceMuxer.cpp
++++ HomerMultimedia/src/MediaSourceMuxer.cpp
+@@ -377,7 +377,7 @@
+
+ // allocate new stream structure
+ LOG(LOG_VERBOSE, "..allocating new stream");
+- tStream = av_new_stream(mFormatContext, 0);
++ tStream = HM_avformat_new_stream(mFormatContext, 0);
+ mCodecContext = tStream->codec;
+ mCodecContext->codec_id = tFormat->video_codec;
+ mCodecContext->codec_type = AVMEDIA_TYPE_VIDEO;
+@@ -710,7 +710,7 @@
+ }
+
+ // allocate new stream structure
+- tStream = av_new_stream(mFormatContext, 0);
++ tStream = HM_avformat_new_stream(mFormatContext, 0);
+ mCodecContext = tStream->codec;
+ mCodecContext->codec_id = tFormat->audio_codec;
+ mCodecContext->codec_type = AVMEDIA_TYPE_AUDIO;
+--- HomerMultimedia/src/RTP.cpp
++++ HomerMultimedia/src/RTP.cpp
+@@ -512,7 +512,7 @@
+ // verbose timestamp debugging mRtpFormatContext->debug = FF_FDEBUG_TS;
+
+ // allocate new stream structure
+- tOuterStream = av_new_stream(mRtpFormatContext, 0);//(AVStream*)av_mallocz(sizeof(AVStream));
++ tOuterStream = HM_avformat_new_stream(mRtpFormatContext, 0);//(AVStream*)av_mallocz(sizeof(AVStream));
+ if (tOuterStream == NULL)
+ {
+ LOG(LOG_ERROR, "Memory allocation failed");
diff --git a/net-voip/homer/files/homer-0.25-ffmpeg-avstream.patch b/net-voip/homer/files/homer-0.25-ffmpeg-avstream.patch
new file mode 100644
index 000000000000..d60f5696cbac
--- /dev/null
+++ b/net-voip/homer/files/homer-0.25-ffmpeg-avstream.patch
@@ -0,0 +1,24 @@
+From 31136f8df53d4d528acb3b301271d4b19274dfc6 Mon Sep 17 00:00:00 2001
+From: ThomasVolkert <thomas@homer-conferencing.com>
+Date: Sat, 7 Jun 2014 13:31:51 +0200
+Subject: [PATCH] - fixed: ffmpeg compatibility
+
+---
+ HomerMultimedia/src/RTP.cpp | 4 +++-
+ 1 file changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/HomerMultimedia/src/RTP.cpp b/HomerMultimedia/src/RTP.cpp
+index ad4d04b..97b631b 100644
+--- a/HomerMultimedia/src/RTP.cpp
++++ b/HomerMultimedia/src/RTP.cpp
+@@ -611,7 +611,9 @@ bool RTP::OpenRtpEncoder(string pTargetHost, unsigned int pTargetPort, AVStream
+ mRtpEncoderStream->priv_data = NULL;
+ // create monotone timestamps
+ mRtpEncoderStream->cur_dts = 0;
+- mRtpEncoderStream->reference_dts = 0;
++ #ifndef FF_API_REFERENCE_DTS
++ mRtpEncoderStream->reference_dts = 0;
++ #endif
+
+ // set target coordinates for rtp stream
+ snprintf(mRtpFormatContext->filename, sizeof(mRtpFormatContext->filename), "rtp://%s:%u", pTargetHost.c_str(), pTargetPort);
diff --git a/net-voip/homer/homer-0.24.1-r1.ebuild b/net-voip/homer/homer-0.24.1-r1.ebuild
new file mode 100644
index 000000000000..e5c5fb9e9820
--- /dev/null
+++ b/net-voip/homer/homer-0.24.1-r1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="Homer Conferencing (short: Homer) is a free SIP softphone with advanced audio and video support"
+HOMEPAGE="http://www.homer-conferencing.com"
+
+MY_PN="Homer-Conferencing"
+MY_BIN="Homer"
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-2
+ EGIT_REPO_URI="git://github.com/${MY_PN}/${MY_PN}.git"
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/${MY_PN}/${MY_PN}/archive/V${PV}.tar.gz -> ${PN}-${PV}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND=">=dev-libs/openssl-1.0
+ media-libs/alsa-lib
+ media-libs/libsdl[X,sound,video,alsa]
+ media-libs/portaudio[alsa]
+ media-libs/sdl-mixer
+ media-libs/sdl-sound
+ media-libs/x264:*
+ net-libs/sofia-sip
+ virtual/ffmpeg:0[X]
+ || ( <media-video/ffmpeg-2 media-video/libav )
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ dev-qt/qtmultimedia:4
+ dev-qt/qtwebkit:4"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-libav-9.patch"
+}
+
+src_compile() {
+ tc-export CXX
+ emake -C HomerBuild default \
+ INSTALL_PREFIX=/usr/bin \
+ INSTALL_LIBDIR=/usr/$(get_libdir) \
+ INSTALL_DATADIR=/usr/share/${PN} \
+ VERBOSE=1
+}
+
+src_install() {
+ emake -C HomerBuild install \
+ DESTDIR="${D}" \
+ VERBOSE=1
+
+ # Create .desktop entry
+ doicon ${MY_BIN}/${MY_BIN}.png
+ make_desktop_entry "${MY_BIN}" "${MY_PN}" "${MY_BIN}" "Network;InstantMessaging;Telephony;VideoConference"
+}
diff --git a/net-voip/homer/homer-0.25-r1.ebuild b/net-voip/homer/homer-0.25-r1.ebuild
new file mode 100644
index 000000000000..84172c754207
--- /dev/null
+++ b/net-voip/homer/homer-0.25-r1.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="Homer Conferencing (short: Homer) is a free SIP softphone with advanced audio and video support"
+HOMEPAGE="http://www.homer-conferencing.com"
+
+MY_PN="Homer-Conferencing"
+MY_BIN="Homer"
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-2
+ EGIT_REPO_URI="git://github.com/${MY_PN}/${MY_PN}.git"
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/${MY_PN}/${MY_PN}/archive/V${PV}.tar.gz -> ${PN}-${PV}.tar.gz
+ http://dev.gentoo.org/~hwoarang/distfiles/${P}-ffmpeg2.patch"
+ KEYWORDS="amd64 x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="pulseaudio"
+
+DEPEND="dev-util/cmake
+ >=dev-libs/openssl-1.0
+ media-libs/alsa-lib
+ media-libs/libsdl[X,sound,video,alsa]
+ media-libs/portaudio[alsa]
+ media-libs/sdl-mixer
+ media-libs/sdl-sound
+ media-libs/x264:*
+ media-video/ffmpeg:0[X]
+ net-libs/sofia-sip
+ dev-qt/qtcore:4
+ dev-qt/qtdbus:4
+ dev-qt/qtgui:4
+ dev-qt/qtmultimedia:4
+ dev-qt/qtwebkit:4
+ pulseaudio? ( media-sound/pulseaudio )"
+
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_prepare() {
+ epatch "${DISTDIR}/${P}-ffmpeg2.patch"
+ # Bug #543138
+ sed -e '/mRtpEncoderStream->reference_dts = 0;/d' \
+ -i HomerMultimedia/src/RTP.cpp || die
+
+ if use pulseaudio; then
+ sed -i \
+ -e "/^set(FEATURE_PULSEAUDIO/s:OFF:ON:" \
+ HomerBuild/config/HomerFeatures.txt || die "sed failed"
+ fi
+}
+
+src_compile() {
+ tc-export CXX
+ emake -C HomerBuild default \
+ INSTALL_PREFIX=/usr/bin \
+ INSTALL_LIBDIR=/usr/$(get_libdir) \
+ INSTALL_DATADIR=/usr/share/${PN} \
+ VERBOSE=1
+}
+
+src_install() {
+ emake -C HomerBuild install \
+ DESTDIR="${D}" \
+ VERBOSE=1
+
+ # Create .desktop entry
+ doicon ${MY_BIN}/${MY_BIN}.png
+ make_desktop_entry "${MY_BIN}" "${MY_PN}" "${MY_BIN}" "Network;InstantMessaging;Telephony;VideoConference"
+}
diff --git a/net-voip/homer/homer-9999.ebuild b/net-voip/homer/homer-9999.ebuild
new file mode 100644
index 000000000000..a6e7bb65d423
--- /dev/null
+++ b/net-voip/homer/homer-9999.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="Homer Conferencing (short: Homer) is a free SIP softphone with advanced audio and video support"
+HOMEPAGE="http://www.homer-conferencing.com"
+
+MY_PN="Homer-Conferencing"
+MY_BIN="Homer"
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-2
+ EGIT_REPO_URI="git://github.com/${MY_PN}/${MY_PN}.git"
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/${MY_PN}/${MY_PN}/archive/V${PV}.tar.gz -> ${PN}-${PV}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="pulseaudio"
+
+DEPEND=">=dev-libs/openssl-1.0
+ media-libs/alsa-lib
+ media-libs/libsdl[X,sound,video,alsa]
+ media-libs/portaudio[alsa]
+ media-libs/sdl-mixer
+ media-libs/sdl-sound
+ media-libs/x264:*
+ media-video/ffmpeg:0[X]
+ net-libs/sofia-sip
+ dev-qt/qtcore:4
+ dev-qt/qtdbus:4
+ dev-qt/qtgui:4
+ dev-qt/qtmultimedia:4
+ dev-qt/qtwebkit:4
+ pulseaudio? ( media-sound/pulseaudio )"
+
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_prepare() {
+ if use pulseaudio; then
+ sed -i \
+ -e "/^set(FEATURE_PULSEAUDIO/s:OFF:ON:" \
+ HomerBuild/config/HomerFeatures.txt || die "sed failed"
+ fi
+}
+
+src_compile() {
+ tc-export CXX
+ emake -C HomerBuild default \
+ INSTALL_PREFIX=/usr/bin \
+ INSTALL_LIBDIR=/usr/$(get_libdir) \
+ INSTALL_DATADIR=/usr/share/${PN} \
+ VERBOSE=1
+}
+
+src_install() {
+ emake -C HomerBuild install \
+ DESTDIR="${D}" \
+ VERBOSE=1
+
+ # Create .desktop entry
+ doicon ${MY_BIN}/${MY_BIN}.png
+ make_desktop_entry "${MY_BIN}" "${MY_PN}" "${MY_BIN}" "Network;InstantMessaging;Telephony;VideoConference"
+}
diff --git a/net-voip/homer/metadata.xml b/net-voip/homer/metadata.xml
new file mode 100644
index 000000000000..aff5964a4a5b
--- /dev/null
+++ b/net-voip/homer/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>gentoo@pennewiss.de</email>
+ <name>Marcel Pennewiß</name>
+ </maintainer>
+ <longdescription lang="en">
+</longdescription>
+ <upstream>
+ <remote-id type="github">Homer-Conferencing/Homer-Conferencing</remote-id>
+ </upstream>
+</pkgmetadata>