summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2023-09-15 13:03:37 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2023-09-19 20:48:17 +0300
commitc1d8e6aa12868bb1339a6d567508b00ec4a65126 (patch)
tree17001bd10c978d6461bb97e932d677d93ff669cb /net-p2p
parentmedia-sound/zynaddsubfx: fix VariableShadowed (diff)
downloadgentoo-c1d8e6aa12868bb1339a6d567508b00ec4a65126.tar.gz
gentoo-c1d8e6aa12868bb1339a6d567508b00ec4a65126.tar.bz2
gentoo-c1d8e6aa12868bb1339a6d567508b00ec4a65126.zip
net-p2p/nicotine+: fix VariableShadowed
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/nicotine+/nicotine+-3.2.8.ebuild21
-rw-r--r--net-p2p/nicotine+/nicotine+-3.2.9-r1.ebuild21
-rw-r--r--net-p2p/nicotine+/nicotine+-3.2.9.ebuild21
3 files changed, 12 insertions, 51 deletions
diff --git a/net-p2p/nicotine+/nicotine+-3.2.8.ebuild b/net-p2p/nicotine+/nicotine+-3.2.8.ebuild
index 2bd3906ae371..7218a610b793 100644
--- a/net-p2p/nicotine+/nicotine+-3.2.8.ebuild
+++ b/net-p2p/nicotine+/nicotine+-3.2.8.ebuild
@@ -3,41 +3,28 @@
EAPI=8
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..11} )
DISTUTILS_USE_PEP517=setuptools
-inherit distutils-r1 xdg-utils
+inherit distutils-r1 xdg
DESCRIPTION="A fork of nicotine, a Soulseek client in Python"
HOMEPAGE="https://github.com/Nicotine-Plus/nicotine-plus"
SRC_URI="https://github.com/Nicotine-Plus/nicotine-plus/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/nicotine-plus-${PV}"
LICENSE="GPL-3 LGPL-3"
SLOT="0"
KEYWORDS="amd64 ppc x86"
-IUSE=""
-DEPEND="${PYTHON_DEPS}"
-RDEPEND="
+RDEPEND="${PYTHON_DEPS}
dev-python/pygobject:3[${PYTHON_USEDEP}]
x11-libs/gtk+:3[introspection]
- ${DEPEND}
"
-
DEPEND="${RDEPEND}"
-S="${WORKDIR}/nicotine-plus-${PV}"
-
EPYTEST_IGNORE=(
"test/integration/test_startup.py"
)
distutils_enable_tests pytest
-
-pkg_postinst() {
- xdg_icon_cache_update
-}
-
-pkg_postrm() {
- xdg_icon_cache_update
-}
diff --git a/net-p2p/nicotine+/nicotine+-3.2.9-r1.ebuild b/net-p2p/nicotine+/nicotine+-3.2.9-r1.ebuild
index bbf1e8854cf3..e890276cd355 100644
--- a/net-p2p/nicotine+/nicotine+-3.2.9-r1.ebuild
+++ b/net-p2p/nicotine+/nicotine+-3.2.9-r1.ebuild
@@ -3,42 +3,29 @@
EAPI=8
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..11} )
PYTHON_REQ_USE="gdbm"
DISTUTILS_USE_PEP517=setuptools
-inherit distutils-r1 xdg-utils
+inherit distutils-r1 xdg
DESCRIPTION="A fork of nicotine, a Soulseek client in Python"
HOMEPAGE="https://github.com/Nicotine-Plus/nicotine-plus"
SRC_URI="https://github.com/Nicotine-Plus/nicotine-plus/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/nicotine-plus-${PV}"
LICENSE="GPL-3 LGPL-3"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
-IUSE=""
-DEPEND="${PYTHON_DEPS}"
-RDEPEND="
+RDEPEND="${PYTHON_DEPS}
dev-python/pygobject:3[${PYTHON_USEDEP}]
x11-libs/gtk+:3[introspection]
- ${DEPEND}
"
-
DEPEND="${RDEPEND}"
-S="${WORKDIR}/nicotine-plus-${PV}"
-
EPYTEST_IGNORE=(
"test/integration/test_startup.py"
)
distutils_enable_tests pytest
-
-pkg_postinst() {
- xdg_icon_cache_update
-}
-
-pkg_postrm() {
- xdg_icon_cache_update
-}
diff --git a/net-p2p/nicotine+/nicotine+-3.2.9.ebuild b/net-p2p/nicotine+/nicotine+-3.2.9.ebuild
index 2bd3906ae371..7218a610b793 100644
--- a/net-p2p/nicotine+/nicotine+-3.2.9.ebuild
+++ b/net-p2p/nicotine+/nicotine+-3.2.9.ebuild
@@ -3,41 +3,28 @@
EAPI=8
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..11} )
DISTUTILS_USE_PEP517=setuptools
-inherit distutils-r1 xdg-utils
+inherit distutils-r1 xdg
DESCRIPTION="A fork of nicotine, a Soulseek client in Python"
HOMEPAGE="https://github.com/Nicotine-Plus/nicotine-plus"
SRC_URI="https://github.com/Nicotine-Plus/nicotine-plus/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/nicotine-plus-${PV}"
LICENSE="GPL-3 LGPL-3"
SLOT="0"
KEYWORDS="amd64 ppc x86"
-IUSE=""
-DEPEND="${PYTHON_DEPS}"
-RDEPEND="
+RDEPEND="${PYTHON_DEPS}
dev-python/pygobject:3[${PYTHON_USEDEP}]
x11-libs/gtk+:3[introspection]
- ${DEPEND}
"
-
DEPEND="${RDEPEND}"
-S="${WORKDIR}/nicotine-plus-${PV}"
-
EPYTEST_IGNORE=(
"test/integration/test_startup.py"
)
distutils_enable_tests pytest
-
-pkg_postinst() {
- xdg_icon_cache_update
-}
-
-pkg_postrm() {
- xdg_icon_cache_update
-}