summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2024-10-03 07:46:35 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2024-10-26 09:35:55 +0200
commit7ba75258ec7d09a15fc4f3d1b9a95d5907f4fe7b (patch)
tree38e57b884fdccdea0c6ca4310efabdda8490dbf0 /net-p2p
parentnet-analyzer/zabbix: dropped obsolete (diff)
downloadgentoo-7ba75258ec7d09a15fc4f3d1b9a95d5907f4fe7b.tar.gz
gentoo-7ba75258ec7d09a15fc4f3d1b9a95d5907f4fe7b.tar.bz2
gentoo-7ba75258ec7d09a15fc4f3d1b9a95d5907f4fe7b.zip
net-p2p/biglybt: add 3.7.0.0
Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Closes: https://github.com/gentoo/gentoo/pull/38836/commits/79cc1a45d9e4e2e9eea26cb3b827e232a44da487 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/biglybt/Manifest1
-rw-r--r--net-p2p/biglybt/biglybt-3.7.0.0.ebuild108
2 files changed, 109 insertions, 0 deletions
diff --git a/net-p2p/biglybt/Manifest b/net-p2p/biglybt/Manifest
index 10e4eca27534..010a27d92500 100644
--- a/net-p2p/biglybt/Manifest
+++ b/net-p2p/biglybt/Manifest
@@ -1 +1,2 @@
DIST biglybt-3.6.0.0.tar.gz 43972902 BLAKE2B 76995d3d5f24f054690e609d2be7bd822f6c8573b6627bcf380c3a93be86265f4ca827c2991db65ef39c9f3f79b0cd8e0aebce492571a36bf237c95fc3d6cc54 SHA512 b56beb006ab813efa2ab2aff8563a04675e677ea70fe6ef72062e2d38ec753749b36740ae87f851739cb1389948a916273cb6ffb65758e651d0701a7f6237afd
+DIST biglybt-3.7.0.0.tar.gz 44021778 BLAKE2B 9ce54062b298d2e47f9fcc88a3fa8da935c7d3c4ad24f28cf2975300b78140b547e3e43c377cae50fd1276d49d53a43bc77e36957133dc6fe1fa7e301ebe80fe SHA512 815ce2f2b327de266650d9650dcbc539247dca2a8bce727ca0a4fc6eb7dfbcee770ffce04dd3b96aef458df1ee20ce39229f6a3d409725a532d081c82d4504bd
diff --git a/net-p2p/biglybt/biglybt-3.7.0.0.ebuild b/net-p2p/biglybt/biglybt-3.7.0.0.ebuild
new file mode 100644
index 000000000000..78bc7fda2552
--- /dev/null
+++ b/net-p2p/biglybt/biglybt-3.7.0.0.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# javadocs are too broken and no tests, #839681
+JAVA_PKG_IUSE="source"
+MAVEN_PROVIDES="com.${PN}:${PN}-core:${PV} com.${PN}:${PN}-ui:${PV}"
+
+inherit desktop java-pkg-2 java-pkg-simple optfeature xdg
+
+DESCRIPTION="Feature-filled Bittorrent client based on the Azureus open source project"
+HOMEPAGE="https://www.biglybt.com"
+SRC_URI="https://github.com/BiglySoftware/BiglyBT/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/BiglyBT-${PV}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64"
+
+CP_DEPEND="
+ dev-java/commons-cli:0
+ dev-java/swt:4.27[cairo]
+"
+
+# Due to removal of AENameServiceDescriptor it would fail to start under jdk:1.8
+# StartServer ERROR: unable to bind to 127.0.0.1:6880 listening for passed torrent info: \
+# sun.net.spi.nameservice.NameServiceDescriptor: Provider com.biglybt.core.util.spi.AENameServiceDescriptor not found
+DEPEND="${CP_DEPEND}
+ >=virtual/jdk-11:*"
+
+RDEPEND="${CP_DEPEND}
+ >=virtual/jre-1.8:*"
+
+DOCS=(
+ CODING_GUIDELINES.md
+ CONTRIBUTING.md
+ ChangeLog.txt
+ README.md
+ TRANSLATE.md
+)
+
+JAVA_GENTOO_CLASSPATH_EXTRA="target/classes"
+JAVA_JAR_FILENAME="BiglyBT.jar"
+JAVA_MAIN_CLASS="com.${PN}.ui.Main"
+JAVA_RESOURCE_DIRS=( {core,uis}/resources ) # yes, need them both
+JAVA_SRC_DIR="uis/src"
+
+PATCHES=(
+ "${FILESDIR}/biglybt-3.2.0.0-disable-SWTUpdateChecker.patch"
+ "${FILESDIR}/biglybt-3.2.0.0-disable-shared-plugins.patch"
+ "${FILESDIR}/biglybt-3.5.0.0-Entities.javadoc.patch"
+ "${FILESDIR}/biglybt-3.6.0.0-disable-PluginUpdatePlugin.patch"
+ "${FILESDIR}/biglybt-3.6.0.0-fix-ambiguous.patch"
+)
+
+src_prepare() {
+ default #780585
+ java-pkg-2_src_prepare
+ # AENameServiceDescriptor fails to compile with jdk >= 11
+ # "error: package sun.net.spi.nameservice does not exist"
+ # https://github.com/BiglySoftware/BiglyBT/pull/2611
+ rm -r core/src/com/biglybt/core/util/spi || die
+
+ # java-pkg-simple.eclass expects resources in a separate directory.
+ cp -r core/{src,resources} || die
+ rm -r core/resources/META-INF || die "deleting META-INF"
+ find core/resources -type f -name '*.java' -exec rm -rf {} + || die "core deleting *.java"
+ find core/resources -type f -name '.editorconfig' -exec rm -rf {} + || die "deleting .editorconfig"
+
+ cp -r uis/{src,resources} || die
+ find uis/resources -type f -name '*.java' -exec rm -rf {} + || die "uis deleting *.java"
+}
+
+src_compile() {
+ # build core classes, needed for compiling uis
+ ejavac -d target/classes \
+ -cp "$(java-pkg_getjars commons-cli):$(java-pkg_getjars swt-4.27)" \
+ $(find core/src -name "*.java") || die
+
+ java-pkg-simple_src_compile
+
+ # uis/src/com/biglybt/ui/swt/plugin/net/buddy/swt/BuddyPluginView.java:68:
+ # uis/src/com/biglybt/ui/swt/plugin/net/buddy/swt/BuddyPluginViewChat.java:45:
+ # uis/src/com/biglybt/ui/swt/plugin/net/buddy/swt/BuddyPluginViewInstance.java:75:
+ # error: package com.biglybt.ui.swt.plugin.net.buddy does not exist
+# use doc && JAVA_SRC_DIR=( {core,uis}/src ) ejavadoc
+}
+
+src_install() {
+ java-pkg-simple_src_install
+
+ make_desktop_entry "${PN}" BiglyBT "${PN}" "Network;FileTransfer"
+
+ if use source; then
+ java-pkg_dosrc "core/src/*"
+ java-pkg_dosrc "uis/src/*"
+ fi
+ default
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ optfeature_header "If you are using plugin proxies you might want to swap them for these native packages:"
+ optfeature "I2P SOCKS proxy" net-vpn/i2p net-vpn/i2pd
+ optfeature "TOR SOCKS proxy" net-vpn/tor
+}