summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Roman <davidroman96@gmail.com>2024-09-08 20:56:05 +0200
committerEli Schwartz <eschwartz@gentoo.org>2024-09-08 20:15:49 -0400
commit5aeff90072bfac4d49a518f0ef65d4c53b67dcae (patch)
tree07ecd4309ce39cfa4df6e64dd9b009b3f22cb3bc /net-p2p
parentnet-irc/kvirc: stop forcing emake (diff)
downloadgentoo-5aeff90072bfac4d49a518f0ef65d4c53b67dcae.tar.gz
gentoo-5aeff90072bfac4d49a518f0ef65d4c53b67dcae.tar.bz2
gentoo-5aeff90072bfac4d49a518f0ef65d4c53b67dcae.zip
net-p2p/kubo: add fs-repo-migrations
Bug: https://bugs.gentoo.org/930853 Signed-off-by: David Roman <davidroman96@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/38525 Signed-off-by: Eli Schwartz <eschwartz@gentoo.org>
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/kubo/Manifest2
-rw-r--r--net-p2p/kubo/kubo-0.29.0-r1.ebuild91
2 files changed, 93 insertions, 0 deletions
diff --git a/net-p2p/kubo/Manifest b/net-p2p/kubo/Manifest
index 0e82d8139fd9..11c2e71fc440 100644
--- a/net-p2p/kubo/Manifest
+++ b/net-p2p/kubo/Manifest
@@ -1,3 +1,5 @@
DIST kubo-0.26.0.tar.gz 16129891 BLAKE2B 199e3fb3d7982eb3bca35c7139a15f4c4f32a54bde2c9ae2e5b594524668d146296001ccfb29d1ded5eec0e82a02b4e16a4bbb7a82bcc4787ee06820f02d4687 SHA512 21bcfd605d0aa0b55afafa5c717b6b0f8c657722a207ae0cb901815b7881266ae528acc85d74e70f5fafec9407c68cd5dcb2e02ab9fbe61c05f648888e15e0e5
DIST kubo-0.28.0.tar.gz 16070929 BLAKE2B f0febdee1e2313c83369c07b520fe285e10a73322d87f3891dd8edc97d6fa3d8dab7644d6108d060ef652fe34ed7cacf75f756e48f1e022d16b12bc30d298c0b SHA512 e6ef309084b8f09b56e5bceae37cf220c7e015003a8660f132d4e79709c7bd29ae8d8bb02736dab6a447b3acccc7dd0bd7043955df0a787a72fb3b9dfe9c42f5
+DIST kubo-0.29.0-fs-repo-15-to-16-v1.0.1-vendor.tar.xz 1643384 BLAKE2B 6c51d34ab06e662213075cdc73fce0d3dad8c9acbfd2af6cd68ee50e90c33b91f06a68bbe40f4f3de867dd2862fb3cc0a09cb377f4d1ae70750906236059de5d SHA512 f3d9fbfc93fa714491eb7b8c995b686b8af86a65c56e7f14034b0dedb36b2b9a4d489852d7988acce30dcfd53f1637e1dca42ffdaa785bc6104864fc19c45a0c
+DIST kubo-0.29.0-fs-repo-15-to-16-v1.0.1.tar.gz 25942003 BLAKE2B 48eb3f50c8d0064561a99dd834cfc73482003bed70be93342bb30e993b509cca6aea0d44658ea981bb1063c458ce98e796293172b01109265e431f7a6ae279ae SHA512 bf631d402ecbee75e5a49e19e31c40172aeef81a13325bbf557841ba9e765caf39df42370a20d6e4039e7bd98e27dc5bd7a42f4490f30928a5614aca2214aea1
DIST kubo-0.29.0.tar.gz 16229764 BLAKE2B 91a6d322987bf7316f4acaf984ea57ea69617925e56adf4cee06be4d08a3a77f8f197aed42aa16cd438485df657de02cd647d3319c7c1afd09c0b8410fab30e6 SHA512 f23496452c3382629fddafce039acdff51c085280b15b807923bc4474b3ec540a39f9906ba7dcba621fef6237336ee2eb1bed10f81cac7a1dfccb21b7c3fecfb
diff --git a/net-p2p/kubo/kubo-0.29.0-r1.ebuild b/net-p2p/kubo/kubo-0.29.0-r1.ebuild
new file mode 100644
index 000000000000..3f83dfd5962a
--- /dev/null
+++ b/net-p2p/kubo/kubo-0.29.0-r1.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module shell-completion systemd
+
+FS_MIG_V="1.0.1"
+FS_MIG_N="fs-repo-15-to-16"
+MY_FS_MIG="${FS_MIG_N}-v${FS_MIG_V}"
+FS_MIG_DIR="fs-repo-migrations-${MY_FS_MIG}"
+
+DESCRIPTION="Main implementation of IPFS"
+HOMEPAGE="https://ipfs.tech https://github.com/ipfs/kubo/"
+SRC_URI="https://github.com/ipfs/${PN}/releases/download/v${PV}/kubo-source.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://github.com/ipfs/fs-repo-migrations/archive/refs/tags/${FS_MIG_N}/v${FS_MIG_V}.tar.gz -> ${P}-${MY_FS_MIG}.tar.gz"
+SRC_URI+=" https://gentoo.kropotkin.rocks/go-pkgs/${MY_FS_MIG}-vendor.tar.xz -> ${P}-${MY_FS_MIG}-vendor.tar.xz"
+
+S="${WORKDIR}"
+
+LICENSE="Apache-2.0 BSD BSD-2 CC0-1.0 ISC MIT MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ acct-group/ipfs
+ acct-user/ipfs
+ sys-fs/fuse:0
+"
+RDEPEND="${DEPEND}"
+
+DOCS=( CHANGELOG.md CONTRIBUTING.md README.md docs/ )
+
+src_prepare() {
+ default
+
+ sed -i '/fs-repo-1[0-9]-to-*/d' "${FS_MIG_DIR}/ignored-migrations" || die
+}
+
+src_compile() {
+ local mygoargs
+ mygoargs=(
+ -tags release
+ )
+
+ ego build "${mygoargs[@]}" -o ipfs ./cmd/ipfs
+ ego build "${mygoargs[@]}" -o ipfswatch ./cmd/ipfswatch
+
+ IPFS_PATH="" ./ipfs commands completion bash > ipfs-completion.bash || die
+ IPFS_PATH="" ./ipfs commands completion fish > ipfs-completion.fish || die
+ IPFS_PATH="" ./ipfs commands completion zsh > ipfs-completion.zsh || die
+
+ cd "${FS_MIG_DIR}" || die
+ emake
+}
+
+src_test() {
+ ego test ./cmd/ipfs/... ./cmd/ipfswatch/...
+}
+
+src_install() {
+ dobin ipfs
+ dobin ipfswatch
+ newbashcomp ipfs-completion.bash ipfs
+ newfishcomp ipfs-completion.fish ipfs
+ newzshcomp ipfs-completion.zsh _ipfs
+ einstalldocs
+
+ systemd_dounit "${FILESDIR}/ipfs.service"
+ systemd_newunit "${FILESDIR}/ipfs-at.service" "ipfs@.service"
+
+ newinitd "${FILESDIR}/ipfs.init" ipfs
+ newconfd "${FILESDIR}/ipfs.confd" ipfs
+
+ keepdir /var/log/ipfs
+ fowners -R ipfs:ipfs /var/log/ipfs
+
+ dobin "${FS_MIG_DIR}/fs-repo-migrations/fs-repo-migrations"
+ find "${FS_MIG_DIR}" -executable -type f -name "fs-repo-*" -exec dobin {} \; || die
+}
+
+pkg_postinst() {
+ elog 'To be able to use the ipfs service you will need to create the ipfs repository'
+ elog '(eg: su -s /bin/sh -c "ipfs init -e" ipfs)'
+ elog 'or change IPFS_PATH of /etc/conf.d/ipfs with another with proper permissions.'
+
+ # See https://bugs.gentoo.org/838238
+ ewarn 'In case kubo CPU usage is too high run the next workaround'
+ ewarn 'su -s /bin/sh -c "ipfs config profile apply lowpower" ipfs'
+ ewarn 'Be aware that this will make your node less visible to other peers'
+}